Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec and Linuxshield

Created: 13 Sep 2013 • Updated: 13 Sep 2013 | 4 comments

I am using Backup Exec to back up my RedHat Linux file server.  On this file server I have LinuxShield 1.9 running with on access scanning set to scan only files that are being written.  On access scanning is off for read.  When backup exec runs every file it checks gets scanned by linuxshield.  This happens even with Incremental Backups when files being checked for changes and not being dumped to tape.  Is there any way to configure the ralus agent to not have linuxshield scan every files while the backups are running?  

Operating Systems:

Comments 4 CommentsJump to latest comment

pkh's picture

This question should be put to the LinuxShield vendor.  BE is unaware of any AV.  Normally, scanning a file being backed up is a setting in the AV software.

Colin Weaver's picture

Not sure if this is possible with the operating system and your AV/security products, but they often have a way to not scan depending on the process that triggers the file request. 

i..e. on a Windows server set the AV product to not scan any file activity made by beremote.exe. If you can do do this with LinuxShield against the process for RALUS (which is potentially also beremote but without the .exe) then that would probably solve it.

Scott_USAP's picture

I did post this question on McAfee community site and got no response.  I'm in a little bit of a bind because I am working with inoperability issus between two competing vendors products (Symantec and McAfee) and the technical support folks are pointing at each other's products as being the issue.  McAfee says "You exclude reading of files from being scanned, so BE is the issue."  One last question - if the process beremote is writing files while checking for file modifications the file system, is there a way to have it use a specific location to write the temporary files to?  This way I could exclude that directory from being scanned (which is an easy setting in LinuxShield).  I'm going back to McAfee with the "exclude files accessed by beremote" question to see if they can assist with that.

Colin Weaver's picture

Just to add something in the mix, It might be neither product that is causing the issue, it may be the way the file system on the volume is reacting to both products.

Unfortunately there are not many things you can change

On the BE side - if you are using the open file technology that is part of the new version of RALUS then maybe disable that/turn it off

On the McAfee side look at exculsion based on accessing process instead of file location and/or some kind of time based 'disable' window' that you can perhaps set for whilst the backup is running.