Video Screencast Help

Backup Exec creating temp folders

Created: 03 Aug 2011 | 8 comments

Anyone else noticed the following files popping up on their storage devices:

"G:\TEMP\Backup Exec\ese.dll"

It's created today and is on both our B2D and deduplication drive.

Cheers, Rob.

Discussion Filed Under:

Comments 8 CommentsJump to latest comment

Gurvinder Rait's picture

It might have been created if you are running Exchange GRT Backups

robnicholson's picture

We are indeed running Exchange GRT backups but I've just added a new drive to the media server that's not actually used for anything yet and voila Temp folder appeared at root. Why is Exchange GRT writing this folder\file to all local drives?

Cheers, Rob.

sbora's picture

Can you please exclude the G:\Temp\Backup Exec folder from Anti Virus scan and check if it helps? Also does it allows you to delete the files manually?

What is the location of B2D folder? Is it on the G drive?

I am assuming that you are talking about G drive of Backup Exec server.

robnicholson's picture

We don't have anti-virus running on the media server (BE is slow enough thanks wink).

Drives in system:

  • C: operating system and apps
  • E: what's left of disk 1 after creating 50GB partition for C: (not used)
  • F: Deduplication folder
  • G: Backup-to-disk folder
  • H: Spare drive but Temp folder appeared here as well

Cheers, Rob.

Gurvinder Rait's picture

GRT backup uses a temp location while performing GRT processing. This temp location is on Exchange server when the backup is to tape and on Backup Exec server when the backup is going to disk. By default the backup job choses the volume which has highest amount of free space

Not sure why it got created at both those locations

You can make the following key to restrict and make sure it uses one drive

NOTE: Registry change is required on the Backup Exec server if backup is going to disk and on the Exchange server if the backups are going to tape)

 

  • Click Start -> Run and type"regedit".  ClickOK.
  • Within the Registry Editor, navigate to HKLM\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange

 

  • Right click and add a new String Value, "OnHostTemp".

 

  • Right click and set the value ofOnHostTemp to"c:\temp". (or any other path that you want)

 

  • Restart all the Backup Exec service on Media server and Backup Exec Remote Agent service on the Exchange Server.



 

  • Run the backup job of Exchange Resources from media server
robnicholson's picture

I haven't had chance to try this yet but I've raised a job in our internal job system.

Cheers, Rob.

robnicholson's picture

I've made this reg change but need to wait for a window to restart BE as it's busy at the moment.

Cheers, Rob.

temp reg change.png
sbora's picture

Check if WmiPrvSe.exe has an open handle on ese.dll in the Temp directory as mentioned in the technote below:

http://www.symantec.com/docs/TECH172067