Video Screencast Help

Backup Exec Exchange 2010

Created: 09 Oct 2012 | 8 comments

Hi,

We currently use Backup Exec 2010 R3 and have started using Exchange GRT backups to our Exchange 2010 DAG environment. We have successfully proven that 6 databases backup successfully using GRT on full & incremental backups, but 2 of the databases on the same DAG fail each time with error:

V-79-57344-65233 - AOFO: Initialization failure on: "\\Exchange Server\Microsoft Information Store\Databasename". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS). Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status. Check the Windows Event Viewer for details. Writer Name: Exchange Server, Writer ID: {76FE1AC4-15F7-4BCD-987E-8E1ACB462FB7}, Last error: The VSS Writer failed, but the operation can be retried (0x800423f3), State: Failed during freeze operation (9).

Coincidentally these 2 databases are the largest databases, so not sure if there is a size limitation on backup exec?

After searching around I have disabled AOFO on the backups, but they still fail with the above error. The vssadmin list writers show all as "no error" except:

Writer name: 'Microsoft Exchange Writer'
   Writer Id: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}
   Writer Instance Id: {c1e27919-8f18-4f8b-abd5-d2ad068dada6}
   State: [9] Failed
   Last error: Retryable error

Given that 6 of the 8 databases backup successfully, and the server has just been restarted, and the Backup exec agent uninstalled & reinstalled, I'm a bit lost.

Does anyone have any ideas on what to try next?

Kind Regards

Comments 8 CommentsJump to latest comment

CraigV's picture

Hi,

That remaining VSS issue can still cause issues.

Symantec updated their VSS troubleshooting document which you can check on the link below:

http://www.symantec.com/business/support/index?page=content&id=TECH173983

THanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Donald Eady's picture

Techy, 

 

       When you restarted the 2 servers in questions did you run the vssadmin list writers command again to verify that the writers had been restored to a State1 stable state?

I hope this posting was helpful

  

lmosla's picture

Hi

Have all the live updates been installed and pushed out to your servers? note: this may require a reboot.

Also, is there any Exchange Maintenance running at the same time as the backups?

One more thing to check is for errors at the time of the backups in the Window event logs for the servers in question.

 

 

Techy2012's picture

Thanks for all of your replies on this. I must admit I was a litle confused as to why 6 databases would work, but 2 large ones wouldn't on the dame DAG. So I decided to try a backup of just those databases using Copy Databases & Logs with no flush, as I suspected possible log corruption (these 2 DBs are around 70GB in size currently, the others are around 2GB).

The backup failed with:

Final error: 0xe000032d - The consistency check of the snapshot for the Microsoft Exchange transaction log has failed. You should check for possible data corruption in the transaction log that is online. Final error category: Resource Errors For additional information regarding this error refer to link V-79-57344-813

Having looked through this error it looks like we may have corrupt logs, and/or require an update to Exchange 2010 SP1 Rollup 6.

Coincidentally, the copy has worked and I am able to restore user's mail items as of the date of this backup.

Any addiitonal thoughts bsaed on this new info?

Kind Regards

lmosla's picture

Are these backups backing up the active or passive copy?

Jaydeep S's picture

When backup exec performs a full or log backup of exchange, it will pass a command to truncate commited logs. Now if there is a coruption in the logs, ESE will not be able to do this successfuly and return an error.

Look in the event viewer fo any events regarding ESE. These issues will need to b addressed to fix the logs corruption. Once tisis fixed the backups should work as well.

Altnatively, you could attempt to perform a full backup of the database, without the consistency check from BE. However, if the database and logs are not consistent at the time of backups, the restore also may not work properly.

Techy2012's picture

We were a few liveupdates out of date (ironically it wasn't updating due to SEP) but since the upgrade the Exchange job gets a bit further. Now that it's getting further I can see in the event viewer that there are 2 log files causing problems, 1 corrupt/damaged & 1 missing. So I'll look at repairing this database then running the backup again.

Thanks for your help.

lmosla's picture

Good to hear that the installing all the liveupdates helped identify the problem.

Hope your backups run smoothly after repairing the database.