Video Screencast Help

Backup Exec Linux RALUS Remote Agent

Created: 31 Oct 2007 • Updated: 21 May 2010 | 5 comments

I am having trouble getting my Linux server to show up on the Backup Exec Selection List. I installed the RALUS agent on the Linux server and it installed fine. However, it doesn’t show up in the Favorite Selections, or any where else on the selection list. I have looked at the log output using “/opt/VRTSralus/bin/beremote --log-console” and I see that it reports success when advertising to the media server. I can ping the media server,
and I can telnet from both machines to port 10000.

I am running Backup Exec 11d Small Business on Windows 2003 Small Business Server with all updates and service packs. The agent is installed on Fedora Core 6.

Any help would be greatly appreciated!

- Dan

 



Message Edited by Knorr Marketing on 10-31-2007 11:30 AM

Comments 5 CommentsJump to latest comment

MitchR's picture
I'm fighting the same problem as we speak.  My current theory is that there's a separate license (and this license key) for Linux clients - and until you install that license key, the server can't see Linux boxes at all.
 
Stay tuned...
 

Mark this post as the solution, and have good luck for 7 years.
Forget to mark this as the solution, and tomorrow your server will crash.

Ben L.'s picture

The agent is installed on Fedora Core 6.

Please check the Software Compatibility List for a list of supported Linux/Unix operating systems.

http://support.veritas.com/docs/286600

Symantec Backup Exec 11d (11.0) for Windows Servers - Software Compatibility List (SCL)


If this response answers your concern, please mark it as a "solution"

MitchR's picture
My hunch was right - if you haven't already purchased a licnese for the Unix/Linux agent (or running on a 60-day demo), you can't even see the server, nor any of the options for that agent.
 
We are now able to see the server, but we can't see anything on the server.  We're thinking it's a rights issue, but no luck yet.  Again, stay tuned.
 
Just getting a stupid backup shouldn't be this hard....
 
 

Mark this post as the solution, and have good luck for 7 years.
Forget to mark this as the solution, and tomorrow your server will crash.

mcknigrf's picture

What did the solution turn out to be?  I have the license key for the agents, but still can't see them when trying to setup the job.

DarkElf's picture

My situation is a bit different: I was able to backup Linux clients for sometime but suddenly failed with the following error, while backups for local files and files on remote Windows servers still work:

 

Final error: 0xe0009418 - Access to a device was not authorized with this edition of Backup Exec.

Clicking the link led to an irrelevant case of the KB: http://support.veritas.com/docs/257059

Telling something about license for SQL agent.

 In addition, when I try to browse selection for the Linux client, the following error message appeared:

"An error was encountered while attempting to browse the contents of backup_exec_client. An unknown error occurred within the NDMP subsystem"

 

I added license for Linux agent later, but still not working.

 

About recent changes to the server, it would be the activation of 2nd NIC on it.  

 

Here is some output from ./beremote --log-console:

 

47108bf0 Thu Aug 28 10:01:41 2008 : Starting BE Remote Agent
47108bf0 Thu Aug 28 10:01:41 2008 : Requested no generation of log file
47108bf0 Thu Aug 28 10:01:41 2008 : No configuration file specified.  Using default.
47108bf0 Thu Aug 28 10:01:41 2008 : Log to console: enabled
47108bf0 Thu Aug 28 10:01:41 2008 : Successfully set the supplementary groups of the process
47108bf0 Thu Aug 28 10:01:41 2008 : Initialized locks for SSL callbacks
47108bf0 Thu Aug 28 10:01:41 2008 : Starting NDMP processor
47108bf0 Thu Aug 28 10:01:41 2008 : NDMPDMainThreadFunc spawned: grpid=1, tid=1111808320
4244d940 Thu Aug 28 10:01:41 2008 : FS_InitFileSys
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsnt5.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedssql2.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsxchg.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsxese.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsmbox.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedspush.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsnote.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsmdoc.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedssps2.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedssps3.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsupfs.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsshadow.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsoffhost.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   loaded libbedsvx.so
4244d940 Thu Aug 28 10:01:41 2008 :   loaded libbedsrman.so
4244d940 Thu Aug 28 10:01:41 2008 :   loaded libbedssms.so
4244d940 Thu Aug 28 10:01:41 2008 :   loaded libbedssmsp.so
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsra.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   libbedsdb2.so could not be loaded: 0x       2 (2)
4244d940 Thu Aug 28 10:01:41 2008 :   loaded libbedsedir.so
4244d940 Thu Aug 28 10:01:41 2008 : Initializing FSs
4244d940 Thu Aug 28 10:01:41 2008 : FS 1 failed to initialize: 0xE000FE46
4244d940 Thu Aug 28 10:01:41 2008 : Function called: RMAN_InitFileSys
4244d940 Thu Aug 28 10:01:41 2008 : Using 'UTF-8' Encoding.
4244d940 Thu Aug 28 10:01:41 2008 :      VXMS Initialization OK.
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <ext3> mounted at </>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <proc> mounted at </proc>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <sysfs> mounted at </sys>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <devpts> mounted at </dev/pts>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <ext3> mounted at </boot>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <tmpfs> mounted at </dev/shm>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <binfmt_misc> mounted at </proc/sys/fs/binfmt_misc>
4244d940 Thu Aug 28 10:01:41 2008 : Detected Mounted Filesystem: type <rpc_pipefs> mounted at </var/lib/nfs/rpc_pipefs>
4244d940 Thu Aug 28 10:01:41 2008 : Successfully resolved the "ndmp" service to port: 6101 (host order)
4244d940 Thu Aug 28 10:01:41 2008 : @@@@@@@MyCloseSocket called with sockfd = 5(0x5)    retval = 0
4244d940 Thu Aug 28 10:01:41 2008 : @@@@@@@MyCloseSocket called with sockfd = 6(0x6)    retval = 0
4244d940 Thu Aug 28 10:01:41 2008 : @@@@@@@MyCloseSocket called with sockfd = 7(0x7)    retval = 0
4244d940 Thu Aug 28 10:01:41 2008 : BETCPListener::BETCPListener: This system appears to be a Dual IP system
4244d940 Thu Aug 28 10:01:41 2008 : BETCPListener::BETCPListener: Successfully set the IPV6_V6ONLY option, this listener may behave as Dual Stack listener
4244d940 Thu Aug 28 10:01:41 2008 : BETCPListener::Bind: Could not bind to port 6101 on IPv6, An error occurred during a socket bind operation: Error Code: 98, System Error Message: Address already in use
4244d940 Thu Aug 28 10:01:41 2008 : @@@@@@@MyCloseSocket called with sockfd = 4(0x4)    retval = 0
4244d940 Thu Aug 28 10:01:41 2008 : BETCPListener::Bind: Could not bind to port 6101 on IPv4, An error occurred during a socket bind operation: Error Code: 98, System Error Message: Address already in use
4244d940 Thu Aug 28 10:01:41 2008 : @@@@@@@MyCloseSocket called with sockfd = 3(0x3)    retval = 0
4244d940 Thu Aug 28 10:01:41 2008 : Could not start NDMP Listener on port 6101: An error occurred during a socket creation operation: Error Code: 98, System Error Message: Address already in use
4244d940 Thu Aug 28 10:01:41 2008 : ndmpRun: exiting
47108bf0 Thu Aug 28 10:01:46 2008 : Stopping remote agent due to explicitly failed initialization
47108bf0 Thu Aug 28 10:01:51 2008 : Startup failure detected
47108bf0 Thu Aug 28 10:01:51 2008 : Remote agent exiting, cancelling 3 joinable threads
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: advertisement cycle started.
4149f940 Thu Aug 28 10:01:51 2008 : RMAN_EnumSelfDLE: AgentConfig GetOracleDBNames returned error. If Oracle Agent is installed, please run AgentConfig.
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: EnumSelfDLE for file system 14 returned 0(0x0) and 0 DLEs
40a9e940 Thu Aug 28 10:01:51 2008 : time to exit thread
4149f940 Thu Aug 28 10:01:51 2008 : BENetConfigEx: Successfully refreshed adapter information.
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: EnumSelfDLE for file system 22 returned 0(0x0) and 1 DLEs
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: Nrds Message Len : 243.
4149f940 Thu Aug 28 10:01:51 2008 : VX_RemoveDLE: DestroyDLE()
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: failed to send to media_server even after 10 attempts
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: failed to send to  even after 10 attempts
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: advertisement cycle complete.  Waiting 240 minutes before advertising again.
4149f940 Thu Aug 28 10:01:51 2008 : NrdsAdvertiserThread: exiting
42e4e940 Thu Aug 28 10:01:56 2008 : NrdsAdvertiserThread: exiting
47108bf0 Thu Aug 28 10:01:56 2008 :   unloading libbedssms.so
47108bf0 Thu Aug 28 10:01:56 2008 :   unloading libbedssmsp.so
47108bf0 Thu Aug 28 10:01:56 2008 :   unloading libbedsrman.so
47108bf0 Thu Aug 28 10:01:56 2008 :   unloading libbedsvx.so
47108bf0 Thu Aug 28 10:01:56 2008 :   unloading libbedsedir.so

 

 Any help is appreciated.

 

Thanks in advance.

Message Edited by DarkElf on 08-27-2008 07:52 PM