Video Screencast Help

'Backup Exec Remote Agent' terminates unexpectedly

Created: 04 Jan 2013 • Updated: 30 Jan 2013 | 14 comments
This issue has been solved. See solution.

This is the information that appears in the Application log of the event viewer.

Log Name:           Application
Source:                Application Error
Date:                    29/12/2012 5:38:44 PM
Event ID:              1000
Task Category:     (100)
Level:                   Error
Keywords:            Classic
User:                    N/A
Computer:           SQLServer
Faulting application beremote.exe, version 12.5.2213.144, time stamp 0x4a6f92dd, faulting module bedssql2.dll, version 12.5.2213.133, time stamp 0x49c7f283, exception code 0xc0000005, fault offset 0x000000000003e927, process id 0x48c, application start time 0x01cde1f83afed0e7.

Comments 14 CommentsJump to latest comment

CraigV's picture


Couple of things you can try:

1. Uninstalling the RAWS agent and reinstalling it via push-install from the media server.

2. Making sure no AV is scanning/blocking beremote.exe, and if so, put in an exclusion for it.

3. Making sure that the media server is fully patched & that these patches have been push-installed to any remote servers you might have.


Alternative ways to access Backup Exec Technical Support:

Gurvinder Rait's picture

When do you get this. During a backup/browse of the SQL Server. Is the crash random. When did the Issue start occuring. Were there any changes done to the setup (any patches etc.). Also  try the above steps, if you still get a failure please upload a beremote dump and remote agent debug from the above system which is seing the crash.

generate dump :

debug (media server and sql server) -  open regedit

HKey_Local_Machine\Software\Symantec\Backup Exec for Windows\Backup Exec\Engine\Logging

Set CreateDebugLog to 1 (the debug logs will be created in raws install path\logs)

RaviAAG's picture

CraigV & Gurvinder, thank you very much for your responses. I have attempted to re-install RAWS via push-install from the media server, but it keeps failing. Attached is a copy of the log file. In the log file, there is a warning that indicates I don't have write access to the Program Files directory of the target server, but I have verified that this is not true; the domain administrator account I am using does in fact have the necessary permissions.

The crash is not random and it occurs anytime I try to do a backup, which is every Saturday. This problem first occured on October 27, 2012. No changes were done to the target server or the media server to create this problem.

install_log.txt 6.56 KB
Gurvinder Rait's picture

Check if system has full control. Also are you able to Install raws locally (copying the raws folder and installing it manually on the sql server)

01-08-2013,11:49:27 : The current user does not have write access to the C:\Program Files directory. 
01-08-2013,11:49:27 : The install could not verify that the user has rights to required install folders.

Regarding the crash will need the crash dump to check what may be causing the problem

CraigV's picture

You can try this:

1. If there is an AV on the server in question, turn it off & try again.

2. try running BE with elevated privileges. Right-click the executable (Desktop/Start Menu) and choose Run As...


Alternative ways to access Backup Exec Technical Support:

RaviAAG's picture

1. The AV on the server & firewall have been disabled.

2. Running Backup Exec with elevated privileges does not make a difference.

CraigV's picture


1. If you run a manual backup using the same job does it crash?

2. Have you tried to uninstall the RAWS agent and install it again using a different domain admin account?


Alternative ways to access Backup Exec Technical Support:

RaviAAG's picture

1. If I run a manual backup, the job succeeds.

2. I have tried with another user account, but I have the same problem.

CraigV's picture

...if it runs manually, then create a new selection list and stand-alone job for testing purposes. Once done, schedule that for 15 minutes time for instance, and let it run automatically.

If it succeeds, it points to some sort of corruption in either the selection list or job. In which case just transition to this.


Alternative ways to access Backup Exec Technical Support:

pkh's picture

What is the version of SQL that you are using?  You did not specify whether you are using BE 12 or BE 12.5.  Check the appropriate SCL's below to ensure that your version of SQL is supported.

BE 12.5 Software (SCL)

BE 12.0 Software (SCL)

RaviAAG's picture

Gurvinder - The System account and domain administrator account has full control of the directory. I was able to install RAWS locally without any issues. How does installing it locally affect the BE software rather than doing a push install? I have attached the beremote dump as well as media server & SQL server remote agent debug.

pkh - I am running Microsoft SQL Server 2008 (10.0.4067) and Symantec Backup Exec v12.5. I have verified that the version of SQL I am running is supported.

Craig - I will get back to you within 90 minutes regarding the status.

beremote dump.7z 75.66 MB
MediaServer Remote Agent Debug.7z 4.38 KB
SQLServer Remote Agent Debug.7z 54.56 KB
Gurvinder Rait's picture

10.0.4067 ? Do you have SP2 on SQL 2008 

12.5 SCL only has support for 32/64 bit SQL 2008 (does not mention about SP1 or SP2)

Please refer the SCL -

And this is the error you are getting on all the databases. Seem we are unable to handle this and crash.

[12184] 01/09/13 10:49:08 SQL2_StartCommand = BACKUP DATABASE [AAG_MAXIMIZER] TO VIRTUAL_DEVICE='BE_SQLAgent-AAG_MAXIMIZER__673add83_b711_4462_a20b_0dccde30219f_' WITH name='Backup Exec SQL Server Agent', SNAPSHOT
[4228] 01/09/13 10:49:29 SQL2: PrepareForFreeze: SQL command failed before VD transfer
I would recommend an upgrade to 2010 R3 and see if this works there.
RaviAAG's picture

Hi Craig,

Sorry for the late response. I do have a workaround in place for now - I am now doing the SQL server backup separately from the other system backups and I am not experiencing any issues at the moment, however, this workaround is not ideal since I would like to be doing the SQL server backup & other system backups together in one backup job.


RaviAAG's picture

Hi Gurvinder,

The workaround we have in place (backup the SQL databases in a separate job from the rest) is working fine for now.

This issue is now resolved for the time being despite no solution being found. Eventually we will be upgrading to the latest version of Symantec Backup Exec.