Video Screencast Help

Backup Exec Services will not start. An internal error (10) occurred in object 13

Created: 17 Apr 2013 • Updated: 17 Apr 2013 | 6 comments
This issue has been solved. See solution.

Been noticing the past couple of days that our backups have not been completing. Logging into the server and then into Backup Exec 2012, I find that I am unable to connect to the Backup Exec Server. Some of the services have stopped, including Backup Exec Server. 

An attempt to enter a username and password to connect to the server yields:

 

Could not connect to net.tcp://nkaddbackup:50104/BEMService/ServerData. The connection attempt lasted for a time span of 00:00:04.0291402. TCP error code 10061: No connection could be made becuase the target machine actively refused it 10.1.0.36:50104

 

I then jump over to event viewer and see the follow, generic message:

 

The Backup Exec Server Service did not start.  An internal error (10) occurred in object 13.
 
There have been a few posts related to a registry key and a bad path to the installation directory, my registry keys all seem to go to the right space. No firewalls are turned off and Symantec Endpoint Protection was disabled.
 
Any thoughts on this?

 

Operating Systems:

Comments 6 CommentsJump to latest comment

VJware's picture

Open cmd & browse to the Backup Exec directory.

Run the following command & pls post the output here ~

beserver.exe -console

Lastly, is Backup Exec updated with atleast SP1a ?

clay.beyer's picture

I did run the latest LiveUpdate, and I believe it was sometime last week. If SP1a was included in that LiveUpdate, then yes, BackupExec is updated. I cannot login to it or get it running at the moment to verify the version... is there a command I can run on command line?

Below is the output of beserver.exe -console

 

 

C:\Program Files\Symantec\Backup Exec>beserver.exe -console
[3996] 04/17/13 09:16:38 -1 Starting beserver console application
[5416] 04/17/13 09:16:38 -1 Starting Service: BackupExecRPCService
[5416] 04/17/13 09:16:38 -1 Entered RpcXfaceServiceMain.
[5416] 04/17/13 09:16:38 -1 Sending start status to scm. (hint 300000)..
[5416] 04/17/13 09:16:38 -1 SetServiceStatus: state: SERVICE_START_PENDING check point: 1 wait hint: 300000
[5416] 04/17/13 09:16:38 -1 Checking service rights and pending reboots.
[5416] 04/17/13 09:16:38 -1 Checking for pending install reboot.
[5416] 04/17/13 09:16:38 -1     Pending install reboot not detected.
[5416] 04/17/13 09:16:38 -1 Checking to see if start up checks have been disabled.
[5416] 04/17/13 09:16:38 -1 No start up checks have been disabled.
[5416] 04/17/13 09:16:38 -1 Opening process token.
[5416] 04/17/13 09:16:38 -1 Getting token SID.
[5416] 04/17/13 09:16:38 -1 Got current SID: 'S-1-5-21-1644491937-261478967-725345543-500'.
[5416] 04/17/13 09:16:38 -1 Checking for local system account.
[5416] 04/17/13 09:16:38 -1 Got local system SID: 'S-1-5-18'.
[5416] 04/17/13 09:16:38 -1 Not running as local system account.
[5416] 04/17/13 09:16:38 -1 Checking for admin privileges.
[5416] 04/17/13 09:16:38 -1     Current user does have admin privileges.
[5416] 04/17/13 09:16:38 -1 Checking for specific required rights.
[5416] 04/17/13 09:16:38 -1     Checking for 'Backup Files and Directories' privilege.
[5416] 04/17/13 09:16:38 -1             LookupPrivilegeValue( ) found privilege.
[5416] 04/17/13 09:16:38 -1             Privilege is enabled.
[5416] 04/17/13 09:16:38 -1     Checking for 'Restore Files and Directories' privilege.
[5416] 04/17/13 09:16:38 -1             LookupPrivilegeValue( ) found privilege.
[5416] 04/17/13 09:16:38 -1             Privilege is enabled.
[5416] 04/17/13 09:16:38 -1     Checking for 'Create a Token Object' privilege.
[5416] 04/17/13 09:16:38 -1             LookupPrivilegeValue( ) found privilege.
[5416] 04/17/13 09:16:38 -1             Privilege is enabled.
[5416] 04/17/13 09:16:38 -1     Checking for 'Manage Auditing and Security Log' privilege.
[5416] 04/17/13 09:16:38 -1             LookupPrivilegeValue( ) found privilege.
[5416] 04/17/13 09:16:38 -1             Privilege is enabled.
[5416] 04/17/13 09:16:38 -1     Checking for 'Take ownership of files and other objects' privilege.
[5416] 04/17/13 09:16:38 -1             LookupPrivilegeValue( ) found privilege.
[5416] 04/17/13 09:16:38 -1             Privilege is enabled.
[5416] 04/17/13 09:16:38 -1     Not checking for 'Act as part of the operating system' privilege as it is not needed for this environment.
[5416] 04/17/13 09:16:38 -1 Initializing ACE...
[5416] 04/17/13 09:16:38 -1 Cblmanger, shutdown Immenient: started.
[5416] 04/17/13 09:16:38 -1 Cblmanger, shutdown Immenient: complete.
[5416] 04/17/13 09:16:38 -1 Cblmanger, check shutdown Ready: started.
[5416] 04/17/13 09:16:38 -1 Cblmanger, check shutdown ready: complete.
[5416] 04/17/13 09:16:39 -1 Last Virtual Name registry key:
[5416] 04/17/13 09:16:39 -1 Initializing work queue...
[5416] 04/17/13 09:16:39 -1 Read from Registry: DBTimeoutInSec=30 ServerInternal=0x0
[5416] 04/17/13 09:16:40 -1 Server Connection String = Application Name=BEWS Server;Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=BEDB;Da
ta Source=NKADDBACKUP\BkupExec;Locale Identifier=1033;
[5416] 04/17/13 09:16:40 -1 Initializing Persistent Store (NKADDBACKUP\BkupExec, BEDB, Backup Exec Server, 30 seconds)...
[5416] 04/17/13 09:16:40 -1 Attempt to GetMyPartition ComputerName=NKADDBACKUP PartitionID=0 PartitionGUID=AAFB8E04-A150-4707-8F56-CFD1484E34FC
[5416] 04/17/13 09:16:40 -1 InitializePartition() Data partition ID from registry=0
[5416] 04/17/13 09:16:40 -1 GetMyPartition() Data partition to use for 'NKADDBACKUP' is 0
[5416] 04/17/13 09:16:40 -1 InitializePartition() returning 0x0
[5416] 04/17/13 09:16:40 -1 Successfully GetMyPartition ComputerName=NKADDBACKUP PartitionID=0 PartitionGUID=AAFB8E04-A150-4707-8F56-CFD1484E34FC OldComputerName=NKADDBACKUP
[5416] 04/17/13 09:16:40 -1 InitializePartition() ok, partitionID=0, oldComputerName=NKADDBACKUP
[5416] 04/17/13 09:16:40 -1 Creating Business Objects...
[5416] 04/17/13 09:16:40 00 VSN BO Initialization succeeded.
[5416] 04/17/13 09:16:40 -1 Server Configuration: Getting network configuration...
[5416] 04/17/13 09:16:40 -1 ServerName:NKADDBACKUP, ActiveNodeName:,InstanceName:BkupExec, DatabaseName:BEDB.
[5416] 04/17/13 09:16:40 01 Server Configuration: BEServer schema version checks OK.
[5416] 04/17/13 09:16:40 01 Server Configuration: Check eval option expiration workitem added.
[5416] 04/17/13 09:16:40 01 CServerConfigBO::GetFIPSVersionInfo() BECryptoGetCryptoLibraryVersionText()=OpenSSL FIPS 1.1.2
[5416] 04/17/13 09:16:40 01 Server Configuration - First start on upgrade: 0
[5416] 04/17/13 09:16:40 01 Server Configuration: Initialization Complete.
[5416] 04/17/13 09:16:40 02 Ownership: Initialization Complete.
[5416] 04/17/13 09:16:40 03 JobManBO: starting initialization...
[5416] 04/17/13 09:16:40 03 JobManBO: initialization complete...
[5416] 04/17/13 09:16:40 04 CAuditLogBO::Initialize(), Dumping AuditConfiguration cache
[5416] 04/17/13 09:16:40 04 Audit BO ID=0, SubCat=1, Enabled=1, Configuration=0x3
[5416] 04/17/13 09:16:40 04 Audit BO ID=1, SubCat=1, Enabled=1, Configuration=0x7
[5416] 04/17/13 09:16:40 04 Audit BO ID=2, SubCat=1, Enabled=1, Configuration=0x7
[5416] 04/17/13 09:16:40 04 Audit BO ID=3, SubCat=1, Enabled=1, Configuration=0xfcfff
[5416] 04/17/13 09:16:40 04 Audit BO ID=4, SubCat=1, Enabled=1, Configuration=0x77ff
[5416] 04/17/13 09:16:40 04 Audit BO ID=5, SubCat=1, Enabled=1, Configuration=0x7f
[5416] 04/17/13 09:16:40 04 Audit BO ID=6, SubCat=1, Enabled=1, Configuration=0x3ff
[5416] 04/17/13 09:16:40 04 Audit BO ID=7, SubCat=1, Enabled=1, Configuration=0x1ff
[5416] 04/17/13 09:16:40 04 Audit BO ID=7, SubCat=2, Enabled=1, Configuration=0x3f
[5416] 04/17/13 09:16:40 04 Audit BO ID=7, SubCat=3, Enabled=1, Configuration=0xff
[5416] 04/17/13 09:16:40 04 Audit BO ID=7, SubCat=4, Enabled=1, Configuration=0xfff
[5416] 04/17/13 09:16:40 04 Audit BO ID=8, SubCat=1, Enabled=1, Configuration=0x3fffff
[5416] 04/17/13 09:16:40 04 Audit BO ID=9, SubCat=1, Enabled=1, Configuration=0x7
[5416] 04/17/13 09:16:40 04 Audit BO ID=10, SubCat=1, Enabled=1, Configuration=0x3fffff
[5416] 04/17/13 09:16:40 04 Audit BO ID=12, SubCat=1, Enabled=1, Configuration=0x7
[5416] 04/17/13 09:16:40 04 CAuditLogBO: Initialization completed.
[5416] 04/17/13 09:16:40 05 AdammAdminBO: Initialization Start.
[5416] 04/17/13 09:16:40 05 CAdammAdminBO: Current runtime for daily non-DB maintenance is set to : 04/18/2013 04:00:00.
[5416] 04/17/13 09:16:40 05 CAdammAdminBO: Non-DB maintenace runtime (UTC): 04/18/2013 08:00:00, (local): 04/18/2013 04:00:00
[5416] 04/17/13 09:16:40 05 AdammAdminBO: Initialization Complete.
[5416] 04/17/13 09:16:40 -1 LoginAccount: Initialization Started. BO=6.
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Update() - Parent = NULL , Entity = CREDENTIAL_ENTITY
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - Parent = NULL , Entity = DEVICE
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - hr = 0x0
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Update() - Parent = NULL , Entity = CREDENTIAL_ENTITY
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - Parent = NULL , Entity = DEVICE
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - hr = 0x0
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Update() - Parent = NULL , Entity = CREDENTIAL_ENTITY
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - Parent = NULL , Entity = DEVICE
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - hr = 0x0
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Update() - Parent = NULL , Entity = CREDENTIAL_ENTITY
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - Parent = NULL , Entity = DEVICE
[5416] 04/17/13 09:16:40 05 AdammAdminBO::Get() - hr = 0x0
[5416] 04/17/13 09:16:40 06 LoginAccount: Initialization Complete. BO=6.
[5416] 04/17/13 09:16:40 07 Resource: Initialization Complete.
[5416] 04/17/13 09:16:40 08 ServersBO: Initialization Complete.
[5416] 04/17/13 09:16:40 09 CMediaServerPoolBO: Initialization completed.
[5416] 04/17/13 09:16:40 10 ScriptMgrBO: Initialization Started. BO=10.
[5416] 04/17/13 09:16:40 10 **** THE SCRIPT MANAGER IS NOT ENFORCING NDMP backup selection restrictions ****
[5416] 04/17/13 09:16:40 10 ScriptMgrBO: Initialization Complete.
[5416] 04/17/13 09:16:40 11 MessageQueue: Initialization Started.
[5416] 04/17/13 09:16:40 11 MessageQueue: DELETING Corrupt Persistent Files.
[5416] 04/17/13 09:16:40 11 MessageQueue: Shrinking DAT files.
Sorted: 0: msgq0000000000.dat
[5416] 04/17/13 09:16:40 11 MessageQueue: Shrinking DAT files Completed.
[5416] 04/17/13 09:16:40 11 MessageQueue: OptionDDMUsable true
[5416] 04/17/13 09:16:40 11 (5416) ( 09:16:40.521000) CManager started Logging
[5472] 04/17/13 09:16:40 11 (5472) ( 09:16:40.521000) CWorker started.
[2840] 04/17/13 09:16:40 11 (2840) ( 09:16:40.521000) CWorker started.
[0248] 04/17/13 09:16:40 11 (248) ( 09:16:40.521000) CWorker started.
[5564] 04/17/13 09:16:40 11 (5564) ( 09:16:40.521000) CWorker started.
[4980] 04/17/13 09:16:40 11 (4980) ( 09:16:40.521000) CWorker started.
[0980] 04/17/13 09:16:40 11 (980) ( 09:16:40.537000) CWorker started.
[5728] 04/17/13 09:16:40 11 (5728) ( 09:16:40.537000) MSGQ EventManager started.
[5416] 04/17/13 09:16:40 11 MessageQueue: Initialization Complete.
[5416] 04/17/13 09:16:40 12 Djm: ComputerName:NKADDBACKUP, NodeName:NKADDBACKUP. CASServer:.  ssoState:0, ssoPrimaryServer:.
 
[5416] 04/17/13 09:16:40 12 Djm: pMMSFeature is NOT installed, setting mmsUsable FALSE.
[5416] 04/17/13 09:16:40 12 Djm: pCASOFeature, CASO installed:0, CASO enabled:1, LicenseInfo CASO authorized:1.
[5416] 04/17/13 09:16:40 12 Djm: Cannot be a CAS: FALSE
[5416] 04/17/13 09:16:40 12 Djm: mmsUsable is FALSE, so setting DjmEnabled to FALSE.
[5416] 04/17/13 09:16:40 12 Djm 3: DjmMgr:0, DjmClient:0.
 
[5416] 04/17/13 09:16:40 12 DjmBO, FixupGeneralFlagsInMachineEx, DataPartGuid match. No Change needed, NKADDBACKUP, AAFB8E04-A150-4707-8F56-CFD1484E34FC, Flags:1573032.
[5416] 04/17/13 09:16:40 12 CDjmBO, CreatingMediaServer, Local: NKADDBACKUP.
[5416] 04/17/13 09:16:40 12 DjmBO, Initialize, Not a CASO and NOT an MMS, deleting all DJM MsgQ for this machine.
[5416] 04/17/13 09:16:40 12 DjmBO=12. : Initialization Complete.
CASO:0, APPO:0, DjmEnabled:0, Mgr:0, Clt:0, CasoServer:. nRetval=0x0.
[5416] 04/17/13 09:16:41 13 Reports: Using default language = _EN
 
[5416] 04/17/13 09:16:41 13 Reports: Initialize for language = 1
 
[5416] 04/17/13 09:16:41 13 Reports: Setting remote server locations.
[5416] 04/17/13 09:16:41 13 Reports: Loading any new reports.
[5416] 04/17/13 09:16:41 13 Reports: Report Engine started.
[5416] 04/17/13 09:16:41 13 Reports: Initializing CRF.
[5416] 04/17/13 09:16:41 13 Reports: Initializing CRF Failed. ERROR CReportsBO::Initialize()
 
[5416] 04/17/13 09:16:41 -1 Business Object 13 failed to initialize:10
[5416] 04/17/13 09:16:41 -1 RpcXfaceServiceMain: InitializeBOs() failed, BO:13, nRet:10
[3612] 04/17/13 09:16:41 05 CAdammAdminBO: Current runtime for daily non-DB maintenance is set to : 04/18/2013 04:00:00.
VJware's picture

The error occurs here ~

13 Reports: Initializing CRF Failed. ERROR CReportsBO::Initialize()

Was any recent update applied to Backup Exec ? You can either luall.exe from Start- Run or check under Control Panel - Programs & Features - Installed Updates

clay.beyer's picture

The last update was done on 3/14/2013... Hotfix 201596,prior to that, on 1/15/2013, 5 Hotfixes were installed, as well as Service Pack 1a.

VJware's picture

Highly possible the issue occurred when the HF was installed...try uninstalling & reinstalling Hotfix 201596. If this not works, would recommend to log a formal support case.

SOLUTION
clay.beyer's picture

Uninstalling the Hotfix has done the trick... Backu Exec starts up. I reinstalled the Hotfix, using LiveUpdate... the system has started back up.

Looks like that did the trick!

Thanks for the help!