Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec Stopped Services

Created: 27 Jun 2013 • Updated: 24 Oct 2013 | 18 comments
This issue has been solved. See solution.

Hi,

 

Im running Backup Exec 2010 on a Windows 2008 R2 Server and I've been experiencing a strange problem the last few weeks. Every morning when I log  onto the server I am greeted by the backup exec services manager dialog box that prompts me to restart the backup exec services. Since they have all been stopped overnight apparently for some reason I have to restart the services every morning and this is getting really frustrating. Please advise as to how I get solve this very annoying issue?

Regards,

Operating Systems:

Comments 18 CommentsJump to latest comment

Jaydeep S's picture

The next time this happens, open the Windows Servvices console and see if all the Be services are stopped. Search in the windows event viewer for any messages related to a service crash. Check if there are any pending updates for SQL. I have typically seen this before when there is an update trying to install over SQL Instance and ends up stopping/crashing BE.

CraigV's picture

...are you on BE 2010 R3? Might be worth the upgrade as it fixed a number of issues with previous versions. You can use the same license keys. You just need to grab copies of the Data/Catalogs folders before doing any upgrade.

Otherwise check and make sure that any AV running on the server isn't perhaps blocking the BE services...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sy.eikrid's picture

Hi Guys,

Thanks for the speedy replies. I've checked the event viewer and the following backup exec services were indeed not running:

Backup Exec Agent Browser
Backup Exec Device & Media Service
Backup Exec Job Engine
Backup Exec Server

I also found the following error in the event viewer: The Backup Exec service 'Backup Exec Server' failed to start because it uses a Windows Server account that does not have the following necessary privileges:
Create Token Object

As for the AV, we are currently using Kaspersky Endpoint Security 10 and not sure what to look for there...

CraigV's picture

Hi Sy,

 

The BESA needs the following rights:

http://www.symantec.com/business/support/index?pag...

Without them, you're going to run into issues.

As for your AV, check to see if it is actively scanning the BE services, and if so, put in exclusions for them. I've had McAfee block BE services for some strange reason on a number of occassions.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sy.eikrid's picture

Hi Graig,

Thanks for the link. Unfortunately that didn't do me much good, as on friday checked and confirmed that the domain admin account has all the rights as listed in the article. However that did not solve my problem, as this morning I was once again faced with the same dillema. I'm still getting the services stopped dialog box which I then have to manually restart.

I also set my backup exec service manager to be excluded in my AV Firewall, however I think this has been an issue before I installed the new AV. Will still test like this and get back to you.

Best Regards,

CraigV's picture

...does the account perhaps lock out? Are you on BE 2010 R3?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sy.eikrid's picture

Hi Graig,

The account does not lock out. I am on BE 2010 just not sure if it is R3 as it says media server version 13 and desktop and laptop option v 3.1. I did however noticed that the sql server 2005 express edition is still trying to install service pack 4 every night. I have downloaded the service pack and tried to install it with a clean boot but i still cannot get rid of that update. Please help me take the update out from windows update.

Thanks...!

 

Jaydeep S's picture

This could be the problem. Could you stop all the Backup Exec services when no jobs are running and download and install the service pack manually.

CraigV's picture

...the build # for R3 is 5204...check and see if that shows. If not, then you're not on R3 and should look at upgrading to that, and installing BE 2010 R3 SP3 before push-installing these updates to any remote servers you might have. As for the SP installation, SQL Express 2005 SP4 is listed, so no incompatibility issues there. Stop ALL the BE services, including the SQL Express service and try the upgrade. If it still doesn't go through, check and see if your AV isn't perhaps blocking the installation.

Thanks!

 

http://www.symantec.com/business/support/index?page=content&id=TECH203157

 

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sy.eikrid's picture

Hi Craig,

Finally managed to to the installation from the link you gave me above. Just a couple of things that concerns me now. Since doing the installation I'm having trouble starting the services and as such I can't log into media server to give me access to backup exec. Any ideas what could be the problem? I've set my logon info to the credentials i've used previously, before the upgrade, but still having trouble starting services.

Below are the errors i'm getting:

Start services on server: BACKUPSERV
Starting Backup Exec Remote Agent for Windows Systems on BACKUPSERV.
Error starting the service Backup Exec Remote Agent for Windows Systems on BACKUPSERV.
The system cannot find the file specified.

Starting Backup Exec Device & Media Service on BACKUPSERV.
Error starting the service Backup Exec Device & Media Service on BACKUPSERV.
The system cannot find the file specified.

Starting Backup Exec Server on BACKUPSERV.
Error starting the service Backup Exec Server on BACKUPSERV.
The dependency service or group failed to start.

Starting Backup Exec Job Engine on BACKUPSERV.
Error starting the service Backup Exec Job Engine on BACKUPSERV.
The dependency service or group failed to start.

Starting Backup Exec Agent Browser on BACKUPSERV.
Error starting the service Backup Exec Agent Browser on BACKUPSERV.
The dependency service or group failed to start.

One other thing is that Backup Exec now says Trial Version since installing. What's up with that?

Regards,

Colin Weaver's picture

As things now appear to be worse you should log a formal support case.

 

BTW your original problem was probably caused by the automated attempt to patch/update SQL as any attempt to stop the SQL instance for the Backup Exec database will stop the BE services.

sy.eikrid's picture

Yes that sure was most certainly the case. The eventviewer logged events for the SQL update almost every night, so I thought upgrading to SP3 would solve all those problems for me. Is there a specific number or email address that I should use to log a formal support case?

Regards,

sy.eikrid's picture

Thanks for the help guys. I did log a call with symantec and after much trial and tribulations, managed to get a successfull install of BE 2010 SP3. However that still did not solve my problem with the Microsoft SQL Express 2005 SP4 Update. The update is still failing each and every night and every morning I still have to start the BE Services manually.

But I'm not completely discouraged yet, will keep looking for a solution, the one I haven't tried yet is fiddling with the registry keys. Yes I am a little scared of making a mess of things again once I start messing with the registry, so I'm still gonna need some expert advice there.

Regards,

pkh's picture

I too am unable to apply the SP4 update to the BKUPEXEC instance.  What I did was to go to Windows Update and hide the update.  This way, Windows Update will not try to update the instance.

SOLUTION
sy.eikrid's picture

Thanks for the tip pkh, I did just that. Will let you know if it resolved my issue.

 

sy.eikrid's picture

Hi Guys,

Looks like all my sql updates are failing and it's not just SP4. Last night I had a security update that also failed to install for the current SQL version (SP3). This is what i'm getting from the eventviewer:

Product: Microsoft SQL Server 2005 Express Edition - Update 'GDR 4060 for SQL Server Database Services 2005 ENU (KB2494113)' could not be installed. Error code 1603. Additional information is available in the log file C:\Program Files (x86)\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\SQL9_Hotfix_KB2494113_sqlrun_sql.msp.log.

 

pkh's picture

This is more a question for Microsoft rather than BE.

sy.eikrid's picture

Thanks pkh, that actually worked for me as well. I think this is generally a SQL problem and so should be taken up with microsoft...!