Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec useless ??

Created: 18 Jul 2013 | 14 comments

Hello,

we are using BackupExec 12.5 on a Windows Server 2003 with a Quantum Tape Loader.

Befor 2 month we made a Full Backup of our data (20 TB) and have done a verify after -> everything went ok.

Now we needed a part of that Backup back, because an employee deleted accidentially a folder (200 GB). We tried to recover that folder from the Backup. but were getting constantly an error: Error e00084d4

So we were still not able to recover this folder all in all, after doing an verify again .> we got the result that everything was ok :-// ?!?!? But Still not able to recover the folder !!!

Gladly i had a second backup, whe i could restore the desired folder, but know i'm somewhat scared, that all the backup and verify doesn't keep me me safe from such errors. Do someone has any experience with that ?? Because now i'm thinking about a disk to disk backup and get rid of that Tape solution, when there is no eveidence to get a verified and functional backup.

Here is the exact procedure:

 

04.05.2013 –Creating the Backup (19.687 TB – 10 LTO5 Tapes – 71 Hours – Verify ok )

 

24.06.2013 –We had to restore a Folder from the Backup (est. 250 GB) – Error e00084d4 (With and without fast restore, as mentioned in the KB – the error appears) Other Folders worked to restore – the one needed NOT

 

01.07.2013 –Verifying of the complete Set (19.687 TB – No errors, Verify complete after 30 Hours)

 

03.07.2013-Tried to restore the folder – Error e00084d4

 

08.07.2013 –Verifying of the specific folder (250 GB) only – Aborted by us after 90 Hours and 70 TB verifying

 

As mentioned above our main Question is why the verifying finds no error, but the Restore is not possible. angry

Thx for any advice and greetz from Vienna

Peter

Operating Systems:

Comments 14 CommentsJump to latest comment

CraigV's picture

Hi,

What TN did you reference for the restores, because that error specifically mentions it happening during the Verify job:

http://www.symantec.com/docs/TECH4955

All the Verify job does is check that what's on tape can be read...not that what is on tape is correct or ensure the integrity. Whatever it backs up from disk is essentially transferred to tape. Read below:

 http://www.symantec.com/business/support/index?page=content&id=TECH18698

Thanks!

 

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Jaydeep S's picture

To add to what Craig has posted, I would suggest you to check if the Media has any Hard read or Write errors. If so, try to avoid using such media for backups.

CHBL's picture

Hello,

thx you both for the posts.

@Craig: in our case, we started the restore process, choosed the appropriate folder and begun. After a short time we got the mentioned error. We tried this multiple times and every-time the same outcome. Gladly we had a second full Backup with the data needed and the main problem for our company is solved.

Still headache stays, because we got in touch with Symantec Support and we didn't get any useful advise of what's happening here and how to solve. Why ??

First, we made a Verify job after the Backup -> everything OK.

Second we made a Verify AFTER the unsuccessful restore try and still --> everything OK

WTF !!! And this is what I mean, HOW CAN I THRUST IN FUTURE THE BACKUP, when it tells me all ok, but in case we get an ERROR ???

Craig you showed me that verify only says that data is readable and says nothing about if data is wasted. Anyway Verify tells me all the data is readable and therefore i EXPECT that after a successful Verify job, all the files could be restored back onto the Hard-disk. We don't talk from any AD or Database etc., just restoring plain files.

@ Jaydeep

Yes the Tapes have all (very less) Read/Write Errors but in the Properties there they are all "correctable".

In my experience there are NO Tapes without Errors, but when there are a lot or "uncorrectables" then it's time to change. If you mean I should change the tapes all month, when the first error comes then this type of backup is way to expensive for us. Anyway in the past with old LTO 3 Tapes and an HP Streamer we had less troubles with that.

I appreciate your input and Thank you both very much, maybe we get a solution or at least a reason why things happen as they do, because for now i don't know what this error wanna tell us as well.

Cheers

Peter

PS: SRY bad English...it isn't my mother tongue

Jaydeep S's picture

Peter I am again going to be very specific, does that Tape have 'Hard' Read / Write errors? These generally are not correctable. The 'Soft' Read / Write errors are.

Edit - DM me the case number and I will have it reviewd

CraigV's picture

No worries on the language barrier...what I meant was that BE verifies that the data on tape can be read. If the data being backed up is corrupt, it backs it up and doesn't state that it has backed up corrupt data.

You don't need a Verify job after a restore...makes no sense. Can you verify for certain that the Verify job after the backup in question showed the data was successfully verified?

Jaydeep is correct too...go to the Media tab and check the tape you had a failed restore on...it shouldn't have any Hard Write Errors...if it does, it points to the tape being faulty which might explain why you couldn't restore.

If you're getting no help from Symantec support, escalate it to a higher level...tell them you want it resolved.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

CHBL's picture

Hello

 

@ Jaydeep: i looked now at all properties of the tapes and there were NO hard Read/Write Errors but some SOFT Errors

 

@Craig: i understand you, but as mentioned before. due trough Verify, BE must be able to read and write the data ........and i want it to restore, even when it's corrupt. BTW: I set this option in the Restore task as well.

The Verify job after restore was "ordered" from the Supportteam from Symantec. I thought, ok maybe i will get the information that after backup the tapes were ok and readable and then something went wrong and a tape is now broken.

Yes, i can ensure that the verify after the backup was succesful and the data was readable -> i attach the logfile from that job to this post

So the questions remain; why can't I restore the data to disk ??

For me that means i can't thrust my own Backup solution, because maybe i got the Error e00084d4 and the system stopps restoring........Argllll !!!

 

Best Regards

Peter

 

PS: I will start the job again, so i can make screenshots

AttachmentSize
Log.pdf 3.14 MB
CraigV's picture

...take a couple of tapes and run the restore of the same folder. If it works, then it points to a possible faulty tape. That's a hardware problem, not a software/BE problem!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Jaydeep S's picture

Do you have some free disk space, if yes, setup a test B2D folder. I would suggest you to try an see if you can run a duplicate job from Tape to Disk. If this is successful, try to restore from the backup on a disk.

pkh's picture

Check that in your Windows Device Manager, your tape library is showing up as an Unknown Medium Changer with a Microsoft driver.  If not, change the driver using the procedure in this document

How to uninstall the Original Equipment Manufacturer driver for the medium changer in a robotic library so as to make it "Unknown medium changer"

CHBL's picture

Hello,

first thx to all of you who try us supporting.

@ pkh: we are using exact this driver mentioned in your post

@Jaydeep: no we don't have so much (20TB) free DiskSpace, is it possible to do that with only a part of the Backup as well or only with the FullSet ??

@CraigV: Beg you pardon, but i don't catch the point ? With one set we get this error and with the other set we get the data.

 

As i mentioned in my first post, we got already our needed data back. The main Problem again:

User came to IT -> some folder isn't on the productive server anymore; check -> it's a full Project with all videos, drawings, legals etc. -> uff, how could this happen -> anyway check Shadow copy -> isn't available; check Backup-Server -> folder was deleted before 2 months so the Backup Server was already mirroring the productive server and folder deleted; hmm...ok...we take the tapes but needs a while -> Backup Exec restore Job -> error reaching unexpected end of backup set -> WTF ?? Taking my last Tape set and here i begun really to sweat.....

As you already know, i got the data there, but i have headache now in using BE, when i do a Backup-Job + Verify (of just flat files) from data of the Backup Server where no file was openen......THEN I EXPECT AT LEAST THAT FILES COULD BE RESTORED, without quitting after 10 min with a failure where i have no idea what to do and the BA-Support obvious as well.

THX you all very much for your effort, but i think this could happen anyone.....and that's the question. What happend and why happend ==> can i thrust my Backup - BE ??

#BTW: I tried again to restore....got the failure and post here the error msg.

 

Best Regards

Peter

AttachmentSize
log2.pdf 19.85 KB
CraigV's picture

So the point is this...if you tried a restore off a tape but it failed, yet restored from another tape, it points to possibly being a faulty tape...especially if you've pointed out now that it was 1 backup set while everything else works. Exactly the point Jaydeep and myself were trying to make.

I've had issues with restoring data at times...mainly due to faulty tapes, sometimes due to site IT reps not changing tapes etc...when it came to faulty tapes, I was able to restore from another date. Did faulty tapes give me a reason to throw out BE or not trust it? Answer is no...because these were very isolated events.

If the tape is damaged, then trying repeated restores on different days with the same tape gets you nowhere...the tape is still damaged.

Again...if BE backs up corrupted data, there isn't a guarantee it is restorable, and if it can be, it definitely won't be usable...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Jaydeep S's picture

I am not sure how complex is the folder structure of theParent folder that you are trying to restore. However, could you try to restore smaller chunks of data inside that folder and see if that works or errors out cause of the same or different error.

Apologies to go back to something that you mentioned in your first post but like you mentioned that you tried restoring the value for "Use Fast File Restore" did you try to set it form the registry. Could you try to make the following registry changes and then perform the step that I have sugested above (In the 1st paragraph)

HKLM/Software/Symantec/Backup Exec For Windows/Backup Exec/Engine/Tape Format/Use Fast File Restore=0

 

Edit: +1 Craig

CHBL's picture

Hello,

 

ok let's try to get to an end. I will gave the last answers i have.

 

@CraigV: YES you pointed exactly out what i mean. I have no problem with faulty tapes. BUT I HAVE A PROBLEM with tapes and SW which tells me they have NO Hard-Errors and giving me NO clue about an error after an verify. Thats the point. How should i thrust an Life-Saver (Backup-Program) when in case nothing function. BTW: Till now, noone could tell me WHAT this error in our case means ?? What is this....a faulty tape, a corrupted SQL-Server in the Background etc. The Tech-Articles states all about this error message at a Verify-Operation. But we doesn't get this error on Verify (instead i just got -> All ok) but rather at the Restore process.

Even with the second argument about the corrupted data i'm not with you. As it's just plain data (and the data isn't corrupted but beside this) i expect to BE ABLE to restore at least the corrupted (and useless) data or SOME files (we talk here about 10 LTO-5 tapes with nearly 20 TB of files) and NOT-NOTHING.

@Jaydeep: We tried with smaller chunks, with bigger chunks, with random chunks -> every time the same failure: Unexpected End of dataset......*clueless*. We tried as well with the different registry settings Fast/Slow restore which was in this case the same.

So......Anyway i THANK you ALL very much and i appreciate your effort to help and support us. I think the expectation of the Backup SW is a personal/emotional thingi. As for me, i can't stand with a situation where the BackupSW tells me the Tapes are ok, Verify is ok (so i assume everything is at least readable) but restore isn't possible because of ?????

For sure i will use BE and tapes in the future but i have to insert a new tier  for desaster recovery, because in our last case it was only about LUCK that we had this second Backup-Tapes (and not already backed up the new dir-structure, where this one project was failing). And if that had happened, i wouldn't write here but rather had a oneway ticket to the North-Pole or so.

Again thank you all very much, if somebody knows a bit more about this failure, what it means exactly in conjunction at a restore operation, then please answer apart from that i will close this threat tomorrow.

Best Regards

Peter