Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

backup exec's SQL Server will not start

Created: 04 Mar 2010 • Updated: 22 May 2010 | 1 comment
This issue has been solved. See solution.

I have installed Backup Exec 12 on Win2K3 Server. It has worked for 9 months. Recently there was a disk problem and now my SQL Server will not start up. The service for SQL Server does not start and neither does Backup Exec. I get an error from SQL Server:

2010-03-03 01:05:01.37 spid4s      Starting up database 'master'.
2010-03-03 01:05:01.48 spid4s      Error: 3456, Severity: 21, State: 1.
2010-03-03 01:05:01.48 spid4s      Could not redo log record (513:432:2), for transaction ID (0:0), on page (1:19), database 'master' (database ID 1). Page: LSN = (513:184:2), type = 1. Log: OpCode = 18, context 2, PrevPageLSN: (513:376:46). Restore from a backup of the database, or repair the database.

I don't have a backup outside of backup exec of this database.  I can't seem to find the right docs for the recovery process for SQL Server 2005.

Suggestions?

Thanks for the help,

JC

Comments 1 CommentJump to latest comment

BEsymc's picture

Please browse to the folder, where sql database files are present. You may want to do a search for master.mdf file. In this same folder, you would see $4idr files, use these files to recover the sql instance as mentioned in following document:

http://support.veritas.com/docs/300136

If you don't have these files, then the only option would be to get these files downloaded from Micrsoft, or reinstall sqlexpress. Please make sure you are modifying the correct instance, if this is not the only sql instance present on the server.

Please mark it a solution, if this is useful.
Thanks

SOLUTION