Video Screencast Help

Backup failing with error code 59

Created: 27 Mar 2013 • Updated: 29 Mar 2013 | 10 comments
This issue has been solved. See solution.

Hello All.

Master Server OS: HARDWARE LINUX_RH_X86
Master server NBU version:VERSION NetBackup 7.1.0.4
 

Client os: Linux and client NBU 7.1.0.4

Please find below output of ping,telnet,nslookup,bpclntcmd from master server to client

[80092345@usnbub5500 bin]$ ping alliance-qa-brn
PING alliance-qa-brn.hospira.corp (10.201.136.35) 56(84) bytes of data.
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=1 ttl=127 time=1.81 ms
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=2 ttl=127 time=0.280 ms
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=3 ttl=127 time=0.218 ms
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=4 ttl=127 time=0.344 ms
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=5 ttl=127 time=0.242 ms
64 bytes from alliance-qa-brn.hospira.corp (10.201.136.35): icmp_seq=6 ttl=127 time=0.701 ms

[80092345@usnbub5500 bin]$ telnet alliance-qa-brn bpcd
Trying 10.201.136.35...
Connected to alliance-qa-brn.hospira.corp (10.201.136.35).
Escape character is '^]'.

[80092345@usnbub5500 bin]$ nslookup alliance-qa-brn
Server:         171.74.74.221
Address:        171.74.74.221#53

Name:   alliance-qa-brn.hospira.corp
Address: 10.201.136.35

[80092345@usnbub5500 bin]$ nslookup 10.201.136.35
Server:         171.74.74.221
Address:        171.74.74.221#53

35.136.201.10.in-addr.arpa      name = alliance-qa-brn.hospira.corp.

[80092345@usnbub5500 bin]$ ./bpclntcmd -hn alliance-qa-brn
host alliance-qa-brn: alliance-qa-brn.hospira.corp at 10.201.136.35
aliases:     alliance-qa-brn.hospira.corp     alliance-qa-brn     10.201.136.35

[80092345@usnbub5500 bin]$ ./bpclntcmd -ip 10.201.136.35
host 10.201.136.35: alliance-qa-brn.hospira.corp at 10.201.136.35
aliases:     alliance-qa-brn.hospira.corp     10.201.136.35

Below are the bpcd logs..

alliance-qa:/usr/openv/netbackup/logs/bpcd>cat log.032713

06:36:56.736 [17028] <2> bpcd main: offset to GMT 21600

06:36:56.740 [17028] <2> logconnections: BPCD ACCEPT FROM 171.74.184.221.55707 T

06:36:56.741 [17028] <2> bpcd main: setup_sockopts complete

06:36:56.796 [17028] <8> bpcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOU

06:36:56.796 [17028] <16> bpcd peer_hostname: gethostbyaddr failed to return pee

06:36:56.796 [17028] <16> bpcd main: Couldn't get peer hostname

06:36:58.248 [17294] <2> bpcd main: offset to GMT 21600

06:36:58.249 [17294] <2> logconnections: BPCD ACCEPT FROM 171.74.74.1.43135 TO 1

06:36:58.249 [17294] <2> bpcd main: setup_sockopts complete

06:36:58.251 [17294] <8> bpcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOU

06:36:58.252 [17294] <16> bpcd peer_hostname: gethostbyaddr failed to return pee

06:36:58.252 [17294] <16> bpcd main: Couldn't get peer hostname

06:46:58.411 [6858] <2> bpcd main: offset to GMT 21600

06:46:58.411 [6858] <2> logconnections: BPCD ACCEPT FROM 171.74.74.1.56036 TO 17

06:46:58.413 [6858] <2> bpcd main: setup_sockopts complete

06:46:58.415 [6858] <8> bpcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOUN

06:46:58.416 [6858] <16> bpcd peer_hostname: gethostbyaddr failed to return peer

06:46:58.416 [6858] <16> bpcd main: Couldn't get peer hostname

06:56:58.356 [25540] <2> bpcd main: offset to GMT 21600

 06:56:58.356 [25540] <2> logconnections: BPCD ACCEPT FROM 171.74.74.1.33065 TO 1

06:56:58.356 [25540] <2> bpcd main: setup_sockopts complete

06:56:58.359 [25540] <8> bpcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOU

06:56:58.359 [25540] <16> bpcd peer_hostname: gethostbyaddr failed to return pee

06:56:58.360 [25540] <16> bpcd main: Couldn't get peer hostname

 

Please help..

 

Operating Systems:

Comments 10 CommentsJump to latest comment

Stumpr2's picture

make sure client has bp.conf entries for SERVER =master server first and then media server.

check name resolution for media server on the client and then connectivity between the media server and the client.

VERITAS ain't it the truth?

Nagalla's picture

pcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOU

check the this IP address 171.74.74.1 is resolving on client or not.

bptestbpcd -client <clientname> -verbose -debug from both master and media server.

EC 59 is mostly because of  2 reasons.

1) client bp.conf does not have right master media server entires

2) or client is not able to resovle the IP and Name of Master and media servers.

so find which one is your case and fix it.

 

Marianne's picture

Add /etc/hosts entry on the client for media server with IP address  171.74.74.1.

Add SERVER entry to client's bp.conf for the same hostname that you have added to /etc/hosts for above IP address.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
CRZ's picture

Basically repeating what everyone else has said, reverse DNS doesn't appear to be working at all on your client - we can see this because your bpcd logs indicate that not only do you have a failure to resolve your server's name by IP address, but there was also a failure to resolve another machine (note initial entry for 171.74.184.221) - perhaps the one you were testing bpcd from? - those gethostbyaddr's will need to work before NetBackup can.


bit.ly/76LBN | APPLBN | 75LBN

Will Restore's picture

note your ping nslookup bpclntcmd commands show client on network 10.201.

and your bpcd log show connections from network 171.74.

might be fine but worth looking into

Will Restore -- where there is a Will there is a way

revaroo's picture

Status 59s, the easiest issue to fix in NetBackup (in my opinion). See suggestions above.

Zailar's picture

Hi Wannawin,

Would you like provide /usr/openv/netbakcup/bp,conf and /etc/hosts from client?. All member may be can correction your wrong configuration.

wannawin's picture

Hello Mariann/All.

 

Now it is failing with error code 23, below are job details..

03/29/2013 02:22:37 - Error bpbrm (pid=14172) bpcd on alliance-qa exited with status 23: socket read failed
03/29/2013 02:22:37 - Info bpbrm (pid=14172) alliance-qa is the host to backup data from
03/29/2013 02:22:37 - Error bpbrm (pid=14172) cannot send mail because BPCD on alliance-qa exited with status 23: socket read failed
03/29/2013 02:22:37 - Info bpbkar (pid=0) done. status: 23: socket read failed
03/29/2013 03:18:27 - Info nbjm (pid=22552) starting backup job (jobid=1769685) for client alliance-qa, policy Unix-serv-FS, schedule Incr
03/29/2013 03:18:27 - Info nbjm (pid=22552) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=1769685, request id:{3B819E5C-9849-11E2-8D5A-98AC0604E2E3})
03/29/2013 03:18:27 - requesting resource usnbub5504-omaha-dd-1-lsu-dp-su
03/29/2013 03:18:27 - requesting resource usnbub5500.NBU_CLIENT.MAXJOBS.alliance-qa
03/29/2013 03:18:27 - requesting resource usnbub5500.NBU_POLICY.MAXJOBS.Unix-serv-FS
03/29/2013 03:18:27 - granted resource  usnbub5500.NBU_CLIENT.MAXJOBS.alliance-qa
03/29/2013 03:18:27 - granted resource  usnbub5500.NBU_POLICY.MAXJOBS.Unix-serv-FS
03/29/2013 03:18:27 - granted resource  MediaID=@aaaab;DiskVolume=omaha-dd-1-lsu;DiskPool=omaha-dd-1-lsu-dp;Path=omaha-dd-1-lsu;StorageServer=usnbd8-502-brn;MediaServer=usnbub5504-brn
03/29/2013 03:18:27 - granted resource  usnbub5504-omaha-dd-1-lsu-dp-su
03/29/2013 03:18:28 - estimated 0 kbytes needed
03/29/2013 03:18:28 - Info nbjm (pid=22552) started backup job for client alliance-qa, policy Unix-serv-FS, schedule Incr on storage unit usnbub5504-omaha-dd-1-lsu-dp-su
03/29/2013 03:18:29 - started process bpbrm (pid=14172)
03/29/2013 03:18:29 - end writing
03/29/2013 03:28:29 - Info nbjm (pid=22552) starting backup job (jobid=1769685) for client alliance-qa, policy Unix-serv-FS, schedule Incr
socket read failed  (23)
 

But bpcd port is working, telnet to pbx is not working

[80092345@usnbub5500 sbin]$ telnet alliance-qa 13782
Trying 171.74.72.119...
Connected to alliance-qa.hospira.corp (171.74.72.119).
Escape character is '^]'.
 

[80092345@usnbub5500 sbin]$ telnet alliance-qa 13724
Trying 171.74.72.119...
Connected to alliance-qa.hospira.corp (171.74.72.119).
Escape character is '^]'.

[80092345@usnbub5500 sbin]$ telnet alliance-qa 1556
Trying 171.74.72.119...
telnet: connect to address 171.74.72.119: Connection refused
telnet: Unable to connect to remote host: Connection refused

Client OS is solaris 8, earlier by mistake i wrote wrong..
 

Marianne's picture

I have move status 23 post to new discussion: https://www-secure.symantec.com/connect/forums/backup-failing-error-code-23-0 .

If your status 59 error is solved, please close this thread by selecting the post that helped you most and Mark as Solution.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links