Video Screencast Help

Backup Job ends with exceptions: An unexpected error occurred when cleaning up snapshot volumes.

Created: 10 Oct 2013 • Updated: 21 Oct 2013 | 5 comments
This issue has been solved. See solution.


Backup exec 2010 R3 SP3. Backing up 2 identical terminal servers (VM machines created from clone. They are identical in every single way, including the updates installed and services running).

The job of Server1 completes successfuly.

The job of Server2 completes with expections: V-79-57344-34108 - An unexpected error occurred when cleaning up snapshot volumes. Confirm that all snapped volumes are correctly resynchronized with the original volumes.

I'm getting error is for Drive C, Drive D, System State and Shadow Copy Components.

I'm also getting events on that server:

Application event:

Faulting application name: vssvc.exe, version: 6.1.7601.17514, time stamp: 0x4ce7998d

Faulting module name: vssvc.exe, version: 6.1.7601.17514, time stamp: 0x4ce7998d

Exception code: 0xc0000005

Fault offset: 0x000000000006709f

Faulting process id: 0x27048

Faulting application start time: 0x01cec553a59788eb

Faulting application path: C:\Windows\system32\vssvc.exe

Faulting module path: C:\Windows\system32\vssvc.exe

Report Id: ec067925-3146-11e3-969c-0050569706d0

System event:

The Volume Shadow Copy service terminated unexpectedly. It has done this 15 time(s).

I checked the VSS List Writers and found no errors.

I checked the Shadow Copy properties on all the disks. they are all disabled.

Both jobs are set to use AOFO and use 'Microsoft Shadow Copy Provider'.

Any ideas?

Operating Systems:

Comments 5 CommentsJump to latest comment

Jaydeep S's picture

Assuming this is on ESX, are the VMWare tools installed and updated. Are you able to manually perform a snapshot of the VMs from vCenter or vSphere.

Try to run 'vssadmin list providers' on server2 and see what providers are listed.

If you have the 'Backup Exec VSS Provider' listed, try the steps mentioned in the technote below -

If this still does not help then you could uninstall it using

YonatanC's picture

Hi Jaydeep,

This is indeed ESX. VMWare tools adn installed and updated.

I ran 'vssadmin list providers' and I had both 'Backup Exec VSS Provider' and ' Microsoft Software Shadow Copy Provider' installed.

I now see that this is also the only different between Server1 and Server2.

I will follow the instruction on the article you gave me, but since this a production server I will only be able to do this on our next scheduled maintenance next Monday.

Will let you know if it worked.


YonatanC's picture

Hi Jaydeep,

Just wanted to update that you solution worked.

I removed the Backup Exec VSS Provider as per the technote you supplied and the jobs now finish successfuly.


YonatanC's picture

Hi Craig,

Our AV is stopped using a script before each backup job so that shouldn't be a problem.

I did however added the VSP extention to it's excluded list.