Video Screencast Help

Backup Job Hangs

Created: 14 Jan 2005 • Updated: 21 May 2010 | 8 comments

Running BE 9.1 on Windows 2003 Server with an IBM LTO2 Ultrium tape drive. Backup jobs run normally and verify over 80Gb with no problems for several days and then the next day the job will hang at the first few bytes of the backup stage. Tried all suggestions on the Veritas knowledge base, updated and rolled back drivers for tape drive,installed SP1 for BE1 and emailed Veritas support several times to no avail. No errors are recorded in the Event log but when running SGMon the job appears to be hanging at this point in the log:

beserver: 0x09a0 08-0113:182527:AdammAdminBO: Get - NULL MEDIA
beserver: 0x09a0 08-0113:182527:AdammAdminBO: end get.
bengine: 200 13/01/2005 18:40:04: DeviceManager: timeout event fired
bengine: 200 13/01/2005 18:40:04: DeviceManager: processing pending requests
bengine: 200 13/01/2005 18:40:04: DeviceManager: going to sleep for 900000 msecs
bengine: 200 13/01/2005 18:55:04: DeviceManager: timeout event fired


Cancelling the hung job and restarting th services seems to resolve the problem as the job will restart OK.

Has anyone suggestions as to what I can try next? BE is no use if it fails this regularly and I will have to move to other backup software if I can't resolve this.

Comments 8 CommentsJump to latest comment

Gilly's picture

Seems to be a problem with your Tape Drive.
Try cleaning it and maybe re-installing it.

The log you've posted refers to DeviceManager and Adamm (which is Advanced Media Management).

Gilly

A Lake's picture

I've cleaned the tape drive a few times to no avail. What seems to happen is the job works fine for several days before it hangs. Restart the services and then its ok for another few days.

The tape drive isn't reporting any errors or requesting a clean.

I've also tried using older and the latest tape drivers as well as using the Veritas ones.

The tape drive is attached to an Adaptec SCSI card (not RAID, just a host card) and I've tried many drivers on this as well.

Gilly's picture

Maybe its time to re-install BE at this stage.
If restarting the BE Services sorts the issue then maybe the SW is going out of sync with the tape drive.

A Lake's picture

I've tried (as Veritas recommended) reinstalling BE and the SP1 several times and the same happens. Works OK for a few days then hangs overnight on the initial stages of the job until I restart the server or the services.

To be honest, I think I've only got two choices left at this stage - move the whole setup to another server that isn't running 2003 or move to other software. This has been going on for some months now and I've tried everything I can think of!

gaurav seth's picture

To isolate the issue:
------------------------------

a. Perform backup using Backup to Disk folder. This step is for test purpose only.
Title: How to create a Backup Folder in order to backup to disk?
http://seer.support.veritas.com/docs/237674.htm



b. Perform the backup operation from NTBackup utility. Stop all Backup Exec related services prior to running the NTBackup. This will help us in isolating the issue. If you face the same problem in NT Backup then please contact your hardware vendor and get the device checked.


Hope this will help.

Ameet Thakkar's picture

Please let us know if you are carrying out local or remote backup. Also let us know if you are performing backup of Exchange mailboxes or SQL databases.

1)Kindly split the Backup jobs for C: and D: drives respectively. Let us know the result of the same.


2) Carry out remote backups separately, This is just to isolate the cause of job which hangs at particular file or it hangs intermittently.


- Stop all non essential third party software and Antivirus software services prior to starting Backup Exec job and verify the result.

ManishGupta-STDXB's picture

1.Update the Adaptec U 160 driver from http://support.adaptec.com . its SP5 driver.

2.Are u using AOFO ?

3.Look for SCSI timeout errors.

4.Clean the tape drive.

5.Install latest driver release from Veritas.Restart and then run the device confiuration wizrd and update the driver.

6.Restart and check the evnt viewer for any error from SCSI controller.

-------------------