Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Jobs failed reporting a network protocol error

Created: 20 Mar 2013 • Updated: 29 Jul 2013 | 10 comments
This issue has been solved. See solution.

Hello Symantec world!

very often I have backup jobs failed and the reporting erros in job log is the following:

The Backup Exec server was unable to connect to remote machine (Server Name) using protocol IPv4.

Can someone expains to me why is this happen. Certainly in job options I have double, triple and so on check the settings and one thing is sure: the setting for protocols is set to use any available network.protocol.

Any help is much appreciated

Operating Systems:

Comments 10 CommentsJump to latest comment

pkh's picture

Check the following

1) on the remote server, check that the remote agent service is running

2) open the remote agent utility and make sure that it is publishing correctly to the media server

3) make sure that you can ping from the media server to the remote server and vice-versa

4) make sure that there is no firewall blocking port 10000

5) on the remote server, check that there are no other applications using port 10000.

To test your connection, from a command prompt on the media server, issue

telnet <remote server> port 10000

Borealis's picture

Hi pkh

1) The service is up and running. Further more there's also a 1st Recovery action set up to the Restart the service.

2)The remote agent is published with Full Domain Name

3)Pinging correctly with DNS and IP and vice-versa

4)The firewall service is disabled.

5)TCP port 10000 is listening only and also checked during the telnet session which correctly listed as in use by the media server.

Telent session performed from the the media to the remote server succesfully but only when I use as host the IP and not the DNS name (I'm not sure if this is a problem)

The question now based on the above findings is related to step 2. Does the remote agent needs to be published with the Full Domain Name, with the IP or both. I;m not saying that this can cause any problems. I'm just asking because I can't see any other obvious reason.

Also, be iinformed that the problem occures with VMs and Physical Servers, The jobs very same servers are running succesfully (with full-Icremental-Full-Incr cycle) for the last 4-5 or more days

pkh's picture

Telent session performed from the the media to the remote server succesfully but only when I use as host the IP and not the DNS name (I'm not sure if this is a problem)

This is definitely the problem.  If the media server cannot contact the remote server using port 10000, then it cannot back it up.

You would either need to add the remote server to the media server using the IP address or resolve your DNS problem.

VBU's picture

Hello Borealis,

It would be a better idea to add to add both FQDN and IP address of the media server in the Remote agent utility publishing. If you think the problem is with the DNS you may also please try to add the entries in the host files of both the media server as well as client and that will help.

Borealis's picture

Hi VBU,

The media server is listed in the Remote Agent utility both with FQDN and IP address.

About host files can you be more specific. Does these entries have to be there already? Can you give an example of these entries?

Below is the host file of the media server

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost

and the host file of the remote server

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost

What exactly is missing and/or what I have to add by file?

Thank you in advance

VBU's picture

Hello Borealis,

If there is a problem with the name resolution we can modify the host files to skip or overrule the DNS. You may add an extra line to the host file as below on the media server with the client details and on the client server with the media server details

"# Copyright (c) 1993-2009 Microsoft Corp.

#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost

and the host file of the remote server

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost

IP Address     Name of the server"

Borealis's picture

I will try VBU recommendations, monitor the jobs for the next days and post back

pkh's picture

If you need an update, it is better to PM the user.

Borealis's picture

I found a workaround solution to my problem by activating the error Handling-Rules.

More specificaly when I enabled the

Network-Server-Resource errors rules (by having them to retry the operation for 2 more times every 10 min.) all my jobs were completed succesfully even when they failed the first time.

Possibly the source of the problem had to do with network and/ord DNS issues (in the first place) so until I find the real origin of the problem I applied this technique which is working just fine for the last couple of months.

SOLUTION