Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Backup Problems

Created: 13 Oct 2009 • Updated: 21 May 2010 | 6 comments

Hi, we're having some issues with our Backups. We are running Backup Exec 12 SP2 with Server 2003.  Due to our current ever increasing amount of data, we've recently had to increase the number of tapes from two, to three. We have a three week retention period setup too in order to protect the tapes from being accidently over-written incase someone accidently puts the wrong tapes in.

Now for the first week and a half or so, our backups ran fine. Then we ran into problems and have been for the last month or so. The jobs run, and the first two tapes are usually used to the max, then about 4 to 12GB of data is written to the third tape, the job enteres a queued state and asks for overwritable media, jams up the other jobs and the whole thing essentially falls apart.

Now the problem is, why is it only writing partial data to the tape and then asking for a new one? We're using 800GB tapes, so there is plenty of space on the third tape to be used, but its like the system uses it for 12GB worth of data, and then wants another tape.

Can anyone offer any advice on a solution for this please?

Comments 6 CommentsJump to latest comment

CraigV's picture

Hi Sisko,

Check and make sure that your media is set to overwritable, and not append in this case.
What could be happening is that your tapes are set that way, and when it gets to the third tape, it's looking for more media to append too.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Sisko's picture

Hi Craig,

Yeah I tried that with a Symantec technician, changing our media to overwriteable, but that doesn't appear to have made a difference. Its a really bizarre problem. Using and filling two tapes, part of the third tape and then asking for a new one, despite the fact there's still loads of space free, more than enough to finish the job.

Colin Weaver's picture

Can't comment on the problem - but just for information Append jobs will only append to the first tape - Backup Exec switches to overwrite mode when it spans to the next tape no matter what the job settings were at the start. If Backup Exec did not do this the media families would get corrupted.

Sisko's picture

Bump...anyone offer any further help on this problem ?

Sisko's picture

Can anyone offer any assistance with this issue? I have worked with a Symantec technician but they have been unable to resolve the problem so I am having to go back to them for further help.

As we increased our tape usage from two to three, the technician suggested we were not using enough tapes. So I increased our usage to four, and then partitioned them up accordingly within the tape library. I know that one of our servers that needs two tapes to backup, I assiged this server its own set of tapes to use and then let the job run. It ran the job and didn't use all of the first tape, entered a queued state and it didn't even TOUCH the empty second tape that it could of used....but there doesn't even appear to be an alert for that server asking for a new tape, yet its entering a queued state and not using all the tape and not touching the second as i've said.

It seems to be some sort of spanning issue. If a job needs to span onto two tapes, its just not doing so in this case. We can take our retention protection off, and it will use the tape, but that is pointless because it goes back to the start and then overwrites new data that was just put onto the tape, hence we wouldn't be getting full backups there.

In truth, I don't have a scooby as to what the problem could be.

CraigV's picture

Sisko: Have you tried with a set of new tapes?
Did Symantec ask you to create a new job and selection list, and have you maybe thought of that as an option?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...