Video Screencast Help

Backup problems

Created: 05 Sep 2013 | 5 comments

I have been having backup issues for a long time and I need to get my backups working 100%.

Here is the equipment that I am using:

Server - HP ProLiant DL380 G8

OS – Windows Server 2008 r2 (fully patched)

Tape Drive – HP Ultrium 5 / T24 Tandberg Tape Library (latest Firmware)

SAS CARD / HBA - HP H221 (no updated Firmware at the moment) (newer card)

SAS CARD / HBA - HP SC08e (no updated Firmware at the moment) (older card)

SAS Cable – StarTech.com External Mini SAS Cable (SFF-8088)

Software – Symantec Backup Exec 2012 r2 (fully patched)

I can get a backup to work maybe 1 out of 10 times, most of the time, I get this error:

“The job failed with the following error: The device timed out.”

Or I get this error:

The driver detected a controller error on \Device\RaidPort1.

--------------------

This error signifies controller errors. These errors are generally caused by hardware that is not functioning correctly. To resolve these errors, try the following actions:

- Slow the SCSI bus.

- Verify that the latest SCSI drivers and firmware are loaded.

And then Backup Exec turns my tape drive offline.

For example, last night I did a test backup of a 700mb ISO file and it worked fine, then this morning I tried to run the same job and it failed.

I have tried using a different SAS cable and that produced the same results.

I have tried using new tapes and produces the same results.

I can use Backup Exec to back up files perfectly fine to my NAS device. So I don’t think it is a Backup Exec issue.

Symantec support say’s it is a hardware issue with either the tape drive or the SAS Card / HBA.

Tandberg support doesn’t know what to do since it works occasionally, they think it's a server / SAS card issue.

HP suggested that I try a different SAS Card, so I went from HP SC08e to HP H221. I switched out the cards and was then able to maybe do 5 backup jobs in a row to tape 100%. Then on a Friday evening it stopped working and I’m getting the same time out / slow the SCSI bus error. I'm now on my 4th SAS card.

I have even tried using the SAS cards on a different server and that produced the same results.

Does anyone have any ideas?

Thank you,

Operating Systems:

Comments 5 CommentsJump to latest comment

Lucrothe's picture

When doing a backup to tape it seems to process around 237mb-239mb before timing out and failing.

Donald Eady's picture

Have you verified that the Tape drives are using Symantec drivers and not the OEM 

Take a look at the following documentation 

http://www.symantec.com/docs/TECH5027

I hope this posting was helpful

  

lmosla's picture

Have you done full power cycle of the HP Ultrium 5 / T24 Tandberg Tape Library? :

1. Power Off the Server completely 
2. Power off the Tape Drive then 
3. Power on the Tape Drive  wait till it is at a 'Ready' State then
4. Power on the Server
 
Check Windows Events for System Errors: Event ID's 5,7,9,11,15 These errors point to hardware errors:
  • Event ID 5. This error indicates SCSI parity errors. This error can be caused by a faulty SCSI card or a faulty SCSI termination. for this error contact the hardware's manufacturer.
  • Event ID 7. This error indicates that bad blocks exist and can be caused by an outdated tape device driver, faulty media, or dirty read/write heads on the tape drive. Try updating to the most recent Backup Exec tape device drivers, run a cleaning job, and replace the media with new media, if possible. If the error continues, contact the hardware vendor.
  • Event ID 9. Points to SCSI bus timeouts.  To correct this, slow down the SCSI bus and install the most recent SCSI drivers and firmware. & sometimes this error is caused when another device shares the same cable. Try moving the SCSI card to a different PCI slot that does not share the same bus as a RAID controller.
  •  Event ID 11.  controller errors, to correct this error, slow down the SCSI bus and install the most recent SCSI drivers and firmware.
  •  Event ID 15. Possibly occurring if the incorrect drivers are loaded or the drivers are not up to date
Larry Fine's picture

I assume you have some HP Insight Manager type software installed?  That has been blamed by many as the root cause of many weird things.  It might be woreth investigating as there are mixed opinions on this.

I would concentrate my testing on the HP H221 card, since that seems to be the one that HP officially support tape with.  It doesn't appear that either of those cards are RAID cards, so I think you are in good shape there.  RAID HBAs are generally not supported.

If you find this is a solution for the thread, please mark it as such.

Lucrothe's picture

@Donald,

Thank you for the help, I am using the drivers supplied by the Symantec Driver utility. 

@lmosla,

Thank you for your help, I restarted the devices in the suggested order and then looked in the log files and I was able to an error for Event ID 11. I'll double check the drivers and firmware for the card.

 

Thanks!