Video Screencast Help

backup QNAP 459U RP+ shared folder with BE 2012

Created: 12 Sep 2012 | 13 comments
fezzik12's picture

Hi everyone,

I am trying to backup shared folders from my NAS to a tape. I was able to add the QNAP as a server and verify credentials with the QNAP but I cannot verify credentials with the shared folders. The only way I can backup from the QNAP is by connecting parts of it to a server (windows 2003\2008) via ISCSI and eventually backing it through the windows remote agent.

Obviously I want to use a direct approach to the data.

Thanks,

Eran

hey everyone,

 

Comments 13 CommentsJump to latest comment

VJware's picture

Was the NAS added using the netbios name or fqdn ? If former, use the fqdn name or the ip address...

Also, check "enable selection of user shares" from the BE yellow button - configuration & settings - BE settings - network and security...

If this NAS is capable of NDMP, you might consider using the NDMP option with Backup Exec...And do ensure the Backup Exec account has read/write permissions on the shares...

 

fezzik12's picture

thanks for the reply,

I have already done what U have suggested, I can see the folders but the validation fails with all the accounts that I've tried, administrator, qnap admin, BE account.

the BE uses an admin account which fail as well.

Unfortunately the NAS doesn't have NDMP option.

Any other ideas?

CraigV's picture

...can you add that NAS to the domain? If so, consider this as an option as it means you would get around the security issues you're currently experiencing! You would simply add the BESA to the NAS as an admin!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

VJware's picture

Is this NAS part of a domain ? Also, do check, if the account used by BE has explicit full permissions on the shares...in other words, try this KB - http://www.symantec.com/business/support/index?pag...

lastly, backing up shares in this method also requires a RAWS license to be installed on the media server...

 

fezzik12's picture

hey CraigV,

the NAS is already part of the domain, the shared folders permissions are configured using the AD security, there are folder with full access for all domain users.

But QNAP doesn't allow domain admin to manage the NAS

It's not possible to connect to the NAS web interface using domain accounts, I can manage the shared folders security using the IP address or FQPN,

when using the BE I get pass the server(NAS) credentials but fail on shared folders.

So Weird……

CraigV's picture

That's weird. When you add an Iomega StorCenter NAS to a domain it allows you to log on with a domain account!

Did you perhaps just create a domain alias for it in DNS?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

fezzik12's picture

Apparently QNAP doesn't allow it.DNS A record was created automatically

CraigV's picture

OK, then it's not AD-integrated.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

fezzik12's picture

well, it is in a weird QNAP way, i get to see all the domain users and can give them permissions to shared folders from the QNAP web interface, i can't login\manage the QNAP with a domain user but i can give access to folder using AD.

remind you i pass the server credential test in BE but fail on shared folders, even the ones that have full access to everyone.

CraigV's picture

...and have you tried to explicitly give the BESA full rights to those folders?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

fezzik12's picture

yes i did, like i wrote before, there are shares with full access to everyone and still get failed.

 

fezzik12's picture

VJware, it's not possible to add domain users to the local NAS groups.

i have 3 more server beside the storage, licenses already installed on the BE server.  

khing's picture

I have exactly the same problem with a QNAP 809.

Additional, I cannot backup hidden shares, because BE don't show them.