Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Backup questions and help with exchange

Created: 28 Feb 2013 | 15 comments

Hello,

We're using Backup Exec 2012 to back-up three servers to NAS. A domaincontroller, a mailserver and a printserver.

First a question about backing up SQL; on the print server there is a job with "Microsoft SQL server instances". There is another job for regular files, however I also see MSSQL folder selected there. What does "Microsoft SQL server instances" backup exactly? Am I backing up SQL twice because the MSSQL folder is also selected in a different job?

The same goes for the mailserver; we have a job containing full and differential "Microsoft Information store" backups and another job backing up Exchange\Mdbdata. What's the difference between these two?

Lastly, backup exec always complains we don't use "Agent for Microsoft Exchange", but it IS installed on the mailserver! AOFO and circular logging are both turned off and Backup Exec is fully updated.

Thanks in advance

Justin

Operating Systems:

Comments 15 CommentsJump to latest comment

SuperBrain's picture

What does "Microsoft SQL server instances" backup exactly? Am I backing up SQL twice because the MSSQL folder is also selected in a different job?

"Microsoft SQL server instances" backup your SQL databases (including online dbs) using the Backup Exec SQL Agent. No, you're not backing up SQL twice because when the MSSQL folder is selected for backup (i.e. as a flat file), it will skip your actual database files (.mdf, .ldf) since they are being used. So it will end up backing up other files which include your .bak files (which can be life savers in certain situations).

 

We have a job containing full and differential "Microsoft Information store" backups and another job backing up Exchange\Mdbdata. What's the difference between these two?

Same like SQL, MDBData contains your exchange database files. But, unlike SQL, it is ok to leave this folder unchecked coz "Microsoft Information Store" backup using Agent for Exchange covers everything you need for Exchange.

 

Backup Exec always complains we don't use "Agent for Microsoft Exchange", but it IS installed on the mailserver! AOFO and circular logging are both turned off and Backup Exec is fully updated.

This may be a scenario specific issue, can you provide more details?

justin2204's picture

Hi SuperBrain,

Thanks alot for the fast response!

I just removed Exchange\mdbdata job and when looking at the "Microsoft Information store"\First Storage Group job, I see the public folder and mailbox stores. They are both 0KB. Maybe this is why the job keeps failing?

The exchange job runs full monthly and differential daily. The differential jobs are failing.

 

SuperBrain's picture

Can you check the job log for your successfull Exchange Full backup - Expand all and scroll down to Information Store (Exchange backup section) to check if it shows any byte count?

Differential jobs fail with what error? is Circular logging enabled?

justin2204's picture

 

Here is the output from the initial full backup 2 weeks ago.

Backed up 4 Exchange Server stores
Backed up 11 Exchange Server logs
Processed 79.817.670.596 bytes in  17 hours,  28 minutes, and  12 seconds.
Throughput rate: 72.6 MB/min
Compression Type: Software
Software compression ratio: 1,1:1

Kinda slow if you ask me, but still it succeeded. After then we had daily differential backups. The first differential backup completed with exceptions (selections changed since last backup; probably because someone changed the time of backups), then all others after that failed. I also noticed it performs a catalog job after every succeeded exchange backup job.

The failing differential jobs from last week give this error:

Final error: 0xe000035e - The Backup Exec Agent for Microsoft Exchange was not used to create the last full backup of this database.  You must use the Exchange Agent to run a full backup before you run a differential or incremental backup.
Final error category: Resource Errors

Unable to complete the operation. The following error was returned when opening the Exchange Database file: '-1811 The file was not found.' 

Failing differential jobs from last 3 days give these errors:

Incremental and differential backups are not possible, because one or more of the Microsoft Exchange transaction log files has been deleted since the last backup.
 

Verify- Unable to attach to \\*****.****\Microsoft Information Store\First Storage Group.
V-79-57344-33899 - The resource could not be backed up because an error occurred while connecting to the Agent for Windows. The correct version of the Agent for Windows must be running on the target computer.

Circular logging and advanced open files are disabled for the mailserver.

SuperBrain's picture

Your differential issue looks like something got messed up with the Exchange transaction logs sequence after that first diff completed successfully.

Can you run another Full backup (so the logs are purged) and thn let a couple of new diff's run?

Circular logging and AOFO need to be disabled... so thats good!

justin2204's picture

A full backup of the exchange server was scheduled to run in the weekend. It failed with the error that there was nothing to back up. When I checked the mailserver this morning, I saw the agent for Backup exec service was not running. This seems to happen everytime the server is rebooted. After enabling the service I started a full backup again which is now running. Too bad it's so slow (94 mb/s).

Will post back after full backup and couple of differentials are done.

justin2204's picture

Well after 2 succesful differentials, I once again get this error; Incremental and differential backups are not possible, because one ore more of the Microsoft Exchange transaction log files has been deleted since the last backup. The Windows Event viewer displays both event 206 57920.

The message for 206 is Information Store (240) First Storage Group: Database E:\Exchange\Mdbdata\priv1.edb cannot be incrementally backed-up. You must first perform a full backup before performing an incremental backup. Event 57920 message is: An error occured while preparing Microsoft Exchange Server \\server.domain.xx\Microsoft Information Store\First Storage Group to back up database.

Help is greatly appreciated.

SuperBrain's picture

Somethings not right with the way Exchange is handling its transaction logs. Are you backing up exchange info using any other method (or software)? Do you suspect anything else which may be responsible to purging transaction logs?

Backup Exec only purges logs after a successful Exchange Full / Log backup. It is not designed to purge logs between incrementals/differential.

justin2204's picture

Thank you for replying. I have a suspicion about another backup program. It incrementally backups Exchange each day. People want to keep using this because Symantec isn't backing up completely yet. I will disable the other backup software for a few days and run a full backup with Backup exec and a few differentials again.

However, the two differentials that did succeed didn't have a problem with the second backup program so I'm not really sure the second program is the cause.

I also found this hotfix http://support.microsoft.com/kb/930197 "Event ID 206 is logged when you try to run an incremental Volume Shadow Copy Service (VSS) snapshot backup on an Exchange 2003 server"

Because the Exchange server did log this event ID, I think I will install the hotfix tommorow.

SuperBrain's picture

Sounds like a plan...

Symantec does not recommend using any other backup applications to backup databases like Exchange/SQL/etc when a Backup Exec agent is being used. This usually always causes issues with backups (mainly causing inconsistency in log sequences.. my personal observation!)

Let us know how your backups run after you disable that other backup application!

Colin Weaver's picture

if you use any other 3rd party backup product to protect Exchange and need to do differential backups then the first Backup Exec operation against Exchange that follows that action by the 3rd party Mmust be a full backup as you cannot break the sequence between full and differential

 

i.e

3rd party, BE Full, BE Diff, BE Diff, 3rd Party, BE Full, BE Diff, BE Diff is OK

BUT

BE Full, 3rd party, BE Diff is NOT OK

 

This is one reason why you should choose one backup product to protect your databases and not mess around with multiple products.

 

justin2204's picture

Well it worked for a few days.. until I got this error this morning;

Job ended: donderdag 14 maart 2013 at 0:07:24

Completed status: Failed

Final error: 0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.

Final error category: Resource Errors

-------------------------------------------------------------------------------------------------------------------------------------------------------

Backup- \\mail\Microsoft Information Store\First Storage GroupV-79-57344-759 - Unable to complete the operation.  The following error was returned when opening the Exchange Database file:  '-1014 The database is out of page buffers. '

I did delete some public folders yesterday, but shouldn't it "back up with exceptions" when you remove items?

I clicked the links in the error log but didn't find anything useful. It sounds like the server ran out of memory..

justin2204's picture

Thank you for the link, I read the article and made sure the backup exec processes were excluded from antivirus scans. I also checked the microsoft article but none of those errors are logged in windows logs.

To see if something odd happends, I just started the differential backup again, it finished after 15 minutes but it's been stuck at 'Updating Catalogs' for 2 hours now at 18 mb/min.

Edit: it's been 4 hours now.. speed dropped to 9 mb/min. The NAS still has activity; network interface shows around 800 kb/s up/down.

justin2204's picture

Well, we switched to incremental backups on the 20th of march, a full backup was made of the information store that day. We then made incremental backups each day and all was fine until today. Again we get the error -1014 the database is out of page buffers.

Any more suggestions? Can someone at least tell me what it means?