Video Screencast Help

Backup Skips the Folder

Created: 26 Sep 2013 • Updated: 31 Oct 2013 | 10 comments
This issue has been solved. See solution.

hi Team,

I have configured a backup with the multiple selction(flat FileSystem) Backup for a windows 2K8 clinet. In the selection all completed succssfullly. But only one folder completed with 7KB --> C:\Windows\Assembly. A am not sure why it was. inside assembly i can see data of 1.8 GB.

 

No exclude list added in the client properties.

How!!!

Rgds,

Punbs

Operating Systems:

Comments 10 CommentsJump to latest comment

Nate.D's picture

Did the backup finish with status 0?

If I was helpful in solving your issue please mark my post with a thumbs up or a solution!  Have a great day :)

punbs's picture

Yes,

Status - yes

Size - 7KB

 

Rgds,punbs

wr's picture

What is the Backup Selection in your Policy?  I think this folder only picked up with System State backup.

Will Restore -- where there is a Will there is a way

punbs's picture

Hi Team,

 

Selection, and every thing is alright. But i suspect the data containg the folder C:\Windows\assembly is not backing up. Seems other services are using this. But no clarity.

the file under C:\Windows\assembly are like batch files.

 

Not sure whether it will process the online files. Need help.

 

 

Rgds,

punbs

Marianne's picture

Check for permissions. The user id starting the NetBackup Client Service needs permission to all sub-folders. The default LocalSystem account may not have sufficient read permission.

Also check if there is a mountpoint under this folder - the default policy setting is to NOT cross mount points.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

wr's picture

OK, this is what I see on several Windows clients...

 

Backup Selection = C:\

assembly directory not backed up (empty folder in Restore GUI)

 

Backup Selection = ALL_LOCAL_DRIVES

assembly directory is backed up

 

 

Will Restore -- where there is a Will there is a way

Mark_Solutions's picture

Based on what wr has said this does look to be part of the System State (Shadow Copy Components)

It would appear to be an integral part of Windows and contains assemplies connected with SQL, SharePoint, .Net, GAC etc.

It should get backed up in the System State backup so in the BAR GUI you will not see anything in the actualy folder location but if you can expand the System State part it should be there (though you may not actually be able to see it specifically)

It is not in any of the FilesNotToBackUp keys as far as i can tell so it should back up as long as you have sufficient rights - though local system should do it unless it is an AD controller or has a specific Application working on the server

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
punbs's picture

Hi Team,

 

Any other/alternate to backup the folder C:\Windows\assembly

Even after enabling the VSS for the Client in the Master Server host attribute. It’s not working.

 

 

Rgds,

Punbs

Marianne's picture

Have you checked out Mark's suggestion that files may be filtered into SCC?

You need bpbkar log to confirm.

See http://www.symantec.com/docs/TECH76997
How to tell which files are filtered into Volume Shadow Copy Components

I have also mentioned NBU Client Service account permission.
Have you checked?
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

wr's picture

As I said above C: drive backup alone may not pick up the folder. 

diskshadow tool shows why.  Thanks for posting that link Marianne.

 

Will Restore -- where there is a Will there is a way