Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Stopped and Running Same Time

Created: 22 Aug 2011 | 27 comments

Hello Everyone -

I am having a very complicated issue that I cannot decide is hardware or software.   I have a backup job which runs.  BEX reports the job completed successfully, however when i check my server to monitor the next job, the first job completed (the one that reported completed successfully) is queued and the tape is still shown in my tape library with the green arrow (running)

It seems as though the job has completed but the tape library is not aware the job has completed.

This issue has been on going and is difficult to check, because the backup job which runs first is a 9 hour job.  I am wondering if anyone has a solution or can help me do some troubleshooting to determine what the issue is.

Thanks!

Comments 27 CommentsJump to latest comment

pkh's picture

What is the version of your BE and what is the make/model of your tape library?

1) Make sure that your library's firmware is up-to-date.

2) Run the manufacturer's utility against the library.  Stopped all the BE services before the test and select the write test.

CraigV's picture

Hi,

You don't mention the version of BE you're using, but update the media server with any available patches. Once done, push-install to any remote servers you have in the environment. Also make sure that you are using the latest DDI drivers from Symantec for the library, and run the Device Configuration Wizard within BE to install the drivers.

Post back with an update!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

rickyrak's picture

I am using BEX 12.5 and all drivers are up to date?

CraigV's picture

...check your autoloader manufacturer's website and download their diagnostic utility (HP has Library & Tape Tools for example). Once done, run the diagnostics against the library and drive to rule out hardware errors. Stop the BE services first though as they will interfere with the process.

any failures reported will need to be checked out by the vendor.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Soledad_Torchiaro's picture

Hi, 

         Also make sure, that the drivers that you are using, are Symantec ones, you can check this under device management, right click on the device, select "drivers" make sure Symantec ones are showing. 

Also, Are you showing any type of alerts when running a job? To check this out:

On the BE console

go to "Alerts"

check any related alert referring to this issue with the library. 

You could also check under Event viewer if you are showing any type of even ID related to the library. 

Sole. 

rickyrak's picture

I tried to cancel the job that is waiting for the tape that is stuck in the drive.  The tape remains in the drive with the Green "Play button" symbol and then I received the following alert:

TUE-AP-DUP-EXC-ISPF-2T -- The job failed with the following error: Physical Volume Library Media not found.

rickyrak's picture

Hi ALl -

Thanks for your feedback.

I have checked all drivers and also verified with my hardware manufacturer.   The hardware vendor (Quantum) did some some errors and replaced the drive.   Now I am back to the same problem.  There is a tape in the drive that BEX is currently using (although not sure what its doing) and as a result I cannot eject the tape or cancel the job.    The next job simply asks to insert an overwriteable or appendable media into the library and then nothing more can be done, as there is already a tape in the drive :(

CraigV's picture

...go into Devices, right-click the server name and choose Pause. After 30 seconds, do the same and select Unpause and see if this has stopped BE accessing the drive.

If not, stop all the BE services (kill the processes if need be), and you will then be able to remove the tape.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

In the Windows Device Manager, make sure that your library is listed as an Unknown Medium Changer with a Microsoft driver.  If it has a Quantum driver, change it using the procedure below.

How to uninstall the Original Equipment Manufacturer driver for the medium changer in a robotic library so as to make it "Unknown medium changer"

rickyrak's picture

pkh -

I think we're on the right track here with your solution.  After making this change things started making a little more sense on my backup system.  I still have the same issue however.   This time, my tape drive remained "In use" for some time, and then that message disappeared.   The strange thing is that it was in use even though there were no other jobs running at that time.    Then when my next job was ready to run, it again was looking for a tape, and again the tape was shown still in the drive and still being used by BEX.     At which point i tried to manually remove through my media changer itself (using the interface) and the system told me that the tape could not be ejected because it was in use.   

This tells me that either the system was still writing to it, or the drive itself has gotten stuck for some reason.

Welcoming further advice on this matter....

pkh's picture

1) Delete the library from BE

2) Stop the media server and the library

3) Start the tape library

4) Start the media server

5) Ensure that the library and tape drive is recognised and functioning correctly in the Windows Device Manager

6) In BE, install the library if necessary.  Go to Tools --> Wizards ---> Device Configuration Wizard to do so.

6) Try again.

rickyrak's picture

Hi PKH -

THank you for your advice.   I called my tape library vendor yesterday and went through some tests with them also to verify it was not the hardware.  Even to be safe, before pefroming your steps listed above, I updated my library firmware to the latest patch.   Right now I am at the same situation.   My 3rd job completes, BEX confirms that the job is complete and there are no other tape jobs running.   HOwever, after the job completes, the drive still has the tape as "In Use".   

Is there any log or location I can check to see what is still using the tape?   There are no jobs running and the library is not doing anything, but the tape remains in the drive "in use" by the software.

Cannot figure out this issue :(

pkh's picture

After the job completes, did you check whether the tape is still in the drive?

Have you tried deleting the library using the steps that I have posted previously?

rickyrak's picture

Hello -

Yesterday I deleted and re-added the drive using the steps you posted.  After the job completed, the tape is still in the drive and shows in-use.

I dont know what BEX is doing though because there is no job running.

pkh's picture

In the Windows Device Manager, is your library showing up as an Unknown Medium Changer with a Microsoft driver or is it using a Quantum driver?  If it is using a Quantum driver, change it to the Microsoft driver.

http://www.symantec.com/business/support/index?pag...

rickyrak's picture

RIght now the Medium Changer is showing as unknown medium changer.   Driver provider is Microsoft, Driver date is 10/1/2002, Version: 5.2.3790, Digital Signer Microsoft.

Click on the driver details I see the following Driver files:

c:\windows\system32\drivers\gearaspiwdm.sys

c:\windows\system32\drivers\tpfilter.sys

I guess in this case I need to remove these driver files?  Should I try to just un-install the medium changer all together?

CraigV's picture

...leave it as is, that's how it's supposed to show up. I think pkh means changing the driver for the tape drive itself...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

rickyrak's picture

OK Left as it was, removed the library and now encountered a whole new issue !  GRRRRRRRRRRRRRRRRRR

Now my library shows up with the slots but it claims all the slots are empty.   Also the drive on my library is now showing up as a stand-alone drive in BEX.

Its like BEX is not even talking to my library anymore :(

This is defenitely a driver issue somewhere. 

My Media CHanger is now unknown device, and my tape library is my quantum drive, but using a Symantec provided driver.   Which is correct?

CraigV's picture

...that is the correct setup there...you can open up the Device Configuration Wizard within BE itself and select the option to configure the tape library. It should show the robotics and a stand-alone drive...drag the drive under the robotics and complete the wizard. Restart the BE services and check the Devices tab and make sure it is showing the library correctly.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

rickyrak's picture

Hi there -

I have gotten to that part.   Now the only remaining issue is that on ALL slots, they are shown empty.   There are tapes in the slots, but still they show empty.

I am running an inventory on the library hoping that BEX will update my list of tapes.   Is there anything else i should do to fix the empty slot issue now that all drivers are correct ?

CraigV's picture

Hi,

Just a side-question, but is your media server a virtual server or a physical server?

That aside, if your hardware manufacturer has a diagnostic utility, now's the time to download it and run it against the library to rule out hardware issues. You need to stop the BE services before doing this though as they lock access to the drive (specifically the hardware service!).

Some other troubleshooting steps to take:

1. Check and make sure the cables are all securely connected (SCSI cables). Reseat them if necessary.

2. Check for any warning lights on the library.

3. Reseat the tapes.

4. Check for any errors on the SCSI card.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

VJware's picture

Before running the inventory, did you right-click the library under Backup Exec - Devices & choose " Initialize " ?

rickyrak's picture

Trying now for the initialize.  I left my inventory running last evening and after 15 hours, it was still inventorying.

I have checked the hardware itself and everything is working fine and all is OK, but still I have problems with the library tapes not showing in BEX

rickyrak's picture

Just as a communication test, I placed my library offline by manually offlining it on the library interface.   I did this while BEX was running the initialize (which at this point has been running for 2 hours) and BEX is still running the initialize and not showing the drive offline.

From this test, I assume that BEX and my library are not talking to each other properly.   Any other reccomendations are welcomed.

CraigV's picture

...an Initialize doesn't take hours...it's normally a couple of seconds which indicates an issue with:

1. Tape library itself - get hold of your manufacturer's diagnostic utility and run it against the library to rule out hardware issues.

2. SCSI card problem - check your server's hardware monitoring tools to see if you have issues (ie. HP's System Management Homepage); also check the Event Viewer and make sure nothing shows up there;

3. SCSI cable break/damage which can affect comms between the server and the library.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

rickyrak's picture

Ive re-seated all cables and even run diagnostics with my library technician on the phone looking at the logs.   ALl the hardware is checking out to be OK.  Now I am again being pointed back to software.

ANy other suggestions?

rickyrak's picture

Finally I have initialized everything and all the tapes are showing and everythying is good!

Now I run my backup jobs and I am right back where I started!!!   The tape is in the drive shown in use and no jobs are running.....

GRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR