Video Screencast Help

Backup tapes not expired automaticaly

Created: 26 Jul 2012 | 11 comments

Hi,

 

We have Veritas netbackup 7.0.1 and after upgradation version 7.0.0 to 7.0.1 we have a problem that Backup tapes not expired automaticaly after retention period expire.

I have installed NB_7.0.1_ET2106924_5.zip this hotfix as well on master server but not get solution. i have to do expire my tapes manuly with the help of bin/admincmd>bpexpdate -m <mediaid> -d 0 command.

 

Regards - PARAG U.

 

Comments 11 CommentsJump to latest comment

Andy Welburn's picture

relates to.

What results do you get from:

bpimage -cleanup -allclients

followed by (when the clean-up has finished in the GUI)

bpexpdate -deassignempty

Parks1's picture

Hi,

 

I have tried given commands but not succeeded.:-(

mph999's picture

For one of these tapes, what does this show:

bpmedialist -m <media id>

Thanks,

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Omar Villa's picture

Just for curiosity how are you catalog backups doing? are they failing? could be you have some sort of corruption at DB or Images level and this will be flagged if a catalog backups is failing.

Omar Villa

Netbackup Expert

Twiter: @omarvillaNBU

 

Taqadus Rehman's picture

I have no idea if you have gone through this artical, but surely it could be helpful for you

http://www.symantec.com/business/support/index?page=content&id=TECH125287

Regards, Taqadus Rehman

Parks1's picture

till the issue is running. any idea on same?

Nagalla's picture

Still your issue is running...may be its time for you to go for support call..

 

Marianne's picture

@Parks1 - it took you FIVE MONTHS to respond... surprise ???

Have you checked any of the posts above?

Please consider upgrading to 7.5.0.4.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Parks1's picture

There some mis-communiction in our team so tht why i forgot about that case

mph999's picture

There is a bug at certain versions where bptm -delete_all_expired doesn't work.
For the majority of people, they never notice this as they have many tapes and a few that doesn't expire exactly on time are not seen, because, bpexpdate cleanup does work, and this runs by default every 12 hours.

So these are your only options (in this order)

You need two tapes that are not expired, or if you have only one, do step 1, they when you have another do step 2.

Before you start, make sure the tape is expired.

bpmedialist -m

If the tape shows EXPIRED continue .... If it shows FROZEN EXPIRED than the fact the tape is frozen will be stopping it from expiring (frozen tapes do not expire).

1) Run bpexpdate -d0 -m
Check with bpmedialist -m that the tape is no longer listed

The idea of this is to check that there is no error in the database with the tapes, sometimes a bad emm entry causes the tape not to expire. If the tape is still listed after this, and is not frozen, then contact support.

With the next tape, check it is EXPIRED with bpmedialist -m but this time run ....

2) bptm -delete_all_expired

Now, check with bpmedialist -m if the tape is listed, if it is not, the tape has expired correctly.
If the tape is still listed, then it seems to be that bptm -delete_all_expired is not working.

If you have not applied the EEB to fix this, contact support to obtain it (or google for it). If you have applied the EEB that should have fixed the issue, but didn't, contact support for further assistance.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805