Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

backup for VM

Created: 22 Apr 2012 • Updated: 11 Oct 2012 | 7 comments

hello

I have a problem backup of vm (esx) in a backup server with Backup BACKUP EXEC, when saving an error message

"The job failed with the following error: An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce an application."

help me

Comments 7 CommentsJump to latest comment

CraigV's picture

Hi,

Check the link below for further information:

http://www.symantec.com/business/support/index?page=content&id=TECH129724

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pixxxx's picture

I have made a Full Backup on the entire Virtual Infrastructure and I have received the same error, but, reading the log it seems to me impossible to identify which is the vm in error

could you please tell me how to identify the vm that generated the error?

thanks

Jaydeep S's picture

1. A test to confirm snapshots are working correctly within the virtual environment is to run a snapshot from inside vCenter/vSphere client.

-  Remove the check from "Snapshot the Virtual machine's memory"
-  Check option "Quiesce guest file system."
-  Review the VSS logs on the guest C:\Program Files\Symantec\Backup Exec\RAWS\VSS Provider\logs.
 

2. Verify if either VMWare Snapshot provider or Backup Exec Snapshot provider is used. If yes, remove both.

http://www.symantec.com/docs/TECH130940

http://www.symantec.com/docs/TECH129864

pkh's picture

The user is asking how to identify the problem VM.

Jaydeep S's picture

Sorry pkh, I seemed to have overlooked that.

Sometimes if the snapshot was not performed at all or there was a timeout that happened, in BE 2012, the VM goes missing from the job log. A closer look at th job log and comparing it with the backup selections, will reveal the VMs that are missing in the job log. These are the VMs on which you got the failure.

Alternate ways would be to identify the VM would be either from the VCenter/Vsphere client. This VM will have an error in the Events tab.

The other way is to confirm from the restore selections if there is a VM missing in the backup set.

CraigV's picture

...only way I can think of is to run backups of the individual VMs and see what happens.

It's a long way around, and not necessarily the best, but it will help you isolate the VM.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pixxxx's picture

Dear all,

I have analyzed deep in detail the log and I have found the issue

as far as I have understod the highlighted log was related to the fact the no Symantec agent was installed

the faild backup was related to a single machine

this night I have removed the vm in error from the job and the job has been completed correctly

thanks for your help