Video Screencast Help

Backup VM on BE2012

Created: 13 Jul 2013 • Updated: 14 Jul 2013 | 4 comments
This issue has been solved. See solution.

Hi All,

I am using BE2012 connect to Vcener to backup all of my VMs, however, i figure out two problems, hope someone can helpt to explain:

1. The full backup does not backup the full capacity of VMDK. For example, i have one VMs with only ond Hard disk which 20KB, however after the job finished sucessfully, BE2012 only shows me 10GB backed up in job log.

2. BE2012 backup the snapshot ( Servername_000002.vmdk etc.), and when i restore i got folder of 2 files: Servername.vmx and servernam_000002.vmdk but the disk should really be servername.vmdk. Therefore when i try to register this retored VMs, Vphere5 reported error " Unable to create SCSI for to open disk, unsupported or invalid disk type 7"

Can anyone help me to get out of this?


Operating Systems:

Comments 4 CommentsJump to latest comment

CraigV's picture


Check the link below and see if they help you:

 I assume BE 2012 is running SP1a and any subsequent patches, and that this isn't vSphere 5.1 you're trying to backup?


Alternative ways to access Backup Exec Technical Support:

Tho Le's picture


Yes, it is BE2012 with SP1 and all available patches to backup Vphere5.0.

I actually have read most of those material before deploying but they didn't help answering my issues.


Colin Weaver's picture

1) This is expected behavior - when Backp Exec and VMware are working correctly, then the unused 'white' space in the vmdk file is not backed up which results in a smaller backup set than the size of the vmdk. Most customers usually ask us why it is backing up the full amount (which can be a problem on the VMware side) 

2) might be caused by having snapshots present on the VM that was backed up that were not created by Backup Exec (judging by the rename of the vmdk file anyway)  Can you check in the vmware snapshot manager aganst the VM concerned, remove any snapshots, run a new backup and try the restore with that new backup set. BTW restoring the .VMX file is expected behaviour. Also might be caused if you are restoring to a local folder on the media server and then transfering the into VMware as because we have not backed up the 'white' space, this then means the redirected restore may need you to use the correct tool to transfer it back to VMware for it to be usable

 For info a redirected VMware restore into a datastore does register the VM with VMware so have you tried this instead of the restore to local folder option (redirect into datastore allows you to rename the VM so can be used for testing)

Tho Le's picture

thanks Colin, this answers my question. I restored to local folder which then was copied to datastore.