Video Screencast Help

Backup Windows Server 2012 HyperV Failover Cluster's VM with Backup Exec 2012 V-Ray

Created: 27 Aug 2013 | 7 comments

Hi,

I have newly configure a hyper-v failover cluster that build up with two host (win server 2012) and 5 vm (win server 2012). When I try to use the backup exec 2012 v-ray (win server 2008) to backup these vm inside csv. I getting error that related to vss. Below is the backup exec error code and event viewer error code:

Backup Exec Error Code:

- Snapshot Technology: Initialization failure on :"VRTSRV::\\cluster_name\HYPER-V?HA?VM\vm_name". Snapshot technology used: Microsoft Volume Shadow Copy Service (VSS).

V-79-10000-11230 - VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot technology that you selected does not support snap technology for this volume. Select another snapshot technology, and then run the job again.

Event Viewer Error code in Hyper-V Host:

Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
. This is often caused by incorrect security settings in either the writer or requestor process.

Operation:
   Gathering Writer Data

Context:
   Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
   Writer Name: System Writer
   Writer Instance ID: {9c4082f1-950d-4df5-87b4-e67bf0f37754}

Does this issue related to the VSS or Symantec Backup Exec V-Ray unable to backup Hyper-V Cluster CSV volume?

Anyone know what's wrong for my setting? Thanks if you guys can help me on this issue.

Operating Systems:

Comments 7 CommentsJump to latest comment

lmosla's picture

Hello Desmond Gooi,

Under the AOFO setting in the Job properties Set the Microsoft Volume Shadow Copy Server to use System -Use Microsoft Software Provider

ArulPrasad's picture

Have You installed the SP2 for BE 2012?

The Support for Hypre-v 2012 is avaaible in Sp2 For Backup exec.

 

Once installing push instal the remote agent to teh Hyper-v server and see how the Backup goes...

Arul

Desmond Gooi's picture

Imosla,

we have tried AOFO set to "Use Microsoft Software Provider" but still failed.

Aprasad,

We had installed SP2 already. that time we just add again for the hyper v server and test backup, result still failed.

 

Desmond Gooi's picture

VJware,

the hotfix already been installed.

I suspect that is due to my remote agent (hyper-v server) not been updated to be 2012 sp2. I check the agent -> about and found the version still is 14.0 Rev 1798.0 instead of 14.0 Rev 1798.1244. The reason is because orignal be server we install is be 2012 and then we update the sp2 through update file "BE1798.1244RSP2_x64bit.exe". So after that we didn't uninstall the remote agent at hyper v host and just remove server and add server in be.

Tomorrow I will try to push update for the remote agent and make sure become 14.0 Rev 1798.1244 then test another round of backup see does it work or not.

Others than that I can't find others reason for why be can't backup for my hyper csv. I had been troubleshoot with symantec support over 2 weeks but still can't solve the issue.

Hope this is the root cause for my issue.

 

marco.lelli-123's picture

Hi, I've got the same exact issue.

BE2012 with a Windows 2012 Hyper-V failover cluster.

Did you solve it?

 

Thanks,

Marco

alessandrorosati's picture

Hi i have the same issue in the same environment

someone solve it?

thanks

alessandro