Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Backup2Disc backup of Exchange hangs on loading media

Created: 28 Oct 2011 | 5 comments

I have three B2D device configured solely for Exchange Database backups

B2D-1: 1.8 TB
B2D-2: 1.8 TB
B2D-3: 900 GB

My Exchange 2007 backups run successfull now (see: https://www-secure.symantec.com/connect/forums/exchange-backups-keep-failing-vss-writers)   but today I noticed that Backup Exec decided to use, out of the Exchange B2D pool (all three above disks), a disk with only 60 GB free and no recycle media. (the backup is about 170 GB)

The other disks have plenty of free disk space ( > 1 TB)

The first 60 GB of the backup went fine until it filled up the disk. Now Backup Exec is waiting with the status message "Loading Media"

 

Question: Why is Backup Exec not using the disk from the disk pool with the most free space and why is it not continuing on a empty disk? What do I need to do to prevent this from happening?

Comments 5 CommentsJump to latest comment

AmolB's picture

If the job is configured to append and if appendable media is available then BE will start appending 

backup job. Configure backup job to overwrite.

Remko de Koning's picture

It is configured to append/overwrite. Problem is that on this specific disk the jobs have not yet expired. On the other disks in the device pool, there is plenty of space.

When I (pre)expire an old job the backup continues. However, this defeats the purpose I guess.

Remko

AmolB's picture

BE will look for media as per the allocation date. If possible target the backup job to the B2D folder 

instead of the device pool. As a best practice try the below step

In BE console, click on Tools->Options->Media Management->"Use recyable media before scratch media"

Remko de Koning's picture

Thanks "AmolZeroCool", unfortunately the settings, as you described, were already configured as you mentioned.

I have it now configured that Backup Exec picks a specific disk instead of a device pool.

Bad thing is that I had to cancel the Backup Job. For some reason this is trowing my VSS writers in error.

It's about the ten-zillion time I have to reboot my Exchange server for this to correct this. Kind of frustrating.

Thanks and have a good weekend!

Remko

pkh's picture

When you use a device pool, BE will the first available device in the pool.  It will not look for the device with the most space.

If you want to span disk, you got to enable the low disk space threshold parameter for the B2D folder and check the span disk option.

For B2D, there is no advantage in appending so always use overwrite for your jobs.