Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BackupExec 2012 - Help CLI command to schedule duplication of disk storage to Tape?

Created: 29 May 2012 | 6 comments

Hi,

First off I've been using BE since it was VERITAS, and always recommended it to my customers and associates.  I am hugely disappointed with this version, the idea of progress in IT is making things work faster and with less effort, this is the complete opposite.  I've spent two weeks fighting many issues and it still not fit for purpose.

So I'm testing Backup 2012 for a new Greenfield site of 70+ servers.  It is a disaster for my needs, maybe it is more suited to smaller operations but the inability to link server jobs in the UI is a terrible decision. 

My backup set will fit on one lto 5 tape but due to the changes to server centric and scheduling makes it difficult if not impossible, having to estimate times for completion to schedule tape duplication for each job is beyond a joke. Plus if your out by a second and the tape is still in use it chooses another tape.  From one tape to 4, none even close to full...

I have come up with a solution, pretty basic but should work.  All I want to do is schedule a duplicate job of all backup sets on my disk storage to tape, and remove the duplicate to tape option from each individual server job.. (70 times.....)  Except there doesn't appear to be a way to schedule this in the ui more than once.  I want to schedule this daily utilizing different media sets on specific days.

Please tell me there is a cli command to enable me to schedule this. 

If not I will not be recommending the purchase of this product and will be looking at alternatives.  Any idea's anyone?

Thanks,

A.

Comments 6 CommentsJump to latest comment

aharte's picture

After testing it does work to duplicate backup sets from storage to tape, BUT you cannot select more than 63 backup sets at a time to duplicate to tape so not a solution unless there is another method of selecting all backup sets for the duplication job via cli.

MattiasA's picture

It is kind of Off topic but still:
If you only have one tapedrive, does it simply not queue the duplication of the next job?

And if I may ask, what is the reasoning behind the need to schedule the duplications?

The tape problem seems to do with the Append period, you might want to check on that.

Don't forget to give a "Thumbs Up" or mark as "Solution" if someones advice has helped you.

David Palmerston's picture

We ran into the same problem with multiple tape usage.  Our site has multiple tape drives which allowed the use of multiple tapes at the same time.

When we created a specific media set to be used only for the duplicates, it stopped using more tapes than we desired - you might try that.

On your other comment - the "cannot select more than 63 backup sets" - what is the error that you receive when you select more?

When I select more than 63 servers at one time to perform a function, I receive "Exception has been thrown by the target of an invocation when trying to create backup jobs" Is this the same you receive?

aharte's picture

Thanks for replies,

In regards the 63 servers, its actually more like 70.   In the disk storage view.  I don't get an error message, it just deslects the previous selected backup sets and picks the last 63-70.   

pkh's picture

You can do the following

1) put all your duplicate jobs on hold

2) use the BEMCLI cmdlet below to get the list of duplicate jobs

Get-BEJob -JobType Duplicate

3) Use the method described in my article

https://www-secure.symantec.com/connect/articles/u...

to chain your duplicate jobs.  You can use one of your backup jobs to trigger the chain of duplicate jobs.

Make sure the the first duplicate job overwrites the tape so that you maximise the use of the tape space.

aharte's picture

Critical link in another thread post thanks SUSH, http://www.symantec.com/docs/TECH189306 : for help with issue of multiple tapes.  Media sets a given, but more importantly for me is if you have a tape library, do not select it as the target device instead select the individual drive.  Am testing at present will report back but looking better.

Thanks