Video Screencast Help

BackupExec 2012 vs Quantum Superloader 3

Created: 09 May 2013 • Updated: 09 May 2013 | 5 comments
This issue has been solved. See solution.

So we replaced our tape library with a Quantum Superloader 3 last September. Overall it works OK with BackupExec 2012. The biggest issue is when a job needs a tape that hasn't already be loaded and identified by the tape library. The job will prompt and say I should import the tape. But import is apparently not supported on this device. I can run an import job and it will just sit there until cancelled with no prompts or actions on the tape library. I can get the tape into the library by using the control panel on the front of the library, but then BackupExec doesn't see that the tape was inserted. "SCAN" is the function required to do that, but "SCAN" jobs sit waiting for the original job that requested the tape to complete before running. That created a lockout situation because in order to see the tape needed for the original job, BackupExec needs to SCAN the library. But it won't. 

Today, I finally found a combination that works around the issue. Here's how to do it:

  1. Manually insert the tape into a slot in the library.
  2. Start a BackupExec import job for that slot.
  3. Once the tape shows up in that slot in BackupExec, cancel the import job

Of course, it would be nice if SCAN jobs just ran when a job was waiting for a tape mount. Or if import jobs would simply complete once they say a tape was already in the slot. Or if they worked in the first space. But for now, at least I can work around it without cancelling the original job.

Maybe by sharing this a real solution can be worked into the product...

Operating Systems:

Comments 5 CommentsJump to latest comment

CraigV's picture

Hi, has a mailslot, and the admin guide for that device talks about import/export.

Have you tried to contact Quantum themselves?


Alternative ways to access Backup Exec Technical Support:

bret.miller's picture

I haven't contacted Quantum because the import and export work both from the front of the library and from their web interface. What doesn't work is when I do it from BackupExec. So I'm expecting that if I ask Quantum they'll blame the software vendor and tell me to contact Symtantec. After all, BackupExec uses its own driver, which means that either the driver is not coded to support the import/export functions or the API exposed by Quantum's library isn't sufficient to handle import and export. Unless there's some way to show that it's a hardware problem, Quantum is unlikely to do anything. Right now, all I have is the BackupExec import and export jobs sit there "running" forever without any prompt to do anything or error message while Quantum's web interface doesn't indicate that the library was asked to do anything. To me that doesn't seem much like a hardware failure.

CraigV's picture

...have you checked this TN out to make sure you are doing it correctly?

Alternative ways to access Backup Exec Technical Support:

bret.miller's picture

I had not. I have always done it from the slot because that's how I was taught and when I right click on the slot, the option is there to "import now" but it apparently doesn't work from there. The library itself doesn't have the option, I'm guessing because it's segmented. But each slot segment has the option. I've never tried doing "importing" into the whole segment because it's always asking for 1 tape, so I'd choose the slot. So having tried that by itself, it actually prompted me to insert tapes into the slots in that segment. I inserted the one tape into the one slot and responded to the prompted and the job ended. So it appears that if I do it that way it may work. 

Will have to try it that way the next time I have a real job asking for a tape.

Exporting seems to work sometimes. It prompts for tape removal, but about half the time the library is locked so the tape can't be removed. Canceling the job, unlocking the library from BackupExec and retrying usually fixes it. But it's faster to remove the tapes and "scan" since the "export" process simply adds more steps when you're doing multiple tapes.

"Import" and "Export" here don't seem to actually do anything with the library. They just tell BackupExec that you need to do something with the library in advance of actually doing it. That's necessary for a tape mount for an already-running job, but not so much for preparing for later scheduled jobs. As long as you remember to scan the library afterwards so BackupExec knows what's there.

Larry Fine's picture

Import should work fine on that library.

When you run an import job by right clicking on a slot, you should get an alert asking you to "Please insert media into the following slots: X".  Might you have your alerts configured such that you are missing the alert?

Once you have used the library interface to import the media into the slot, then you would acknowledge that alert.

The other issue you saw about a scan job not running is a known issue.

If you find this is a solution for the thread, please mark it as such.