Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

BackupExec & Netapp FAS2040 without NDMP

Created: 14 Jan 2013 • Updated: 18 Jan 2013 | 6 comments
This issue has been solved. See solution.

BackupExec 2012 Version 14.0 Rev 1798 (64 bit) installed on Windows Server 2008 R2 Standard SP1 x64 Virtual Machine

NetApp FAS2040 Version 8.0.2

I have a few questions/problems going on with backing up the CIFS shares on our SAN.  We are not licensed through Symantec for the NDMP license as of right now thus I followed the solution (http://www.symantec.com/business/support/index?pag...) to install it as a File Server.  This worked fine except one thing I noticed is that it takes several minutes to work with it.  Anytime I need to edit the backups to make a change to the selections or edit the login credentials it will take 20+ minutes before the selection options become available.  When I want to test just one selection login it takes just as long to test all selections.  If I make a change in the backup job options and hit OK to save and exit I get an error to "Please specify valid selections." and am forced to wait or exit without saving changes.

The next issue is relating to a failure stating "Checkpoint restart cannot be applied to the restarted backup job.  The backup job will not run." even though "Checkpoint restart" option is not enabled...  This error linked me to this article which I have triple checked (http://www.symantec.com/business/support/index?pag...)

The domain account that I use for backing up servers has all appropriate permissions to do its job yet I recieve a login error on almost all CIFS shares.  There is a CIFS share directory for our compnay file shares and another CIFS share named HOME for redirected My Documents, Desktop items, etc.

There are no problems backing up the HOME directory but forget about the CIFS location.  It backs up the first Folder but nothing inside of it or the remaining 20 or so shares.  All show a "Snapshot Technology Initialzation failure" and then redirects me to a set of Error Code Lookup results that do not pertain to this issue.

 

 

 

 

Comments 6 CommentsJump to latest comment

Colin Weaver's picture

Ontap 8.x can cause a problem with CIFS backups and 2012. I am not 100% sure if your symptoms match, however I believe we found that anyone doing a CIFS backup of NetApp data with 8.x (and possibly the lasts version of 7.x as well)

1) MUST apply/upgrade to whatever the latest version of Ontap 8.x is

2) MUST also use a software firewall on the media server to disable any outbound request to the IP address of the NetApp via Port 10,000 (you do need other ports to be allowed and you don't want to block 10,000 to remotes servers in your enviornent, just to the NetApp)

 

Apparently NetApp changed the challenge response for any Port 10,000 request when the port is not listening from some kind of timeout to an actual response and this the fools Backup Exec into thinking a remote agent is present even though the resposne is to state Port 10,000 not active. (This is the reason for Firewall setting). There was also some other problem which needs the latest OnTap to solve. (I am not sure of the details of this one)

rsmccall's picture

We do not have any additional software firewall other than Windows firewall that is disabled via Default Domain Policy.  We use dual Cisco ASA's.  I went ahead and created a rule inside Windows firewall on the media server anyhow to block outbound TCP port 10000 communication to the FAS2040 IP address, should I create a block for the UDP comm. too?

rsmccall's picture

I went ahead and added the "ndmp 9000/tcp" entry into the services file on the media server.

i have deleted the NetApp from the server list in BE and have re-added it.  at this moment i can see the HOME & CIFS shares as i should without getting the Access is Denied message but i want to run a full backup before saying it's good to go. 

rsmccall's picture

 

How to change the default port used by the Backup Exec Remote Agent for Windows Servers (RAWS)

http://www.symantec.com/business/support/index?pag...

rsmccall's picture

Not sure which one of the above steps made the difference or the combination of all of them but I was finally able to complete a full backup of the NetApp device.  

SOLUTION