Video Screencast Help

Backups are stuck in queue

Created: 06 Dec 2011 • Updated: 29 Dec 2011 | 14 comments
This issue has been solved. See solution.

Hello dear users,

I've had some problems with our deduplication folder running BE2010 R3 SP1 fully updated. This resultet in deleting the deduplication folder and creating it again. Backups seemed to run fine however now jobs are stuck in queue end nothing happens.

I have 2 sites. 1 CASO server where I backup data to a deduplication folder, afterwards dedup to site 2 and again to tape.

As far as I can see all devices are ok and the deduplication folder is in use. In alters I get this error:

Backup Exec was unable to initialize and communicate with the device [SYMANTECOstLdr MACF] (The handle is invalid.). Click the link below for more information on how to diagnose the problem.

Any ideas where I can see more information about this? Backups are running fine after restarting the services.

Comments 14 CommentsJump to latest comment

CraigV's picture

Hi,

 

If you right-click the Queued job and choose the option to respond to the alert, what is it telling you to do?

 

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Jakn's picture

Thanks Craig,

I did not see that option. Of course I did restart services so I'll have to wait till my jobs get stuck again and try. 

Jakn's picture

Hello again,

Seemed to happen again. The alert option is not available.

 

AmolB's picture

Do you see a "Green Question" mark on the queued job.

You may also check the alerts tab in BE console.

dedupe-works's picture

At the begining of the backup, and during each time a media is spanned, the job will query for overwritable media, during this process, expired media is erased.

Check your audit log for "quick erase" while in queued state.

 

check this doc for a reg key workaround to get the jobs working tonight.

 

http://www.symantec.com/docs/TECH159843

 

Regards.

Randey

Jakn's picture

Hello Randey,

Sorry I'm a bit new to backup but I tried to  look in the audit log and I can see that media is getting erased when jobs start to run. However it can run fine a few days and then hang again so its not that the jobs dont have time to erase old media and there is plenty of space on the dedup folder.

Restarted services again and jobs started to run fine. Just until next time... :-)

Thanks

dedupe-works's picture

Try this and restart BE services. Not Dedupe services. If it works, let me know via private message and we can go from there.

reg key workaround

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

  1. Using the regedit tool, edit the following key:
    • Key Name: HKEY_LOCAL__MACHINE\SOFTWARE\Symantec\Backup Exec for Windows\Adamm
    • DWORD: Enable OST Space Reclamation
    • Value: 0
  2. Restart Backup Exec services.
  3. Run the jobs that need to be run.
  4. Change the value of the Enable OST Space Reclamation DWORD to 1 to enable it again.
  5. Restart the Backup Exec services.

Regards.

Randey

pkh's picture

Why are you taking this discussion off-line?  Shouldn't whatever further steps that are required be shared with the other forum users?

dedupe-works's picture

.

Regards.

Randey

dedupe-works's picture

Because in 10 minutes I am going to post it as a known issue on the known issue site and officially respond to it with this reg key and tech note reference.

I am merely putting this customer first before doing a bunch of needless paper work.

 

The offline work is merely going to be setting up the transmission of logs to confirm the issue is related to the product issue I have identified in support cases.

Also, if this was a configuration issue, the greater community at large would have solved it.

I saw this post within context to a support case I saw and wrote it up for investigation because this can't be fixed by a configuration change, only by workaround, which I posted above.

If you have any more questions regarding my posts, send me a private message.

Regards.

Randey

dedupe-works's picture

As stated previously, here is the link to the known issue: https://www-secure.symantec.com/connect/issues/backups-deduplication-go-queued-state-after-excessive-amount-media-has-expired

Please +1 this issue if you have Deduplication backup jobs in queued state for an unresonible amount of time relative to your environments requirements.

Regards.

Randey

Jakn's picture

Thanks Randey

Did this and jobs seems to be running. When backups completely I'll change the value back and post back here in a few days to confirm the solution.

previosly I have deleted the dedup folder and created it again in one site to fix another problem. Maybe that can have something to do with this?

/Jan

dedupe-works's picture

What happens is the media that is in the folder becomes expired due to media set settings.

If a large amount of media expire at the same time, job queue time can increase.

The workaround should be used as a stop gap to get you to the next day where it can be turned back on and a test job ran to initiate the media reclamation process.

Deleting the folder simply gets rid of all the media in one swoop and starts over with new media. This is not a favorable solution for many and that is why I have brought it up with engineering.

Regards.

Randey

SOLUTION
Jakn's picture

Seems that jobs are running just fine now.

Thanks