Video Screencast Help

Bad Gateway error.

Created: 03 Jun 2009 • Updated: 21 May 2010 | 5 comments
SV's picture

Hi Friends,
 I am getting the following error message while generating some reports ( Report type = Risk, select a report = comprehensive risk report ) .

                                                                       Bad Gateway
The server received an invalied responce from another server while attempting to fullfill the request

Can any one help me why it is giving the error.
we are having two Symantec servers ( Clustered) with common data base ( SQL Server)
version SEP 11 Mr4 Mp1a.

Comments 5 CommentsJump to latest comment

Vikram Kumar-SAV to SEP's picture

 Are you logged on locally on this server or taking an RDP..If through RDP then try logging in on Console session.

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

SV's picture

Hi friends.............
is there any coments??????????????

Vikram Kumar-SAV to SEP's picture

can you post scm-server logs 

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

Siddarth's picture

Try http:\\localhost:<TCP port number for SEPM website>\Reporting

In there if you are getting the same error "Bad gateway - The server received an invalid response from another server while attempting to fulfill the request" then you can follow the steps given below:-

If you use the Symantec Endpoint Protection Manager console on the Windows Server 2003 operating system with Internet Information Services (IIS) 6.0 installed, you may want to install Microsoft's FastCGI Extension for Internet Information Services 6.0.

For your convenience, the following FastCGI extensions are located in this folder:

■ fcgisetup32.msi, for use on 32-bit computers

■ fcgisetup64.msi, for use on 64-bit computers

For more information about FastCGI, see the information available at the following URL:

http://www.iis.net/fastcgi/phpon60

Run the setup for fcgisetupXX.msi on the computer on which you have Symantec endpoint protection installed.
FCGISETUP32.msi is available in CD2 or you can download that same from

http://www.microsoft.com/downloads/details.aspx?FamilyID=2d481579-9a7c-4632-b6e6-dee9097f9dc5&displaylang=en

FCGISETUP32.msi   for 32 Bit server
FCGISETUP64.msi   for 64 Bit server

After the installation is done navigate to C:\Windows\System32\inetsrv

Open fcgiext.ini with a text editor.

Add the following lines to the bottom of the file:

Note :- <Drive> denotes the drive on which your Symantec Endpoint protection manager is installed. e.g c: or d:

php=PHP

[PHP]

ExePath=<Drive>:\Program Files\Symantec\Symantec Endpoint Protection Manager\PHP\php-cgi.exe

Arguments=-c "<Drive>:\Program Files\Symantec\Symantec Endpoint Protection Manager\Php\php.ini"

InstanceMaxRequests=10000

EnvironmentVars=PHP_FCGI_MAX_REQUESTS:10000

Save the changes to the file.

Now navigate to <drive>:\Program Files\Symantec\Symantec Endpoint Protection Manager\Php\php.ini

Right click on php.ini and uncheck "Read only" and click on OK. Then open the file and add the following lines to the bottom of the file:

fastcgi.impersonate=1
fastcgi.log=0

Save the changes to the file and close it. Again open properties php.ini and check the "Read only" box and click on OK.

Click Start>Control Panel>Administrative Tools>Internet Information Services (IIS) Manager

In the navigation tree, under Web Sites, under Default Web Site, right-click Reporting, and then select Properties.

On the Virtual Directory tab, click Configuration. On the Mappings tab, under Application extensions, click the executable path, for the extension .php and then click Edit.

Change the path to C:\windows\system32\inetsrv\fcgiext.dll

Or %WINDIR%\system32\inetsrv\fcgiext.dll

Where you replace %WINDIR% with the definition of %WINDIR% on your computer.

Hope that should work for you..