Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Basic Command Line Installation from Newbie

Created: 13 Nov 2012 • Updated: 21 Nov 2012 | 6 comments
This issue has been solved. See solution.

Hi

apologies for posting such a basic question , but I can't get PGP command line to run properly on my Works Machine , no matter what I try the command pgp -h  ( or anything else) the error message "Error no personal documents directory found"

I have checked that the folder C:\documents and settings\<user>\my documents\pgp is there. My user is now set to be Local Admin on my machine and still no joy

I know it is a setup problem because I have downloaded PGP command line at home , installed it and it works fine !!!

I assume it is something to do with either folder permissions or machine permissions but am struggling to find any info about this

can anybody point me in the right direction or at a list of obvious checks to make

thanks

chris

Comments 6 CommentsJump to latest comment

dfinkelstein's picture

I'm sorry you're having this problem.  What version of Windows are you running, and what version of PGP Command Line?

If you run "pgp --version --verbose" do you also see the error?  If not, what is listed as the "Personal Directory" under the "File Information" section, and does that directory exist, and do you have permissions to access the directory and its contents?

--------

David Finkelstein

Symantec R&D

Chris_Barclaycard's picture

Thanks for the reply

I am running Windows XP sp3 (both works machine  and Home)

I am running PGP command Line version 9.8 on works ( I think it is 10 on my home machine)

When I run pgp --version --verbose I get the same error message

"Error No personal documents directory found "

Where do I look for File information section ?

according to the manual I have the personal documents directory should be set to c:\documents & settings\username\my documents\pgp  , this folder exists and I have both write and read access to the folder.

The applications folder  c:\documents and settings\username\Application Data\PGP Corporation\PGP also exist and I have write/read access to this folder

The application was not installed under my username and it will not be possible (as far as I know) to download the latest version easily (lot of manager approvals needed)

chris

dfinkelstein's picture

The "File Information" section should have been part of the output of "pgp --version --verbose".  But it looks like it is failing before it even gets a chance to print out that information.

Do you have the "PGP_HOME_DIR" environment variable set?

Can other users on this system run pgp?

If you manually set PGP_HOME_DIR to some other location (say, C:\temp) or run with the "--home-dir" option set, do commands work?

--------

David Finkelstein

Symantec R&D

Chris_Barclaycard's picture

we make progress !!

After setting the PGP_HOME_DIR I get a different error message when I try pgp --version --verbose

(Home dir set the C:\chris ) message reads

C:\chris\pgprefs.xml:version(1089 unable to open Preferences file )

I do have a PGPPrefs.txt file that came with the installation (could this be a version mismatch ?)  but no .xml file

Re other users

I am currently the only user on the system, I am programming a proof of concept.I will probably end as the "administrator" for this system

chris

dfinkelstein's picture

We do not use "PGPPrefs.txt" in the product, nor does a copy of the preference file come as part of the installation.  It is created the first time PGP Command Line runs.

I would consider wiping your current installation and any "PGP" directories (back up any keyring files, if you have them, but you probably don't if this has never worked for you) and re-install, and see if that improves things.

--------

David Finkelstein

Symantec R&D

SOLUTION
Chris_Barclaycard's picture

I reinstalled PGP command  line and tried again , no joy same error message

I tried pgp --version --verbose --home-dir C:\chris  and it worked , went back and checked the Environment variable and found I had put the dir name  in incorrectly (apologies)

I can now get the Version information up on the command line and am proceeding to license the Application and will create keyrings etc

appreciate the help

chris