Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrade.
Please accept our apologies in advance for any inconvenience this might cause.

Basic PGP Desktop Questions

Created: 13 Dec 2012 • Updated: 13 Dec 2012 | 14 comments

I am new to pgp desktop and have these basic questions:

1)  after I have created my passphrase, does it remain cached for every session?  There is a clear cache feature - does that relate to this passphrase caching.  if I mistakingly cleared it, how can I cache it again.

2) I cannot decrypt the notepad file I had encrypted.  I am getting the bad parameters error message when I click current window and do the decrypt.

Any assistance would be most appreciated.  Thank you.

Discussion Filed Under:

Comments 14 CommentsJump to latest comment

Tom Mc's picture

I am new to pgp desktop and have these basic questions:

1)  after I have created my passphrase, does it remain cached for every session?  There is a clear cache feature - does that relate to this passphrase caching.  if I mistakingly cleared it, how can I cache it again.

In PGP Options, on the General Tab, you set whether you want to use passphrase caching, and how it functions if you want to use it.  Yes, the Clear Caches option will remove any passphrase caching currently in effect.  If you use the Clear Caches option, it will only remain in effect until the next time you enter your passphrase, which will then again function as set on the General tab of PGP Options.

2) I cannot decrypt the notepad file I had encrypted.  I am getting the bad parameters error message when I click current window and do the decrypt.

Any assistance would be most appreciated.  Thank you.

The Current Window function will not work on all software, and some versions of PGP have had more difficulty than others, also related to the operating system you are using.  I'm currently using 64 bit Windows 7 with PGP 10.2.1 and it is working properly with Notepad.  However, I use Pegasus Mail for my personal email, its developers made a change to its functioning years ago that has resulted in the Current Window option not working with it.  In your example, it may work for you, if you first select (highlight) the encryption (including the Begin and End lines) in Notepad before you attempt the decryption.  I think that will work for you, but if not, you can select the encryption, copy it to your clipboard, and then use the Clipboard Decrypt & Verify option.

 

 

 

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Tom Mc's picture

Do you need further help with this?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Mehmood's picture

There is no passphrase caching option in General Tab.

I use Universal Server 3.2.1

Mehmood's picture

Even on the ckient side, for a user who has key mgmt enabled, there is no option to disable caching.

I selected "do not save my passphrase" & it doesn't work.

sven_frank's picture

Hi Mehmodd,

there cashing is in the "Keys" section and is always server controlled for managed Clients also when the option is there on the client side.

You find the Options Section under Keys:

I marked it in Red for you:

Be aware the client will also when cashing is disabled do it for 3 seconds this is needed for certain smartcards and therefore is the lowest possible value.

Screen Shot 2013-03-25 at 09.12.06.png

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

Mehmood's picture

Hello Steve,

Did that too, but the passphrase on the client continues to cache.

Please refer to this thread:

https://www-secure.symantec.com/connect/forums/pgp-desktop-how-disable-passwords-cache

Tom Mc's picture

Wondering what will happen if you set it to save the passphrase for 1 second.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Mehmood's picture

Hi Tom,

Less than or equal to 3 secs is considered as Do Not Save Passphrases.

Tom Mc's picture

Since your selection of Do Not Save Passphrase is not doing it for you, I suggest trying the option of setting it for 1 second.  I'm not optimistic, but am thinking of a similar situation in a past version of PGP Desktop where it did.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Mehmood's picture

Did that too. If you select 1 sec, a msg prompts stating: Your save passphrase time is <=3, it will be treated as "Do Not Save Passphrases". And then Do Not Save Passphrases is automatically checked. PW continue to cache.

Tom Mc's picture

Thanks for the clarification.  I'd try setting it to 4.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

sven_frank's picture

Blond Question: Which Keymode is the user ?

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.