Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE 12.5 Cannont Add SharePoint Farms

Created: 04 Mar 2013 • Updated: 21 Apr 2013 | 3 comments
This issue has been solved. See solution.

Community,

Working with Backup Exec 12.5 in a test environment to test backup and restores from our production environment.  I installed SharePoint 2007(SP2) on Windows server 2003 (SP2), SQL 2000 (SP4) and .net 3.5 (SP1) one one server and Windows Server 2003 (SP2) Backup Exec 12.5 (SP4) with SQL and SharePoint agents licensed, in a simplistick setup with pretty much all the defaults.

When I try and add the SharePoint server as a SharePoint resource I get the error: "None of the Web servers for the specified server farm could be accessed."

I can successfully connect backup and restore SQL, but that isn't the method used on our production.

I've tried every article/discussion I could find related to this error, any advice or troulbeshooting steps would be greatly appreciated.

Also attached is the debug when I try to add the sharepoint server farm

 Backup Server:

***************************************************************************
*****                  SGMon log for \\BACKUP2003                      *****
***************************************************************************
BKUPEXEC: [03/05/13 10:36:16] [3148]     luster" key does not appear to be present in the registry
BKUPEXEC: [03/05/13 10:36:16] [3148]     iled to open Microsoft cluster ()
BKUPEXEC: [03/05/13 10:36:16] [3148]     S cluster keys do not appear to be present in the registry
BKUPEXEC: [03/05/13 10:36:16] [3148]     iled to open VCS cluster ()
BESERVER: [03/05/13 10:36:16] [3356]     -1 Client requested key (1362447526).
BESERVER: [03/05/13 10:36:16] [3844]     "Cluster" key does not appear to be present in the registry
BESERVER: [03/05/13 10:36:16] [3844]     Failed to open Microsoft cluster ()
BESERVER: [03/05/13 10:36:16] [3844]     VCS cluster keys do not appear to be present in the registry
BESERVER: [03/05/13 10:36:16] [3844]     Failed to open VCS cluster ()
BESERVER: [03/05/13 10:36:16] [3844]     01 Server Configuration: Client added: 7
BESERVER: [03/05/13 10:36:16] [3844]     -1 Client 'BACKUP2003' connected('','NT AUTHORITY\SYSTEM'): 0x10ca370
BEREMOTE: [03/05/13 10:36:16] [1228]     "Cluster" key does not appear to be present in the registry
BEREMOTE: [03/05/13 10:36:16] [1228]     Failed to open Microsoft cluster ()
BEREMOTE: [03/05/13 10:36:16] [1228]     VCS cluster keys do not appear to be present in the registry
BEREMOTE: [03/05/13 10:36:16] [1228]     Failed to open VCS cluster ()
BEREMOTE: [03/05/13 10:36:16] [1228]     GetServerType for local machine
BEREMOTE: [03/05/13 10:36:16] [1228]     Finding MNET entries using PunchDownWithWNetCalls()
BEREMOTE: [03/05/13 10:36:16] [1228]     Notes Agent:FindDrives
BEREMOTE: [03/05/13 10:36:16] [1228]     No Oracle SID's were discovered
BEREMOTE: [03/05/13 10:36:16] [1228]     GetServerType for local machine
BEREMOTE: [03/05/13 10:36:16] [1228]     Device Shadow?Copy?Components Dle platform 2  major version 5  minor version 2  build 3790
BEREMOTE: [03/05/13 10:36:16] [1228]     No utility partitions found on any of the disks
BEREMOTE: [03/05/13 10:36:16] [1228]     NRDS_RA_FindDrives entered
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client connected.
BEREMOTE: [03/05/13 10:36:16] [1228]     FS_CreateTempDLE
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client connected.
BEREMOTE: [03/05/13 10:36:16] [1228]     NRDS cache-hit for sharepointtest
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client disconnected.
BEREMOTE: [03/05/13 10:36:16] [1228]     FS_CreateTempDLE
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client connected.
BEREMOTE: [03/05/13 10:36:16] [1228]     NRDS cache-hit for sharepoint2
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client disconnected.
BEREMOTE: [03/05/13 10:36:16] [1228]     FS_CreateTempDLE
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client connected.
BEREMOTE: [03/05/13 10:36:16] [1228]     NRDS cache-hit for backup2003
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client disconnected.
BENETNS:  [03/05/13 10:36:16] [2528]     NRDS API - client disconnected.
BEREMOTE: [03/05/13 10:36:16] [1228]     NRDS_RA_FindDrives completed
BEREMOTE: [03/05/13 10:36:16] [1228]     Informational: Cps root device creation using default Cps library mechanism when creating device 'Cont?Prot?Srv' in CPS::DetermineRootCpsComponent:696
BEREMOTE: [03/05/13 10:36:16] [1228]     Informational: Cps library not available.  Not creating Cps root device 'Cont?Prot?Srv' in CPS::DetermineRootCpsComponent:700
BEREMOTE: [03/05/13 10:36:16] [1228]     Function called: DB2_FindDrives
BEREMOTE: [03/05/13 10:36:16] [1228]     Status 0xE0008488 returned calling FindDrives for file system 28 in DLE_UpdateList
BEREMOTE: [03/05/13 10:36:16] [1228]       AD:DeviceName "System?State" in SystemState::CreateDLEs:361
BEREMOTE: [03/05/13 10:36:16] [1228]       AD:Full Device Path "System?State" in SystemState::CreateDLEs:366
BEREMOTE: [03/05/13 10:36:16] [1228]       AD:ADRO Agent is authorized for System?State.
BEREMOTE: [03/05/13 10:36:16] [1228]       AD:Found 0 instances of Active Directory Applcation Mode in SystemState::GetADAMInstanceCount:1365
BEREMOTE: [03/05/13 10:36:16] [1228]     ADC_FindAgents entered
BEREMOTE: [03/05/13 10:36:16] [1228]     AdcEstablishConnection: , ERROR: Error=8007054B
BEREMOTE: [03/05/13 10:36:16] [1228]     ADC_FindEntries: Could not create ADC instance
BEREMOTE: [03/05/13 10:36:16] [1228]     ADC_FindAgents completed
BEREMOTE: [03/05/13 10:36:16] [1228]     Status 0xE000FE0B returned calling FindDrives for file system 33 in DLE_UpdateList
BEREMOTE: [03/05/13 10:36:16] [1228]     SQL2_FindDrives - the default SQL Service is not running on BACKUP2003.
BEREMOTE: [03/05/13 10:36:16] [1228]     SQL2_FindDrives - checking named instance BKUPEXEC.
BEREMOTE: [03/05/13 10:36:16] [1228]     IsServiceClusterOk called on BACKUP2003
BEREMOTE: [03/05/13 10:36:16] [1228]     Found SOFTWARE\MICROSOFT\Microsoft SQL Server\MSSQL.1 in the registry.
BEREMOTE: [03/05/13 10:36:16] [1228]     VCS cluster keys do not appear to be present in the registry
BEREMOTE: [03/05/13 10:36:16] [1228]     Failed to open VCS cluster ()
BEREMOTE: [03/05/13 10:36:16] [1228]     Found SOFTWARE\MICROSOFT\Microsoft SQL Server\MSSQL.1 in the registry.
BEREMOTE: [03/05/13 10:36:16] [1228]     SQL2_CreateDLE - creating BACKUP2003\BKUPEXEC.
BEREMOTE: [03/05/13 10:36:16] [1228]     SQL Version 2005
BEREMOTE: [03/05/13 10:36:16] [1228]     Found SOFTWARE\MICROSOFT\Microsoft SQL Server\MSSQL.1 in the registry.
BEREMOTE: [03/05/13 10:36:16] [1228]     Found SOFTWARE\MICROSOFT\Microsoft SQL Server\MSSQL.1 in the registry.
BEREMOTE: [03/05/13 10:36:16] [1228]          Setting 2K5 extended feature bit.
BEREMOTE: [03/05/13 10:36:16] [1228]     AddESE_DLEs( )
BEREMOTE: [03/05/13 10:36:16] [1228]     first load attempt of esebcli2.dll failed: The specified module could not be found.
BEREMOTE: [03/05/13 10:36:16] [1228]     Looking for esebcli2.dll in sysetm path
BEREMOTE: [03/05/13 10:36:16] [1228]     never found EseBcli2.dll
BEREMOTE: [03/05/13 10:36:16] [1228]     esebcli2.dll not loaded
BEREMOTE: [03/05/13 10:36:16] [1228]     EV_FindDrives
BEREMOTE: [03/05/13 10:36:16] [1228]     evFileSystem::RefreshTopology()
BEREMOTE: [03/05/13 10:36:16] [1228]     CEvServices::GetEVInstallPath : Could not find EV registry key.
BEREMOTE: [03/05/13 10:36:16] [1228]     CEvServices::GetEVInstallPath : Probably EV is not installed on this machine.
BEREMOTE: [03/05/13 10:36:16] [1228]     This EV version is not supported by Backup Exec.
BEREMOTE: [03/05/13 10:36:16] [1228]     evFileSystem::RefreshTopology: Failed while requesting XML.
BEREMOTE: [03/05/13 10:36:16] [1228]     evFileSystem::EV_FindDrives: RefreshTopology() failed.
BEREMOTE: [03/05/13 10:36:16] [1228]     Status 0x00000001 returned calling FindDrives for file system 37 in DLE_UpdateList
BESERVER: [03/05/13 10:36:16] [3844]     01 Server Configuration: Client removed: 6
BESERVER: [03/05/13 10:36:16] [3844]     -1 Client 'BACKUP2003' Disconnected:0x10ca370
BEREMOTE: [03/05/13 10:36:16] [1620]     FS_ResolveDevName: [Server Farm 1 (SHAREPOINTTEST)]
BEREMOTE: [03/05/13 10:36:16] [1620]     MB2-Resolve returned 1
BEREMOTE: [03/05/13 10:36:16] [1620]     Notes Agent:CLNFileSystem::ResolveDeviceName
BEREMOTE: [03/05/13 10:36:16] [1620]     ADC_ResolveDeviceName: pid = 1368, checking Server Farm 1 (SHAREPOINTTEST)
BEREMOTE: [03/05/13 10:36:16] [1620]     Inside evFileSystem::EV_ResolveDeviceName
BEREMOTE: [03/05/13 10:36:16] [1620]     Inside evFileSystem::IsGoodEVName
BEREMOTE: [03/05/13 10:36:16] [1620]     evFileSystem::IsGoodEVName: GoodEvName failed for (Server Farm 1 (SHAREPOINTTEST))
BEREMOTE: [03/05/13 10:36:16] [1620]     evFileSystem::EV_ResolveDeviceName: IsGoodEVName failed for (Server Farm 1 (SHAREPOINTTEST))
BEREMOTE: [03/05/13 10:36:16] [1620]       VRTSRV:DeviceName Server Farm 1 (SHAREPOINTTEST)
BEREMOTE: [03/05/13 10:36:16] [1620]     RPCDsSession::GetLoginCredentials: Connecting to BEM API as user: BACKUP2003\Administrator
BESERVER: [03/05/13 10:36:16] [3344]     -1 Client requested key (1362447526).
BESERVER: [03/05/13 10:36:16] [3344]     01 Server Configuration: Client added: 7
BESERVER: [03/05/13 10:36:16] [3344]     -1 Client 'BACKUP2003' connected('','BACKUP2003\Administrator'): 0x10c9190
BESERVER: [03/05/13 10:36:16] [3368]     01 Server Configuration: Client removed: 6
BESERVER: [03/05/13 10:36:16] [3368]     -1 Client 'BACKUP2003' Disconnected:0x10c9190
BEREMOTE: [03/05/13 10:36:16] [1620]      machine name = SHAREPOINTTEST
BEREMOTE: [03/05/13 10:36:18] [1620]     ERROR: e000feff Error: unknown error
 

SharePoint Server:

***************************************************************************
*****                  SGMon log for \\SHAREPOINTTEST                      *****
***************************************************************************
BEREMOTE: [03/05/13 05:29:12] [3548]     FS_ResolveDevName: [Server Farm 1 (SHAREPOINTTEST)]
BEREMOTE: [03/05/13 05:29:12] [3548]     MB2-Resolve returned 1
BEREMOTE: [03/05/13 05:29:12] [3548]     Notes Agent:CLNFileSystem::ResolveDeviceName
BEREMOTE: [03/05/13 05:29:12] [3548]     Inside evFileSystem::EV_ResolveDeviceName
BEREMOTE: [03/05/13 05:29:12] [3548]     Inside evFileSystem::IsGoodEVName
BEREMOTE: [03/05/13 05:29:12] [3548]     evFileSystem::IsGoodEVName: GoodEvName failed for (Server Farm 1 (SHAREPOINTTEST))
BEREMOTE: [03/05/13 05:29:12] [3548]     evFileSystem::EV_ResolveDeviceName: IsGoodEVName failed for (Server Farm 1 (SHAREPOINTTEST))
BEREMOTE: [03/05/13 05:29:12] [3548]       VRTSRV:DeviceName Server Farm 1 (SHAREPOINTTEST)
BEREMOTE: [03/05/13 05:29:12] [3548]     FS_BlowOutMachine: entered -->Server Farm 1 (SHAREPOINTTEST)<--
BEREMOTE: [03/05/13 05:29:12] [3548]     FS_BlowOutMachine: device already in DLE list
BEREMOTE: [03/05/13 05:29:12] [3548]     Could not resolve the "bews-ndmp" or the "ndmp" service, error code: 10109, using port 10000
BEREMOTE: [03/05/13 05:29:12] [3548]     ndmpConnectEx: 'SHAREPOINTTEST' resolves to the local machine itself. So, we will try and connect to a loopback address ...
BEREMOTE: [03/05/13 05:29:12] [3548]     ndmpConnectEx : Control Connection information: A connection was established between end-points 127.0.0.1:1095 and 127.0.0.1:10000.
BEREMOTE: [03/05/13 05:29:12] [2284]     ndmpRun: Control connection accepted : connection established between end-points 127.0.0.1:10000 and 127.0.0.1:1095
BEREMOTE: [03/05/13 05:29:12] [3548]     NDMP version 3 connection CONNECTED
BEREMOTE: [03/05/13 05:29:13] [0000]     BECryptoInit: BECrypto OpenSSL FIPS v1.1.1.0 mode successfully enabled.
BEREMOTE: [03/05/13 05:29:13] [0000]     BECryptoInit: BECrypto OpenSSL FIPS v1.1.1.0 mode successfully enabled.
BEREMOTE: [03/05/13 05:29:13] [0232]     LogonType set = [LOGON32_LOGON_INTERACTIVE][0x2]
BEREMOTE: [03/05/13 05:29:13] [0232]     LogonUser(LOGON32_LOGON_INTERACTIVE-0x2) success
BEREMOTE: [03/05/13 05:29:13] [0232]     Successfully impersonated SHAREPOINTTEST\Administrator
BEREMOTE: [03/05/13 05:29:13] [0232]     WhoAmI( ) reports: SHAREPOINTTEST\Administrator
BEREMOTE: [03/05/13 05:29:13] [0232]     LogonuserError: 0
BEREMOTE: [03/05/13 05:29:13] [3548]     NDMPEngine::SetupNDMPConnection(): Using proxy authentication as requested
BEREMOTE: [03/05/13 05:29:13] [0232]     process ready?
BEREMOTE: [03/05/13 05:29:14] [3548]     GetTopology returned c27, from server SHAREPOINTTEST, as user SHAREPOINTTEST\Administrator
BEREMOTE: [03/05/13 05:29:14] [3548]     @@@@@@@MyCloseSocket called with sockfd = 1276(0x4fc) retval = 0
BEREMOTE: [03/05/13 05:29:14] [0232]     @@@@@@@MyCloseSocket called with sockfd = 1224(0x4c8) retval = 0
BEREMOTE: [03/05/13 05:29:14] [3548]     This server is NOT an SPS webserver, according to SHAREPOINTTEST
BEREMOTE: [03/05/13 05:29:14] [3548]     DSEnumerator failed with -536805633: The specified machine is not a SharePoint Server.
 

 

Operating Systems:

Comments 3 CommentsJump to latest comment

pkh's picture

Unfortunately, BE 12.5 only support Sharepoint Server 2007 SP1, not SP2.  See the SCL below

BE 12.5 Software (SCL)

SOLUTION
Bradley Peatross's picture

That is unfortunate, although, In our production environment the exact same verions are used and it registers as a SharePoint server farm.

pkh's picture

When you use an unsupported product, if it works, you are lucky.  If it does not, you are on your own.  You would not be able to open a support case with Symantec.

Time for an upgrade?  It is free if you are on a current maintenance contract.