Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

BE 12.5 Ejects tapes

Created: 13 Oct 2012 • Updated: 14 Oct 2012 | 12 comments
This issue has been solved. See solution.

We have BE 12.5 for Windows Servers installed. We previously had 12.0 running but faced problems with jobs failing having unrecognised media. Then we updated to 12.5 with the same problems. Our supplier replaced the drive, HP StorageWorks, with a new one. Currently, BE doesn't give the said error but ejects the tape itself. We tried running a Test Run and it was successful. However, the full backup job itself won't run and would continuously eject the tapes, even new ones. We tried doing a restoration from previous backup tapes but the job also fails.

Any ideas?

Comments 12 CommentsJump to latest comment

sazz.'s picture

When the tape get ejected?Once it is full or in between when the job is running. Are the tape and drives compatible?

We have BE 12.5 for Windows Servers installed. We previously had 12.0 running but faced problems with jobs failing having unrecognised media

Are these new medias or were used in different software, have you tried erasing and using the medias again.

dark_moonx1's picture

It ejects the tape during the "Loading media".

Our tapes were on rotation. Meaning to say, backup tapes for this week would be stored then re-used or overwritten in a couple of weeks after. Logs would indicate that the tapes were of unrecognised format. We did try doing a full format of one of the tapes but with the same problem. Same goes with newly purchased backup tapes. We had one of our supplier's tech check it and ran a cleaning mode with the cleaning tape but it ejected the said tape. So they had it replaced with a new one. 

Both the old and new drives were detected in the Device Manager as well as in the Devices of BE. Now with the new drive, the tapes are just ejected during the "Loading Media" without any other messages or errors.

I'll post some logs from our BE once I get to the office. 

pkh's picture

1) Did you label the tapes before using them?

2) When the tapes are ejected, did you check whether there is an alert asking you to insert overwritable media?  If so, then the tapes are still write protected because their OPP has not expired.  To use them, you either associate them with the scratch media set or shorten the OPP of the media set that they belong to

 

When you put in a cleaning tape, it will be ejected after a few seconds when the cleaning is done.  This is normal.

In case it is a problem with the tape drive.  Re-install it using this procedure.

 

1) Delete the tape drive from BE
 
2) Stop the media server
 
3) Start the tape drive
 
4) Start the media server
 
5) Ensure that the tape drive is recognised and functioning correctly in the Windows Device Manager
 
6) In BE, install the library if necessary.  Go to Tools --> Wizards ---> Device Configuration Wizard to do so.
 
6) Try again.
dark_moonx1's picture

Hi pkh,

How can I find the OPP status of the tapes and where can I set it? Tape ejection would also happen on newly purchased tapes, not just the re-used ones.

Performing Inventories on the used tapes would succeed. However, doing a Catalog would result in failure with the error below:

 

e0008821 - Job was recovered as a result of Backup Exec RPC service starting.  No user action is required.

sazz.'s picture

OPP set is defined on the media set for eg you might be having weekly,daily, monthly ... etc media sets. Depending upon the media set OPP you won't be able to overwrite the tapes. Also check if they are appendable so atleast you can append them.

What kind of tapes are these? LTO 2,3,4?

What kind of Drive you using? LTO 2,3,4?

Please provide the make and model of drive and tape?

If you are putting a tape and erasing it then it should go to scratch pool and should be able to write on it. If you still have issues check the alerts, system eventviwer for any error.May be the replaced drive is bad one, please make sure the cable connections for the drive is good, they are terminated properly. You can run the drive diagnostics from vendor and try to see if you can write the data from it, the way HP has tape tools other vendors have there diagnostics tools. To me it seems the issue is still with the tape library.

pkh's picture

OPP and AP are properties of the media set that the tape belongs to.  Go to the Media tab, right-click on the media and you would be able to see these properties.

To interpret the tape statistics, when it can be overwritten, etc. See my article below

https://www-secure.symantec.com/connect/articles/t...

When you use new tapes, you have to put them in the tape drive, right-click on the tape drive in the Devices tab and select Label to label the tapes.  Otherwise, you would not be able to use them.

When the tapes eject, go to the Alerts tab and see what alerts are there.  The alerts will tell you why the tapes are ejected.

I would strongly suggest that you familiarise yourself with the Data Management section of the Admin Guide which can be found in the BE installation directory.

dark_moonx1's picture

All tapes are HP LTO-4 Ultrium RW 1.6TB data cartridges with the drive is an HP Storageworks Ultrium 1760 connected via a SCSI port.

Current scheduled jobs are set to run on a daily and monthly basis. 

I'm currently checking with the HP Library and Tape Tool with regards to our drive. The drive is visible in the Windows Device Manager in any case with HP drivers in use.

dark_moonx1's picture

Did two tests with HP LTT. The Read/Write Test succeeded and passed the device and the tape. However, performing an LTO Drive Assessment Test indicated that the media is write-protected (though it is not).

 

sazz.'s picture

The drive is visible in the Windows Device Manager in any case with HP drivers in use

 Could you please try using Symantec drivers and see if it makes any difference. Also it would be good to check the scsi cables or try the new scsi cables.

I hope you have rebooted the backups server after chaging the drive.

dark_moonx1's picture

I have tried to reinstall the drive using Symantec drivers using the Device Config wizard. Then rebooted the server. I've run the full backup job of one of our scheduled daily backup. The drive/BE ejected the tape with "Media is of unrecognised format" in the alerts.

Running the Inventory of the old tapes from Devices>right click drive>Inventory would succeed but media label would be blank. Before it would display as LTOxxxxxxx, but now there's nothing. After the inventory, performing a catalog of the tape would eject the tape after 2 minutes of running with only an alert of Please insert media " in the drive. 

Performing a long erase on an old tape results in a time out.

 

pkh's picture

1) In the Windows Device Manager, confirm that the tape drive is using a Symantec driver and is functioning o.k.

2) Put in a old tape.  In the Device tab, right-click on the tape drive and select label.  Label your tape.

3) Do an inventory on the tape and then a small backup to this tape.

Make sure you are using LTO3 or LTO4 tapes.  The tape drive cannot write to any other previous generations of tapes.

dark_moonx1's picture

It seems by boss reinstalled the whole BE application and reconfigured all settings to defaults. As per him, backup is working and is now trying to restore from old tapes.

Thanks for the help. I did love to have it resolved and get the bottom issue without having to rely on reinstallation of the software. 

SOLUTION