Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE 2010 B2D : don't have access to more than 1 day recovery history

Created: 19 Feb 2013 • Updated: 20 Feb 2013 | 9 comments
This issue has been solved. See solution.

Hello everyone,

I have a problem I can't seem to be able to solve on my own.
A little background : using backup exec 2010, we used to backup around 850 GB of data every night on LTO4 tapes.The tape drive failed, so I tryed to switch to an iSCSI attached drive to do backup to disk. I created a backup folder on said disk leaving every thing on default ( 4GB file size, 100 saves / files ). On the job, I set up a 5 days data protection.

The job is running well, but when I check the restoration menu, I only see the last backup available for recovery. None of the 4 others I would like to get.

So, there is enough room on the attached disk for the 5 days of backup history ( 7 TB left atm) and I noticed that whatever I do, there are 150 backup files in the folder I set up for backup. Like there is some limit set up somewhere and there is a set (150x4) 600GB of disk space set for this backup job ( wich obviously should not be enough for our 850+ GB of data, maybe compression is very good )

I guess I am missing something easy, but I can't find the option and can't formulate a good question on google to get any info.

Hope someone can help.

Cheers !

Raph

Comments 9 CommentsJump to latest comment

Gurvinder Rait's picture

Have you confirmed looking at the backup job log that the data being backed up is 850 gbs. Please verify the selection of the backup job to ensure everything is selected properly and no exclusions set.

Raphael.giudici's picture

Hello !

I checked the log for the last backup (last night) and it backup up 886GB of data.

The selection seems to be ok.

pkh's picture

Go to Tools ---> Options ---> Data Management and check that the Overwrite Protection Level is set to Partial or Full.

On the job, I set up a 5 days data protection.

Describe how you do this because from your description, it would seem that your OPP is less than 1 day and your job is overwriting the previous day's backup set.

Raphael.giudici's picture

Hi !

Thanks for taking the time to help. I checked the Overwrite Protection Level and it was already on "None".

BTW we have BE 12, I made a mistake in my original post.

I will try to describe how I set up the job, but as my BE installation is in french, I might not use the correct words :

In "Devices" I set up a new Backup to Disk Folder leaving the default options.

In "Media" I create a media set with 5 days protection against overwrite but adding to the media set possible.

In the backup job, I set "add to media, erase if no media is available for add"

Colin Weaver's picture

Overwrite Protection set to None means ignore the protection  settings in the media set and just use the oldest first - change this setting it should not be "None"

Raphael.giudici's picture

Well, overwrite is set on 5 days protection.
Adding protection is set on None.

pkh's picture

Sorry.  I made a mistake earlier when I said the OPL should be set to Partial or None.  It should have been "set to Partial or Full"  If you set the OPL to None, that there is no protection at all and all your OPP setting does not apply.  This explains why your backup sets are overwritten.  You got to set the OPL to either Partial or Full, not None for overwrite protection to work.

SOLUTION
Raphael.giudici's picture

It worked thanks !
Too bad there is a not so obvious option that overwrite the settings of your job.

Cheers !