Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE 2010 CPS : very long time for indexing a snapshot

Created: 14 Oct 2010 • Updated: 01 Jan 2013 | 7 comments
This issue has been solved. See solution.

Hi,

 

since we have installed BE 2010 CPS, it takes more than one day for indexing only one snapshot.angry

 

Before, with release 11d, it took almost 1 hour.

 

Why it is so long with BE 2010 R2 ?

Comments 7 CommentsJump to latest comment

CraigV's picture

Hi ramfast,

 

I believe you already logged this, and I answered it for you here...

 

https://www-secure.symantec.com/connect/forums/be-2010-cps-very-long-time-indexing-snapshot

 

If it helped at all, please close it off with the solution. THe article above explains how, and why, it works the way it does...

 

Craig

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

RahulG's picture

Try the following ans see if this helps

1. Stop all CPS services
2. Rename rsa.db and rsa.log to rsa_db.old and rsa_log.old.
3. Rename the \CPS\Index directory to Index.old.
4. Start the CPS services; the CPA database files and Autonomy Index directory will be replaced automatically.  This re-syncs the snapshots
Check if there is any connectivity issue between the servers
Colin Weaver's picture

As I anwered in your other post

Please review this

http://www.symantec.com/docs/TECH141776

Bengaul's picture

Hi, 

I am having this problem as well, and going by the last post, it is not much of an answer! The indexing is taking almost a day, and to point to an article that simply states the indexing will take longer is cold comfort. 

I am trying at the moment to rename the rsa.db, and rsa.log and the Index directory, but it is still early days and I don't know if it will be any quicker.

Is this something that Symantec are working to improve, or are we faced with this issue for the foreseeable future? If this is how it is going to be, it pretty much subverts the whole point of CPS, as I may as well stick with the usual backup. It is also a bit much that the Indexing can bring a Intel Xeon Quad core CPU with Hyper-Threading enabled, and 12 Gig of RAM to it's knees!

UrbanLegendPA's picture

This may solve the problem for many Installations.

I have had this same problem. the process indexer-service.exe was using all available CPU and with the process set to NORMAL priority everything else would slow to a crawl. I have researched this problem extensively and found no workable solution. I tried scheduling a job to stop and restart the indexing service periodically and it helped, but periodically the problem would recur.

I have a solution that works for our installation. We use CPS to backup 2 servers; an Exchange Server and a SQL server. Both Servers are backed-up nightly using remote agents and CPS set for continuous protection. When we need to restore one of these servers, we use Backup Exec and the IDR option to rebuild the machine. Then we use CPS to restore the databases to their state at the time of failure. Since we select the files to restore and do not need to use the search feature to find files the CPS index is not needed.

Since we don't need the snapshot index we uninstalled it. Problem solved! To uninstall the indexing feature, run the CPS setup, selected additional options, and remove the Indexing component from the list of features to be installed. After the installation completes, a reboot was required. The indexing feature is gone and no longer a problem for us. After removing the CPS snapshot indexing feature we had problems with the CPS agents connecting to the CPS server. We traced the problem to the Windows Firewall blocking the inbound connections. After allowing the connects, everything worked perfectly.

I hope this helps!

If you do need the CPS snapshot indexing feature then this won't help. Sorry.

SOLUTION
Bengaul's picture

Thanks UrbandLegendPA!

It would seem that is the answer for us as well. Knock indexing on the head and get on with your life! Such a shame it's a bag of spanners.

R3Tard's picture

You could always try and set your processor affinity to use only one processor or half of the cores if you running multi core processors. That way your syetem will continue to index and leave some processing power for the operating system and other functions

1. Start Windows Task Manager

2. Click on the processes tab

3. Find the process called indexer-service.exe and highlight then right click and choose 'Set Affinity'

4. Then choose how many processors or cores you want the service to use

5. Click ok

Worked beautifully for me =)