Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

BE 2010 R3 : Backup files take much more space than the actual backuped files !

Created: 16 Apr 2014 | 21 comments

Hello everybody,

We use BackupExec 2010 R3 (under W2008R2) to backup data from a Windows 2008R2 file server, and an Exchange 2007 server.

The storage space for backup files is located on the backup server itself. This space is also used for other backups (not through BackupExec, but using SFTP on Unix servers).

Our Windows file server holds about 2,7 TB of data (and not all is backuped).

On our backup server, the *.bkf files related to our file server take an amount of 3,48 TB ! According to the modification date of these *.bkf files, they are all actively used.

It seems that BackupExec expands the size of the backup files until it reaches the total available space on the device. Due to this, the other SFTP backups don't work properly.

Is there a way to avoid such behaviour of BackupExec 2010 R3, forcing it not to exceed a specified amount of disk space ?

Thanks for reading, have a nice day

Operating Systems:

Comments 21 CommentsJump to latest comment

pkh's picture

Go to the properties of the B2D folder and set the low disk space threshold

RahulG's picture

You have to check the properties of your backup to disk folder .

The option to allocate max size to backup to disk file would be checked in your case.

Colin Weaver's picture

If it is all BKF files and no IMG folders then you could save space on disk by enabling software compression in your backup jobs. IMG folders are created by GRT enabled jobs and don't compress.

It is possible that some things in the System State are also backed up in the backup of your drive letters which would add to the size a little.

RahulG's comment above may also apply although you may not be aware that BE 2012 and BE2014 (when released) handle the allocating maximim size scenario in a way that a) allocates the size in steps and not all in one go and b) truncates the unused space when the job finishes which would help avoid this scenario. I would wait for BE 2014 before upgrading from 2010 R3 though as BE 2012 does restrict to the single server  per job model which provides some challenges.

elanclan's picture

Thanks for your quick answers.

In the properties of the backup to disk folder, under the "General" tab

  • the maximum backup file size is set to 4 GB (which is OK in our case)
  • the "allocate max size to backup to disk file" checkbox is currently unchecked
  • the maximum number of backup sets per backup file is set to 100

Under the "Advanced parameters" tab

  • the "low disk space threshold (suspending backup operations)" checkbox is checked
  • this threshold is set to 5 GB

When I check the "allocate max size to backup to disk file" checkbox, the "maximum number of backup sets per backup file" option disappears. I understand I should not check it in my case, is that correct ? (RahulG's comment)

I am a little bit afraid of the "suspending backup operations" mention by the low disk threshold setting. Does it mean that the backup would be only partial once this value reached ? (pkh's comment)

The type of compression in the backup job is "Hardware, [if available, otherwise software]". (Colin Weaver's comment)

Any further help would be appreciated !

Kind regards

elanclan's picture

I've just seen that in the B2D support list, about 40% of backup supports are in blue color, with "Deletable" (or "Rewritable", or "Crushable") mention in the "Deletion protection period up to" column

And for all the backup supports (in blue color as well as in black color), I have

  • "Adding impossible (support is full)" mention in the "Possible data adding up to" column
  • used capacity 4,0 GB
  • data 4,0 GB.

Does it suggest that compression does not actually work ?

Sorry if some columns or mentions are unaccurate, since I have to translate them to English.

pkh's picture

No.  This has nothing to do with compression.  The media is full hence it cannot be appended to.

You got to do a couple of things.

1) Make sure that your jobs specify Overwrite.  Do not use Append because this will prolong the protection of the media.

2) Check the Overwrite Protection Period of your backup sets.  If they are set too long then they will occupy unnecessary disk space.

3) Go to Tools ----> Options -----> Media Management and change the setting to use recyclable media in the targeted media set before scratch (circled in red)

BE 2010 - Media Management.png

elanclan's picture

Thanks again for your answer.

I've made the changes, let's see what happens in the next 24 hrs.

How can I safely erase the unnecessary files ?

Can I delete all files marked in blue color, with the "Overwritable" mention (using the media set settings) ?

pkh's picture

You can delete the overwritable media. Associate the overwritable media with the Retired Media Set, right-click on them and select delete. This will delete them from BE. You then need to go to Windows Explorer and delete them from the disk

elanclan's picture

Backup was suspended during last night, due to lack of free space.

I've deleted the "overwritable" files, and got more than 1 TB of free space.

Wait and see..

elanclan's picture

Hello,

After manual cleanup by the end of last week (according to pkh's las comment), our backup folder size was 2,19 TB.

Now, after the weekly backup, size is still growing (3,30 TB this morning).

222 files of 4GB each are still marked as "Overwritable" in the B2D media list. I have just deleted them : backup files now take 2,45 TB.

So, thanks to your help I have a manual workaround. But I still need a solution which requires no manual action.

Kind regards

RahulG's picture

As suggested by PKH you need to set the backup job to Overwrite and not append, that should take care of the issue and you would not need any manual intervention.

elanclan's picture

Backup jobs are set up by a policy.

In the properties of this policy, under the "Peripheral and media" section, the "At the begining of this job" radio button the setting is already "Overwrite the media"

Is there another similar setting somewhere else ?

elanclan's picture

Obviously this setting, which is in place since one week, is not taken into account by BackupExec.

Is there a way to fix this ?

Note : server was rebooted a few times.

pkh's picture

You got to be more specific about what is not working for you

Halwa Wala's picture

What is the retention period used for incremental backups? One of the reasons why a media may not be getting overwritten is because that media contains a backup set on which other(incremental) backup sets depend.

elanclan's picture

What is not working : used space for backup exceeds the sized of the backuped files, and is still growing

Retention period : In the properties of the policy, under the "Peripheral and media" section

  • media set is "daily media set" for daily incremental backups
  • media set is "weekly media set" for weekly complete backups

The possible choices for this item are

  • Keep data infinitely (forbid overwrite)
  • Keep data for 1 day
  • Keep data for 4 weeks
  • Keep data for 5 days
  • Weekly data set
  • Daily data set

Is there another place where this value can be set ?

Current files are protecetd for overwrite up to April 26th (today is 23rd). I have deleted manually all the "overwritable" files earlier today.

pkh's picture

Suppose you currently have 1TB of media on your disk and your daily backup, Mon - Fri, is 100GB each.  If you have set BE to use recyclable media before scratch and your OPP is 6 days. On the Monday of the second week, you would have 400GB of protected media and 600GB of overwritable media. This is the steady state.  Unless your data grows, you will always have this much of protected and overwritable media.  The overwritable media will not be deleted from your disk.  They would only be re-used.  If you want to reclaim the space, then you have to associate the overwritable media with the retired media set, right-click and delete them from BE. After this, you can then delete the media from your disk.  In this example you can at most reclaim 500GB of disk space because you have 5 backup sets of 100GB each.

You should check the properties of your media set to make sure that the OPP is set correctly and is not set to retain media for too long.

Halwa Wala's picture

One thing you could try is go to the physical location where the disk storage is created. At the root of the folder, you will see 2 .cfg files. Cut-paste them to another location and restart the backup exec services. Hope this helps.

elanclan's picture

Hello,

I was waiting a few days to see the actual behaviour of BEx after the first modifications made thanks to your comments.

Unfortunately, the used space is still growing (2,71 TB today after weekly backup).

I have a workaround with the manual delete of overwritable files, but I would prefer a fully automted solution.

The Overwrite Protection Period of the media set is 1 week, the append period is 1 week too.

I will try now to rename and move the two .cfg files located at the root of the physical location where the disk storage is created, as Halwa Wala suggested. I will tell if it helps.

Thanks