Video Screencast Help

BE 2010 R3 Services Problem

Created: 18 Jul 2012 • Updated: 25 Jul 2012 | 9 comments
This issue has been solved. See solution.

We have been using Backup Exec 2010 R3 successfully for several months now.  It is used to back up a single server (Windows Small Business Server 2011 Essentials - code base is Server 2008 R2).  Perhaps coincidentally, we installed some server OS updates from Microsoft yesterday (which required several sever reboots), and Backup Exec has not been working since that time.

I went through the Event Viewer error logs and found the following problems:

1). Application Log - Warning.  Source: SQLBrowser.  Event ID 3.  Message Text: "The configuration of the AdminConnection\TCP protocol in the SQL instance BKUPEXEC is not valid."

2). System Log - Error.  Source: Service Control Manager.  Event ID 7022.  Message Text: "The Backup Exec Server service hung on starting."  When I look at the services list, the BE Server service status is locked on "starting, as opposed to started.  It cannot be manually stopped.

3). Next come additional System Log errors (Event ID 7001) indicating that the Backup Exec Agent Browser and the Backup Exec Job Engine have both failed to start because they are "dependent on the Backup Exec Server service, which failed to start because of the following error: 'After starting, the service hung in a start-pending state.'"

I would greatly appreciate any assistance in getting this problem resolved so we can resume our server backup again.  Thanks very muich.


Comments 9 CommentsJump to latest comment

VJware's picture

Try this KB -

And also, check if you are able to kill the beserver via the task manager or not..

Jayb's picture

Try the link

and make sure we are able to start the SQL service as the rest of the backup exec services are dependent on the SQL.

Start the Backup exec remote agent

Then start the Backup exec device and media service.


John_N's picture


Thanks for your suggestions.  I apologize for the delay in responding, but I have been out of the office the last few days and just returned today.  I wanted to trace through the problem again before writing back to you.

Are you saying that the SQL service has to load properly before any of the Backup Exec services will operate?  If so, then the SQL service does not appear to be the problem here.  Both the Backup Exec Remote Agent and Backup Exec Device and Media services loaded without error and are shown as "running."  The problem seems to start with the Backup Exec Server service.  That does not load correctly.  It appears to hang in a "starting" ("start pending") state.  The next two BE services (Agent Browser and Job Engine) fail to start because the BE Server service apparently needs to be running first, and it is not.

As I mentioned, in terms of history, BE has been running fine for over eight months until this problem surfaced last week.

This is not my area of expertise, so I really appreciate any direction and assistance you can offer.


Jayb's picture

Ok if beserver does not start , and stays in starting state...

Check the "Data" folder under c:\program files\symantec\bacup exec\data.

Check if any .xml files are huge (Typically they should be few mb's only), if you find something huge with the latest date , may be that could be the reason , so let rename those files and try restarting the beserver service.

Also :

Go to the backup exec location in command prompt :

c:\program files\symantec\backup exec

and then run "beserver -console"

and post the output :)


John_N's picture


I was able to check the size of the XML files in C:\Program Files\Symantec\Backup Exec\Data with no problem.  The largest XML file is 39 KB, so that doesn't seem to be the culprit here.

I then tried running BESERVER -CONSOLE, and it generated quite a few screens of output.  It never returned to the C prompt, though.  It stopped at the line "-1 RpeXfaceServiceMain: Initialization BOs <> failed BO:-1 nRet=4313."  I had to type "Q" (quit) to exit the program and get back to the command prompt.

Since this took several screens, I thought I would dust off my old DOS piping output commands and try and save the BESERVER -CONSOLE output to a text file, which I could then upload here.  Initially I received an "Access is Denied" error when I tried to generate an output file.  Not being familiar with BESERVER, I then tried a simple DIR command, with the output routed to TEST.TXT.  Same error message (access is denied).  This sounded like a directory rights problem, so I ran the command prompt as the administrator ("run as administrator").  That worked in that I no longer received the "access is denied" error.  However, the program never returned to the command prompt.  Presumably it was stuck at the same point desribed above, but I couldn't see the actual output once the piping command worked.  I had to "break" (CTRL-C) out of BESERVER -CONSOLE to get back to the command prompt.  The only problem with that is that the TXT output file was empty (zero bytes), so I could not upload the program's output.  If you can suggest a way I can get the output of the BESERVER program to you, please let me know and I will follow your suggestion.

In the meantime, the best I could do was to capture most of the output via the Windows Snipping tool.  The command box on the screen did not extend all the way to the end of the text lines, so some of the program output is truncated.  Below please find what I could get, which will hopefully be of some use.  I will try and send you better output if there is a way to do so.  There are two files in all, which I will attach to this note.

Thanks again for your help with this.


BE Server Output 1.PNG BE Server Output 2.PNG
Jayb's picture

How to debug the Backup Exec Server service

Also check the event id at that moment for any errors.

It could be the Application or even .net.

Before trying any of the above, if there endpoint or any security application , plz disable them and then try.


John_N's picture

Thanks for the suggestions, Jay.  I have tried each one.  First, I disabled both the anti-malware/security software on the server (Symantec Endpoing Protection), and also the WIndows firewall.  Next, I changed the login account used by the Backup Exec Server service from myself to the Local System Account.  Unfortunately, none of these changes had any effect on the stalled BE Server service. 

The only way I was able to stop BE Server (even though it never fully started) was via the TaskKill command.  Each time I tried to start it afterward, it got locked in the "Starting" state.  I did get a Windows error when I tried to restart BE Server from the Services.Msc program.  It was an Error 1053 (the BE Server service timed out and never started).  I have attached a copy of the Application event log containing this error to my message.  There were no other Windows event viewer log entries beside this Error 1053 one.

Beyond the above, here is what I tried:  1) Stopped the BE Server service via the TaskKill command.  2) After verifying that the service had in fact stopped, I tried to manually start it within the Windows Services snap-in (Services.Msc).  No luck, it hung as noted above.  3) With this service still hung, I ran BESERVER -CONSOLE (see the attached log files for details).  That program also stopped after displaying several screens of information, and I had to use the Q (Quit) command to exit and get back to the command prompt.  4) Next, I killed the service again with TaskKill.  5) I then started the Backup Exec program as usual (Start > Programs), and ran the Backup Exec Services Manager.  I then stopped all running BE services, then tried to restart them through the BE Services Manager.  As you can see from the attached debugging log files, I was never able to get the BE Server service to work under any conditions.  The BE services before it loaded fine, but of course the following BE services that are dependent on the Server service did not start either.

Please let me know if you see anything helpful in the attached log files.  Thanks again for your help with this stubborn problem.


SERVER-SGMon.txt 15.98 KB
SERVER-SGMon2.txt 132.17 KB
Application Log Error.txt 506 bytes
log_beserver.txt 16.19 KB
Jayb's picture

Based on the logs attached i see the IPv6 is enabled.

If IPV6 is not in use , try disabling it.

Apart from that i see only a block, which you have disabled.

If nothing works , plz reply back little early so i can reply back on the same day.


John_N's picture

We were able to solve the hung BE Server service problem today with a cold reboot (complete power off, then on again) of the server.  Once we did this, BE loaded and worked perfectly, as it had for the previous eight months.  I would have never thought of a hard reset of the server, but our network engineer remembered some times back in the past when BE would lock up loading services on machines that used a tape drive for backup.  The current server has an internal Dell RD1000 disk cartridge backup drive, rather than tape.  In the past, the cold reboot would reset the tape drive backup hardware and resolve an interaction problem between the hardware and BE software.  I would not think that this "fix" would apply to a disk drive, but luckily it did!  We spent a great deal of time trying to resolve this problem, and I'm just glad the server is being backed up again.

Thanks again for all of the time you spent working with me on this problem.  You may want to add "cold server reboot" to the list of possible fixes if this problem occurs again for someone in the future.