Video Screencast Help

BE 2010: Tape drive offline again

Created: 23 Jan 2013 • Updated: 24 Jan 2013 | 3 comments
MIXIT's picture
This issue has been solved. See solution.

Hi all.  An issue occurs from time to time where the external SAS single LTO5 tape drive attached to a server powers off, for example if the tape operator accidently hits the power button rather than Eject or something.  The server stays up, of course.  The result, after powering back on the tape drive is that the drive shows as offline in BE.  Even if you right-click and mark it Online, it goes back to offline in a few seconds.  So far the only solution I've found is simply to reboot hte server. 

Speaking from a BE perspective, or even just froma general servertape drive hardware angle, what's up with this?  Is there some trick I'm misisng?  This is a Dell server, with aDell tape drive.  It's as common a setup as you'll get anywhere and I can't imagine everybody runs into this same problem.  The tape drive firmware is up to date I believe, though I will check into that to be sure. 

Does this seem more a BE thing or a server/hardware thing? 

Thank you. 

Comments 3 CommentsJump to latest comment

Sush...'s picture

Hello Mixit,

    This is moreover Hardware and OS issue.

Backup Exec gets the information of the Tape drive connected to it from Windows OS. So when the tape drive is Powered OFF and then ON again and if it not detected in the Device manager of Windows then Backup Exec will definately show it as Offline.

You may try to perform "Scan for hardware changes" in the Windows Device manager and see if that helps. But as drivers needs to be initialised it may not show up.

 

Thanks,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

CraigV's picture

Have you tried to rescan for new hardware in Windows, and then followed this up with a service restart using BEutility.exe for BE?

If power to the drive goes down and BE marks it as offline, then a service restart (sometimes a server restart) might be necessary...but if Windows doesn't see the drive, neither will BE.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION
MIXIT's picture

The device already showed in Dev Mgr, and a rescan in there didn't change anything with what was listed.  Just a LTO Tape Drive.  This is the BE driver, version 5.1.37.0 dated 2/12/2008. 

But it turns out this time, the problem was fixed by stopping/starting the services (just via BE console, not BEUtility.exe). 

Speaking of which, I haven't used BEUtility.exe yet, looks interesting though.  I've been putting off getting more in depth with BE for a while now due to other training, but will be doing STS for it over the next few months so I'll soon probably stop asking such basic questions :)

So this issue may still havfe been HW/OS, even though the drive still shows in devmgr, maybe the rescan forced it to talk again.  We all know how useless Devman's "Your device is working properly" status is :)

Or maybe just restarting the BE services was the trick, though last time this problem occured I don't think it did.  Next time it does, I'll not do the devman rescan and just the BE svcs and we'll see, hard to remember right now. 

Thanks guys.