Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE 2010 VSS error

Created: 25 May 2010 | 11 comments

Dear All

I recently upgraded our Backup Exec from v12.5 to v2010. After upgrade, I am facing problems with a number of backup jobs.

One error I am seeing very frequent is the following:

V-79-57344-34070 - AOFO: Initialization failure on: "\System?State">\\<server_name>\System?State". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).
Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them. Check if files were deleted or renamed.

Firstly, I have not specified to use AOFO for this backup job, so not sure why it is still indicating it is using it.
Secondly, I have followed a number of different articles and suggestions, but it still fails.

If I understood the documentation correctly, the AOFO comes default with the remote agent license and does not need to be licensed specifically.

Appreciate your help.

Best regards,
Thomas

Comments 11 CommentsJump to latest comment

pkh's picture

Install the VSS Rollup fix http://support.microsoft.com/kb/940349 on the problem server, reboot and try the backup again.

thomas_olsen44-123's picture

pkh

Thanks a lot for that advice. I will definitely install this patch at the first convenient time and test again.
I'll post back here once I have tested.

thomas_olsen44-123's picture

So I installed the VSS Rollup fix on the servers that failed, and it appears to have solved the issue on some of them.
However, backup is still failing on some servers even after installing the fix (and restarting those servers). The error only happens for System State backup.

Another thing which doesn't make sense is that the message says AOFO is used, even if that is not ticked in the job.

In my selection list for all my servers, I select C: drive, System State and Shadow Copy Component.
I am unsure if Shadow Copy Component should be selected and what this actually backs up.

Maybe someone can shed some light on this.

Regards,

pkh's picture

Just a long shot.  I am not sure if this will solve your problem.  See the last post in this discussion

https://www-secure.symantec.com/connect/forums/aofo-unable-backup-system-state

Dev T's picture

Hello,

Make sure that the "Volume Shadow Copy" and "MS Software Shadow Copy Provider" service is stopped and the Startup Type is "Manual"

Hope this helps....

Its a best practice to have a "Support Contract" with Symantec...
 

Symanticus's picture

ok, how about checking the status of the VSS writer in the failed system ?

Ensure that all of the VSS writers are stable and that they are not reporting an error. Run the command:

C:\Users\Workstation> vssadmin list writers

The output for each writer appears similar to:

Writer name: 'VSS Metadata Store Writer'
Writer Id: {75dfb225-e2e4-4d39-9ac9-ffaff65ddf06}
Writer Instance Id: {088e7a7d-09a8-4cc6-a609-ad90e75ddc93}
State: [1] Stable
Last error: No error

Ensure that the State is Stable and that the last line of the output is Last error: No error.

see if any of the options is failed ? if yes, then go with the following steps:

1. Backup the following regkey: _*HKLM\Software\Microsoft\EventSystem* _
2. Erase the regkey HKLM\Software\Microsoft\EventSystem{26c409cc-ae86-11d1-b616-00805fc79216} an below 
3. Reboot. 
4. Verify that things are working by running

vssadmin list writers
vssadmin list providers. 

/* Infrastructure Support Engineer */

thomas_olsen44-123's picture

Thanks a lot for all the suggestions.

I have verified that the registry key has the correct permissions.
VSS and MS Software Shadow Copy Providers services are both Manual
vssadmin list writers list no errors.

I have also removed the backup agent and installed it again on one of the clients which are still failing, but it didn't help.

For this particular server, I have three selections; C:\ drive, System State and Shadow Copy Components.
C:\ drive backup works fine, but both System State and Shadow Copy Components jobs are failing.

And the error still says "Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS)." even if I am not using AOFO.

Appreciate some help.

Best regards,

thomas_olsen44-123's picture

If I rightclick on any of the disks in any of my Windows servers, there is a tab for "Shadow Copies".
Do I have to enable this in order for my snapshot backups to work?

Or if "Shadow Copies" is indeed enabled, can this cause issues with my snapshot backups?

Best regards,
Thomas

Colin Weaver's picture

Don't know the answer for the actual problem but for info - you are seeing the AOFO error even though AOFO is not specifically enabled because the correct way to backup the System State is via a VSS snapshot - and it is also VSS that AOFO uses and as we don't interpret the reason for calling VSS a slightly misleading message is  returned indicating an AOFO issue when in reality is is a VSS issue against the system state.

On the system where it does not work are you using a local admin account (or domain admin if it is a DC) as we have identified that Backup Operator is not really enough to do VSS requests of System States

thomas_olsen44-123's picture

Colin

Thanks a lot for the information.

I am using a dedicated account to back up everything. This account is currently member of Domain Admins group.

On one of the servers I saw this problem (2003 server), I enabled "Shadow Copies" on the C drive and it seems to have fixed the issue.
The weird thing is that backup is successful on other 2003 servers where "Shadow Copies" is not enabled for the C drive.

Doesn't seem to be consistent.

Kim Stroem's picture

Thomas

I don't know if you're problem has been solved. As I read you're comments You have 2 vss providers. One from Microsoft and another one. I had a similar problem that was solved by deleting the other provider. I copied the provider id and used that as a search string in regedit. Remember to backup the registry before deleting anything :-)

Best regards

Kim