Video Screencast Help

BE 2012 - Add Exchange DAG error "Cannot insert a resource container"

Created: 05 Sep 2013 • Updated: 05 Sep 2013 | 9 comments
patboy's picture
This issue has been solved. See solution.

I try to add an Exchange Database availability group in BE 2012 using the "Add a Server" wizard. All the latest hotfixes and patches are installed. The wizard works until the last process (see picture). I'm unable to find anything about this error.

Does anyone have any ideas?


Operating Systems:

Comments 9 CommentsJump to latest comment

lmosla's picture


What version of Exchange is this? 

lmosla's picture

Try removing and readding the Exchange license along with removing and repushing AWS.

patboy's picture

If i remove the "Agent for Applications and Databases" license, is this going to break all the backup jobs for SQL, Active Directory, etc. ?

Which side effect will this have?

Donald Eady's picture

How many machines are in the DAG "2" it would appear that there are only 2... i f there are morePlease verify that all machines in the DAG have successfully installed and started the Remote agent...

I hope this posting was helpful


patboy's picture

There are 2 member servers in the DAG. The BE Agent service is up and running on both servers and the trust is established. The media server only see the Windows Cluster object that are reported by the agents and it did not recognize the DAG.

patboy's picture


This is not an upgrade from a previous version. This is a brand new installation (less than 2 weeks).

I have 2 datacenters with one BE 2012 server on each. I just test adding the DAG on my BE server in my second datacenter and the wizard completed successfuly.

So, I think that the problem is with the BE SQL database in my first datacenter.

patboy's picture

Finaly, I opened a support case and we found what caused this error.

My mistake was when I created a group for my Exchange servers in BE2012 in which I added my tow Exchange servers and the Windows Cluster node with the name of my DAG. Then when I tried to add the DAG using the wizard "Add a Server", the wizard was unable to add the informations in the BEDB probably because it saw a conflict.

To correct the problem, I only removed the cluster node from the server group and I was able to add the DAG to BE2012.