Video Screencast Help

BE 2012 Compression ratio

Created: 17 Sep 2013 • Updated: 18 Sep 2013 | 17 comments
This issue has been solved. See solution.

Hi All,

 

I am using HP LTO-3 Ultrium 800 as my backup media. Under storage, the media storage capacity is 391GB and compression ratio is 1.0:1

 

How do i make it 2.0:1 for ratio?

FYI: I enabled compression and encrpytion for my backup job and now it reported no enough space.. my last backup byte count was 468GB.

 

Please help

 

 

Operating Systems:

Comments 17 CommentsJump to latest comment

ahtshun's picture

this backup was working well before i enable encryption. I created encryption key as 256-bit AES under BE 2012

Previously successfully job only got compression enabled "Hardware if available otherwise none"

 

will this a cause to my job failure?

 

 

CraigV's picture

Hi,

It's highly doubtful you will ever get 2:1 compression unless you're only backing up text files. Different file types compress differently. However, enabling compression will ensure that the levels of comression you got before, won't happen again due to the overhead placed on the files while encrypting them.

You can ensure that Hardware encryption is used, as this uses the capabilities of the drive, and not the resources of the server using Software encryption.

Thanks!

EDIT: check below for more information:

http://www.symantec.com/business/support/index?page=content&id=HOWTO21799

 

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

ahtshun's picture

Yup i enabled hardware encrpytion under backup job - storage and uses 256 bit encryption key.

Before this option enable, all my job run well. Now it said media full,insert another media.

Any idea why?

CraigV's picture

LTO3 is capable of 400GB native, and 800GB compressed capacity, assuming 2:1 which isn't possible in real-world scenarios.

You're getting that alert as you are getting no compression, hence you're only hitting the native capacity of the tape, namely 400GB. You either need to live with this and use multiple tapes, but have encryption, or turn off encryption and go back to fitting everything onto 1 tape again.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Rahul Kumar1's picture

Hi,

      It is not recommended by Backup exec to have both Encryption and Compression option enabled together. When you enable encryption then compression does not happen. So in order to enable compression on tape please turn off encryption.

Thanks

pkh's picture

This is not true. You can have both encryption and compression, provided they are both either hardware or software. If you have software encryption and hardware compression then you will get very bad compression ratio

CraigV's picture

...do you have some sort of documentation around this?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

LTO3 does not support hardware encryption. You are probably using software encryption. This combined with hardware compression gives you the bad compression ratio. Use software encryption and software compression and you should be fine

SOLUTION
ahtshun's picture

Hi PKH,

I tried your method to use both software on compression & encryption. However, the compression ratio under storage tab still show 1.0:1.
 

i got a few backup media LTO3 ,some shown as 1.9:1 as ratio.

 

Any idea?

pkh's picture

This is correct because the data are already compressed when it is sent to the tape drive.  To see what the compression ratio is, take a look at the job log or divide the amount of data on the by the amount of data at the source.

Suppose you have 2GB of data on your source disk.  If you use hardware compression and the final result is that 1GB of data is written to the tape, then your compression ratio is 2:1.  If you use software compression, the 2GB data is compressed to 1GB before it is sent to the tape, hence you get a 1:1 compression ratio.

ahtshun's picture

Hi Pkh,

I did check the backup log. The byte count is the same with the backup source file even software compression is enabled.

i did use tracer.exe ..seem like no compression.

 

any idea?

pkh's picture

If you use software compression and you still don't get any compression, it means that your data is not compressible.  For example, you have zipped or movie files, sound clips or picture in your source.  See my article below on the subject.

https://www-secure.symantec.com/connect/articles/c...

To test your compression, create a test directory and fill it with text files.  Back this up both with software and hardware compression and you will see good compression ratios.  You can even throw in encryption in your test.

ahtshun's picture

Thanks pkh for the great article. Now i'm fully understood.

BTW do you have article on LTO 4 and above?

I am running a test job. Hopefully it will work..update u again

pkh's picture

do you have article on LTO 4 and above?

What information are you looking for?

Rahul Kumar1's picture

Hi,

       Here is a document supporting what I stated earlier.

 http://www.symantec.com/docs/TECH135848

Thanks



 

 

CraigV's picture

Well, strictly what you said is untrue. The TN above doesn't recommend not using compression and encryption together. It simply states that files can be 5% bigger.

The Related Article states that hardware compression shouldn't be used. Instead use software encryption. So there is nothing in either of them stating that Symantec doesn't recommend using compression and encryption together, as per 1 of your previous posts.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

ahtshun's picture

i recreated a job, enable both software compression and encryption and my job successfully.

 

thanks everyone for your advice/suggestions.