Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE 2012 - GRT Enabled Backup - Full VM Restore

Created: 20 Mar 2013 • Updated: 21 Mar 2013 | 4 comments
This issue has been solved. See solution.

Hello,

Simple questions for which I am reading different responses on the web, so hoping someone can provide a concise answer.

Context: Backup / Restore functionality within BackupEXEC 2012 for VMware 5.0 Environment, VMware Agent in Guest.

When a backup job is formed for a VM through the registered ESX host or VirtualCenter Server (within BE2012), what is the answer to the following question.

Q1. When the Job has GRT Enabled (and it completes successfully) (Agent installed in VM), can a Full VM restore be performed off that backup? or can it only be used for File / Folder / Object level restores?

I am seeing different answer on the Web, some people say you need to have two backup jobs for each VM, one with GRT enabled to provide File / Folder / Object level restores and one without to enable for full VM restore capability. 

The Backup EXEC 2012 Admin Guide is not clear. (Page 782 and onwards)

My testing has been as follows.

1. GRT Enabled - Full VM restore Failed

2. GRT Disabled - Full VM restore worked

Before I start investigating why the GRT enabled full VM restore failed, I want to be sure it is supported in the first place.

Thanks

Bernie.

Operating Systems:

Comments 4 CommentsJump to latest comment

pkh's picture

You should be able to do a full VM restore even when you enable GRT.  There is no need to run 2 backups, one with GRT on and one with GRT off.  Check the Known Issue section and see whether you are hitting any of the known problems.

SOLUTION
berniebgf's picture

(Edit)

pkh,

Thankyou for the response, I will investigate the issue I am seeing and report back with the results.

Bernie.

berniebgf's picture

Have just tested a new Full backup and the restore has been successfull, I believe the issue was one of the following from the earlier fail.

1. agent patch installed since last full

2. Restore Account did not have privilages for VSphere environment

I'm thinking it was most likely a permissions issue.

Thanks again

Bernie.