Video Screencast Help

BE 2012 PDF report not working

Created: 12 Dec 2013 | 20 comments

When I change the "report format" setting in Backup Exec 2012 from HTML to PDF and try to run any report, I get a largely empty window titled "Symantec Backup Exec Reports" with a minuscule icon showing a white X on black background, and at the bottom three buttons labeled Help, Print, Save As, and Close. Right-clicking the icon offers Select All, Create Link, Add To Favorites, Encoding, Print, Print Preview, Update, and Properties.

Help pops up an Internet Explorer security warning about content from about:internet being blocked, then opens the Windows help viewer displaying "This program cannot display the web page".

Print prints a single page showing the same X icon in a single line border with a header "page 1 of 1" and a footer "file:///C:/Users/Administrator.ARTEGIC/AppData/Local/Temp/2/BEXReport_c5a6d7... 12.12.2013".

Save As pops up a Save As dialog with file type HTML. If I click Save it pops up an error (translated from German): "The index lay outside of the range. It needn't be negative and less than the listing. Parameter name: startIndex" The additional information pane of that error message window contains a longish backtrace which for some strange reason is blocked against copy/paste so I won't cite it in it's entirety here, but the top three function calls are

System.BitConverter.ToInt32
BackupExec.UI.ViewModel.ReportsViewModel.SaveReport
BackupExec.UI.View.ReportViewer.cbSave_Executed

Close, for one, acts as expected, closing the window.

In the context menu, Print Preview displays a page looking much like what Print prints, ie. the X icon with a border, header and footer.

Properties shows the Internet Explorer document icon with the text "not available" and below that, the properties

Protocol: File Protocol
Type: Adobe Acrobat Document
Connection: not encrypted
Zone: Own Computer | Protected Mode: inactive
Address: (URL) file:///C:/Users/Administrator.ARTEGIC/AppData/Loc...
Size: 22641 Bytes

Do PDF reports work at all? If so, what might be the reason for the strange behaviour on my machine?

Thanks,
Tilman

Operating Systems:

Comments 20 CommentsJump to latest comment

Artegic's picture

Faced with the deafening silence here I investigated this problem a bit further on my own. It seems it's "just" a problem with BE2012's report viewer window. If I open the folder embedded in the URL shown in the properties dialog (C:\Users\Administrator.ARTEGIC\AppData\Local\Temp\2, or %TEMP%\2) the PDF report file is there and opens just fine in Adobe Reader. Also, if I click "Save as" and manually change the File Type to "PDF" the report is saved correctly.

Looks like a bug in the report viewer to me.

 

Vishal Shinde's picture

Hello Artegic,

I tried to repro the same issue at my end, however could not do so.

can you please send the screen shot of the error you are getting, additionally, I may like to inform you that my system had only one pdf reader installed, is it the same with you too?

 

Regards,

S

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services

Artegic's picture

Hello Shinde,

I'm attaching screenshots of the window opening after the report has been generated (SBER.png) and of the help window opening after klicking Help and closing the ESC warning on "about:internet" (SBEH.png).

Translations:

- Report window

Title: "Symantec Backup Exec Reports"

Buttons: "Help" "Print" "Save as" "Close"

- Help window

- Buttons: "Fade out" "Previous" "Next" "Back" "Print" "Options"

- Left pane: "Content" "Index" "Search" / "Keyword to search for"

[List of topics omitted - I guess you know them and they are mostly broken German anyway]

- Right pane:
"This program cannot display the website
Most probable causes:
* You have not created a connection with the Internet.
* A problem with the website has occurred.
* The address may possibly contain a typographical error.
Possible way to proceed:
* Check the Internet connection. Visit a different web site to make sure that a connection is established.
* Enter the address again.
* Change to the preceding page.
(v) Further information"

All inapplicable of course. Klicking on the triangle in front of "Further information" has no effect.

Thanks for looking into this.

Happy new year,

Tilman

SBER.png SBEH.png
VJware's picture

What is the version & bit (32-bit or 64-bit) of IE, Adobe & the OS ?

Addtionally, is BE 2012 updated with SP3 ? If yes, have you tried running a repair install of the Report Viewer component ?

Artegic's picture

Windows Server 2008 R2 Standard, Service Pack 1

IE 10.0.9200.16721 (32 Bit)

Adobe Reader 11.0.1

Backup Exec 14.0 Rev. 1798 (64 Bit)

Installed Updates: Service Pack 3

Repair install of the Report Viewer component: haven't tried because I have no idea how to do that. Could you point me to the appropriate manual section or KB entry?

Thanks,
Tilman

VJware's picture

Under Programs & Features, there would be a listing for MS Report Viewer Redistributable. Select this program and choose the option to run a repair.

Lastly, as a test, is it possible to install a 32-bit version of IE 9 and check if this pdf issue reoccurs or not ?

 

Artegic's picture

After running a repair of Report Viewer, nothing changed with PDF reports but trying to run a HTML report (which worked before) now produces an error:

Report could not be executed.
No further information available.
[OK]

 

VJware's picture

This is a generic error and I would recommend to try this KB first - http://www.symantec.com/business/support/index?pag...

If this KB does not help, would recommend to log a formal support case for us to review further.

Artegic's picture

Thanks, Vivek, for your reply. Strangely enough, the "No further information available" problem vanished all by its own, about half an hour after a restart of Backup Exec services. HTML reports now seem to work fine again. So I'm back to the original situation where HTML reports are displayed correctly in the report viewer, but PDF reports only show up as a small black icon with a white X and I have to save them to a file and open in Adobe Reader in order to view them.

VJware's picture

Did PDF reports from within BE ever work ? If it did, were there any updates from IE, Adobe, BE or the OS applied ?

Was Adobe installed prior to installing BE or was it installed laters ?

 

Artegic's picture

Vivek,

thanks a lot for your helpful questions. smiley

PDF reports probably never worked. In fact we never tried them until last December when we encountered the "No further information available" problem with HTML reports for the first time (cf. https://www-secure.symantec.com/connect/forums/rep...) and tried switching to PDF as a stopgap measure.

During my research I noticed that Internet Explorer wasn't able to display PDF files either, so I reapplied "select default PDF application" in the Adobe Reader settings, and now when I paste the file:/// URL from the black icon's properties into Internet Explorer's address field the report displays correctly there. The Backup Exec report viewer's behaviour however is, alas, still unchanged.

Should I try uninstalling and reinstalling Adobe Reader, or perhaps some other PDF viewer?

Thanks,
Tilman

VJware's picture

I have come across few issues such as yours and most were around the inter-compatibility between the OS, browser and the PDF viewer in terms of version, bit..

Reinstalling Adobe would be a good way to start first, though I would first recommend to try using a 32-bit version of IE 9 first and check.

Artegic's picture

Reinstalling Adobe Reader did not help.

I'll try to find out how to downgrade Internet Explorer to version 9 as soon as I find the time.

Artegic's picture

Problem got postponed because of other, more urgent troubles with Backup Exec.

After installing Service Pack 4 for Backup Exec 2012 I tested again but the problem still exists.

CraigV's picture

...you seem to have multiple problems with the software all at once. I'd really recommend opening up a support query with Symantec to get them all sorted out, otherwise you're going to be running around trying to tie them all up.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Artegic's picture

I don't know a way of opening a blanket "sort out all my problems" support case. If I call Symantec support I am asked to state a specific problem which then becomes the topic of the case. I did that already for the two most urgent problems I have. Unfortunately those are both still unresolved. Handling several cases in parallel turned out not to work too well, and there doesn't seem to be a way to merge or extend cases. So for the time being I'm limited to babysitting my two open cases and postponing all other problems until these two have been solved. If you have a better suggestion I'm glad to hear it.

CraigV's picture

...that's the pits. I hope you come right with everything.

Have you joined the BE 2014 Beta yet?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Artegic's picture

Sorry, I don't have the resources (neither machines nor manpower) to do a beta test. I'll wait for the release and in the meantime make do with what I have.

Will keep you posted about my progress on the various fronts.

CraigV's picture

Thanks, and good luck. Not much worse in a backup admin's world than fighting fires on all fronts. Been there & done that!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...