Video Screencast Help

BE 2012 Scan of Tape Drives not working

Created: 29 Jun 2012 | 11 comments

I scan my tape drives with BE 2012 SP1a but it does not recognize new tapes.  I must restort to restarting BE service in order for new tapes to show up.  One result of this is BE2012 will incorrectly report which tape a job was written to.

Comments 11 CommentsJump to latest comment

ZeRoC00L's picture

What kind of tape device are you using, and is it listed in the HCL of BE 2012 ?

http://www.symantec.com/business/support/index?page=content&id=TECH175582

If this response answers your concern, please mark it as a "solution"

fowljewl's picture

Dell PowerVault 124T with LTO3-60 Quantum is listed on the HCL. 

David Palmerston's picture

fowljewl -

We are beginning some investigation of which tapes are being used for backups as we have seen some confusion in our records. 

We are finding interesting information on our system regarding which of the Identifiers for Tape Media are actually being used and displayed by BE2012.  We are using a 2-drive Dell TL2000 with 2-LT05 drives.

Within BE2012, we see at least the following related to each tape cartridge:

Media Label

Media Description

Media ID

Media GUID

Media Used

When a cartridge is loaded into a drive, the Storage tab shows "Tape Drive 0001 (some label)" - what is that number?

And, on the cartridges themselves we have the barcode label.

Before today we have never manually changed a media label, but yesterday we had 2 tapes in our slots with the same Media Label 000036L5 but with different Media ID (Media GUID).

I'm looking for some acknowledgement of how the 6 different "Names" for a single tape cartridge relates to actually what resides on a particular cartridge according to BE2012 records..  If I'm looking in BE2012 to restore something (and it is not loaded) which number would be used to identify the cartridge that I would need to load?

 

 

Biker_Dude's picture

fowljewl,

How are you getting the new media in to the tape library?

How are you scanning the new media once it is in the tape library?

Please list the exact steps for both.

fowljewl's picture

Eject entire tape cartridge

Insert all tapes

Insert entire tape cartridge

Right-click the Robotic library 0001

Click scan 

Also try clicking scan on each individual tape slot

 

Does not detect any of the new tapes or tapes and still shows tapes that are no longer in the system.

I then restart all services but do not select to Enable the deduplication services to be started or stopped.

It still does not read the tapes correctly. 

I have even reinstalled SP1a, rebooted the server but it does does not recognize new tapes.

 

Dazz42's picture

I'm having a scanning issue as well.

When I put tapes in the library and then do a scan they dont show up and the scan does not seem to run.

For example, if prompted for a library insert to finish a job I put a tape in the partion of the library that needs it and try and scan but I cannot get it to show up in the slots so the job can continue.

If I cancel the job it then shows up almost immediately which seems to mean that the job or the alert is stopping the scan working.

Another thing to add is that this issues only seems to happen when an alert is there.

If a job is running normally you can run the scan job and it works but when there is an "insert overwritable media" alert present it will not run on any partition.

Any ideas?

 

Thanks

Larry Fine's picture

Are you trying to run a Scan job while other jobs are running?  If so, the Scan job is probably sitting queued and isn't actually running yet.  This is different in BE 2012 than in previous versions.  In BE 2012, the Scan is an actual job.  Previously it was something magical that happened in the background immediately upon request.

Does the job log for the scan job show the correct media in the slots?

If you find this is a solution for the thread, please mark it as such.

Dazz42's picture

Thanks for the reply Larry.

There are jobs running but this wasn't an issue with BE2010, as you say, and the scan job just ran and once you responded to the alert the job carried on.

If in 2012 it's a job in the queue, how do you insert new media into the library and scan it, if the job needing it is essentially stopping the scan running?  Do we have to wait until a drive becomes available to do the scan? That would mean that the drive could be tied up for hours doing nothing,waiting for the other drive to become free to do the scan. That doesn't seem right to me.

As far as the scanning goes the right media is reported once the job runs so that's not really an issue.

FYI we have a HP MSL 4048 with 3 partitions with two LTO4 drives

Larry Fine's picture

re: If in 2012 it's a job in the queue, how do you insert new media into the library and scan it

I have worked around this issue by running an import job, as it will run immediately.

If you find this is a solution for the thread, please mark it as such.

Dazz42's picture

Thanks Larry, it does work but surely the same process in 2010 should have worked in the next version ?

Anyhow, I'll move on to the next issue with 2012 now I have a workaround for this one.

It is bizarre that we are working with a lot of workarounds with this new version. They should almost have just renamed the product and relaunched it as something else as some things just dont work the same way they did before. In an upgrade it is not unreasonable to expect something as basic as this to do the same thing in the same way in both versions.

Anyhow, thanks again  :)

Colin Weaver's picture

Symantec are officially researching an issue with the scan job not running if other activities are accessing the tape drives.

 

Acknowledgement here

http://www.symantec.com/docs/TECH192576