Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE Archive Option ArchiveIndex rebuild?

Created: 25 Jun 2013 • Updated: 27 Aug 2013 | 3 comments
This issue has been solved. See solution.

I am running BE 2010R3 with the Archive Option (for file system and mailbox archive) installed and configured.  Everything was running fine until I had a user who was unable to locate an archive email in their vault.  Troubleshooting revealed that there was a gap of missing messages.  I confirmed that the actual messages were archived OK.  I discovered that the timeframe of the missing messages coincided with a drive that had filled up to capacity - the same drive that contained the ArchiveIndex.

I had since moved the ArchiveIndex to a larger partition.  However, the "damage was done".  I discovered the 'indexcheck.exe' untility, and used it to verify the problem - that the items were missing from the index.  Running the utility with the -c MissingContent option produced the expected result.  During a maintenance window this weekend, I worked to rebuild the index and resolve the problem. 

After bringing down all the EV serivices, and creating a backup of the ArchiveIndex directory, I then removed all the 'ind_*' files.  I then ran 'indexcheck.exe' with the -c exist command, and specified a .csv file for output (which, I would then use with the -rebuild command).  While the command was running, I observed the output in the command window and could see that it was correctly identifying the missing documents/content.  The command created the .csv file - but did NOT populate it with ANY entries!  Therefore, I'm unable to run the -rebuild command.  It seems like the -c exist option is working correctly, but is not populating the .csv file.

I ended up having to restore my backup.

Is this possibly some result of this being the "watered down" version of Enterprise Vault?  Is there someway for me to rebuild the index?  I posted this in BackupExec instead of Enterprise Vault, since this is the Archive Option in BE I'm working with.  Most of the documentation I've found regarding index troubleshooting/rebuild points toward the use of the 'indexcheck.exe' command from EV support forums and pages.  But, I'm guessing that not all of that documentation would apply to the Archive Option within BE.

 

Operating Systems:

Comments 3 CommentsJump to latest comment

teiva-boy's picture

Tis true that the EV engine is watered down for BackupExec. I think it's EV8 under the hood?  

Sadly, you will have to call into support, get into level 3 or higher support to troubleshoot.  I'd open a web ticket, then call and ask for a duty manager for escalation.  Or you'll sit with a Level 1 tech that wil ask you to restart services and servers...

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

SOLUTION
lmosla's picture

With this issue tevia-boy is absolutely right. It's best to cut to the chase and get help from engineers trained in troubleshooting EV. Here is a link for Technical Support Online Case Creation.

mpare's picture

Thanks for the quick reply folks!  I'll give that route a go.