Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

BE Services Credentials Lost on Every Reboot / W2008.R2

Created: 10 Jul 2014 • Updated: 14 Jul 2014 | 8 comments
This issue has been solved. See solution.

I have two Backup Exec Servers on Windows 2008 R2 platform. Both are facing same problem that on every reboot of the server, BE Services credentials lost and BE services failed to start dueto logon Error. I have tried following but no results.

  • - Set BE services to use local system account, it works fine, but on reboot, same logon failure issue occurs
  • - Set BE services to use Domain Admin account, it works fine , but on reboot, same logon failure issue occurs
  • - I have tried changing the credentials using BE Utility, it works fine, but on reboot, same logon failure issue occurs

I have verified domain admin account is active and working fine for other operations. Only BE services are having issues.

 

Operating Systems:

Comments 8 CommentsJump to latest comment

Colin Weaver's picture

The link between services and their startup credentials is maintained by the operating system, not the Backup Exec software

As such have you got any odd group policies or security products installed that have locked the services to the accounts that were active at the time they were configured?

Or have you got something that recorded a specific state of the server and always returns that state on reboot enabled?

aacable's picture

Both BE servers are member of W2008R2 Active Directory Domain, with no custom policies implemented, no account lockout is configured no security policy is in place at a moment, just a plain AD environment.

There are other few other services in this box, like Veeam, and few other which uses the same domain account and they are starting automatically.

 

 

Colin Weaver's picture

So after the reboot and the faulure what steps do you take to fix the condition?

 

If you just start the services again then it is probably just an environmental timing issue and you may need to set a delayed start on all of the BE services (An operating system setting)

 

If you actually have to edit the logon account on the service then this would be an Operating System issue as I previously mentioned.

aacable's picture

on reboot, when I try to start the BE services, it show 'service fail to start dueto logon failure'

To fix the issue on every reboot, I have to enter the password again in windows services (or be console manage services), and then services start fine. but on next reboot, i have to repeat the steps otherwise BE services don't start.

Colin Weaver's picture

OK so that confirms it is the operating system (or some other piece of software on the operating system) blocking the credentials correction and it is not specifically an issue with Backup Exec.

Chatting with immediate colleagues we are unable to come up with anything within BE that would cause this

You might need therefore to talk to Microsoft about what would deny the ability of the operating system to maintain the correct credentials against a service when set uisng their services applet.

 

Out of intesrest is it only a full reboot that causes it, if you  fix the issue and maybe a few days later try to restart all the BE services do they restart OK?

 

C.

aacable's picture

Thank you for follow up. I do appreciate it.

Usually a full reboot causes the issue. once server is reboot and i re-enter the credentials in be services, it works fine, and i can again restart the services without any issue, only reboot cause poblems.

Since both servers are in live environemnt, so its hard to reboot them manually,

I will try it in some test vm box & will post updates and findings here .

Lothar Müller's picture

Hello aacable

I have seen this issue if my AD has Group Policys where security options are set.

Then it is no issue with password, but with User rights of Exec Service Account.

If you type in password in the services.msc windows server sets the correct security options (start as service) for the user account you typed in and the services will start.

After the reboot the the group policys overwrite the options.

 

If you can reproduce this by running "gpupdate /force" and restarting services, I think this is your issue.

 

To resolve this issue you have to set the correct settings in your group policys for your BE Service Account.

http://www.symantec.com/docs/TECH36718

I have read your post that you habe no costum policys but I think you should double check it.

I habe seen it very often and in many clean enviroments.

If this helped you to solve your problem, please mark this post as solution for this case.

SOLUTION
aacable's picture

Solved !

in my domain controller default policy, I followed below guide and added my account in respective category as required and now BE startign auto on reboot...

http://www.symantec.com/business/support/index?pag...