Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE2010 Cataloged tape, zero errors log has files but can't restore

Created: 07 Aug 2014 • Updated: 08 Aug 2014 | 11 comments
This issue has been solved. See solution.

It's a cliche but I've never EVER had issues restoring before.  I have one particular tape that I did an archive backup (i.e. backup, verify, then delete)

The tape had no errors, zero.The job completed some weeks ago with again (no errors)  I went to do a restore on some of the files and got the "the selected media was not found in the catalogs".

So I inventoried the tape. Then I Cataloged the tape and an 1:02 hours later the logs say

Byte count             : 327,531,951,757 bytes
Rate                   : 5,154.00 MB/Min
Files                  : 98,759
Directories            : 7,943
Skipped files          : 0
Corrupt files          : 0
Files in use           : 0  and I try to restore again and get the same "no catalog message.

After this I shut down BE services, renamed the catalog directory, turned off "use storage based media catalogs" and 1:06 hours later again got

the above "success" and 327 gb.

but THE RESTORE DOESN'T FIND ANYTHING.  I get to the server, drive letter, share and no files.

If I had a tape error this would make sense.  This makes NO sense and I'm totally stuck.

 

Did I miss something.   Otherwise there's 327 gb of data on one tape that sits and looks at me but I can't get to.

 

Operating Systems:

Comments 11 CommentsJump to latest comment

CraigV's picture

...is the date range correct in the restore window?

THanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

Go to the Media tab, right-click on the tape and select restore.

SOLUTION
jstrowe's picture

Did that, same results.  It indicates that the media is not cataloged right after I have a finished catalog job for that very tape.

 

(Not to be questioning? but does right click do something to bypass the media not having a catalog)  I'd started by right clicking on each tape in turn after I didn't see the media in job setup/restore and the servers they covered were not listed.

 

I blew away the catalogs moved to a larger disk drive and am trying the whole thing all over again.  You kmow if it's disk space I'm goiing to be annoyed since a "your'e out of disk space" would be an error message I'd at leas tknow what to do with.

 

So i'm rerunning catalogs on a much bigger partition.. hope it works.  If it doesn't I have a really huge issue.

pkh's picture

Sometimes the backup set does not appear in the restore list.  When you right-click on the media, you would be able to see the backup set on the media and then do a restore straight from the media.

SOLUTION
jstrowe's picture

So the solutions seemed to be disk space among all.  The symptom is that the catalogs seem to write correctly, show no errors at all but then right clicking on a tape saying "restore" the catalog can't be found.

 

In hindsight earlier versions of BE would throw odd errors for catalogs when disk space was low.  I didn't even think of disk space since my server had 10 gb free and the catalogs would seemingly generate with no errors.

 

If I'd HAD an error or the catalogs hadn't worked in my logs I might not have been thrown off (for disk space)

 

I do wish this version of BE had thrown some kind of error since as I keep beating the drum on, :THE CATALOGS threw no errors at all.  They would say 654,000 files found (or whatever the number was) and 300 gb of data.  i.e. the catalogs looked perfect.  

The overall symptom ended up being continuing messages of "inventory and catalog the tape" errors when trying to restore.

Your work around of right clicking on the tape in the all media view I'd swear didn't work last night but worked this morning.  (so either I did it wrong last night... distinctly possible since I was rattled all to heck) or having more disk space helped... I don't know.

 

But I'm restoring this tape to an alternate location then I'm going to get what I need and back it kup again to a different tape.

 

Craig, not to be snarky on the disk space (another post) I do maintain that earlier versions of BE threw errors if they were unhappy about disk space and having 11 gb free sure as heck didn't seem like inadequate space.

CraigV's picture

...warning of disk space would be a function of Windows, and not really BE.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

jstrowe's picture

In that instance I don't agree.  (not that it matters LOL) but if a BE function fails or acts erratically there are plenty of ways to have an error trap on disk space.  I wouldn't expect that 11 gb of free space would be an issue but since I moved the catalogs to a 1tb drive and the problem disappears (or it's disappearing) it is space.

 

So Craig I don't agree.  This should have been a function of the catalog if it was having trouble writing.  It doesn't matter since this programs legacy anyway.

jstrowe's picture

OH my... went to the media tab after re-doing most of the catalogs and it worked.

So as I pick my mouth up off the floor (LOL.. it kind of hurts down there)  I would love to know why and how that worked.

 

i.e. when I go to the library I have right click on the tape and say restore I get a catalog not found error and when I go to the media view of all tapes and right click I have data.

 

That's pretty strange.  

SOLUTION
Artegic's picture

Hate to say that, but it's probably time to open a support call with Symantec.

jstrowe's picture

Heh heh, if stuff doesn't work Artegic that's good advice.  I have moved to more disk space and things seem to be getting better.