Video Screencast Help

BE2010 - Exchange Backup fails: Error occured while creating or accessing a directory.

Created: 22 Apr 2010 • Updated: 29 Sep 2010 | 51 comments
This issue has been solved. See solution.

Hey guys,

Im having trouble with our Exchange Backup (GRT Enabled) running on BE2010 rev 2896.
The job can run fine for a few days, then it fails with the following error:
 
Final error: 0xe0001203 - An error occurred while creating or accessing the directory specified for this operation. Check to make sure that the B2D folder and/or the temporary path specified for this operation are valid.
Final error category: Resource Errors
 
V-79-57344-4611 - An error occurred creating or accessing the directory \\.pdvfs\<BE-SERVERNAME>\2\BEData specified for this operation. Ensure that the directory is accessible and can be written to.
 
I am backing up three servers, and it fails on all of them. The errorlog provides a link, but that only refers to a restore problem. It also states that the problem was fixed in BE v12.
I have checked that all temp-folders exist and can be reached. The backup destination is a dedupe folder on a iscsi san. But i can browse through the iscsi disk without problems.
I've tried to both disable/enable the b2d folder, and restarted the BE server.

Any ideas where the problem lays?

Comments 51 CommentsJump to latest comment

Martin_Forster's picture

HI i have the same problem for all grt based backups to the deduplication folder.
However they work flawless to a traditioinal B2D Folder.
In my case the failure seems to occur after the first try to duplicate the data to tape.

I have a open case with symantec for that issue.

Regards

dominikD's picture

exactly the same problem here for all grt based backups to the deduplication folder. Did you get an answer from symantec?

Rune Skøien's picture

Event viewer shows the following:

Event ID: 50000
Source: PDVFS
Level: Error

An error occurred in the PDVFS driver: <ERR> PdvfsGetDsidNTAclStr: pdvfs_get_nt_sdo_str for /<BE-SERVERNAME>/2/BEData/IMG000423/esent.dll failed

Martin_Forster's picture

i have a different failure:
An error occurred in the PDVFS driver: <ERR> PdvfsOpendir: failed errno=2

my call was transferred to the 2nd level support 1,5 hours ago, im waiting for my callback.

CraigV's picture

I would suggest with starting to troubleshoot by upgrading to the latest patches. Once done try the backup job again...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Rune Skøien's picture

Sorry for late feedback. I havent gotten any closer to the solution. There seems to be so much errors, that im giving up using dedupe. Restores failes 80% of the time, and backup works ok for a few days before the errors occurs.

I have a 8tb iscsi san for backup, but i think i'll go back to using regular b2d folders. Maybe the dedupe will function better later, after a few updates :-)

Im checking for new updates in BE every day, so my system is up to date. I have also reinstalled the entire system, but still all errors appear.

ruddj's picture

We are experincing the same problem. Backups Windows shares fines, but constantly fails on Exchange backups to GRT.

V-79-57344-4611 - An error occurred creating or accessing the directory \\.pdvfs\Backup\2\BEData specified for this operation. Ensure that the directory is accessible and can be written to.

It also floods the event log with: An error occurred in the PDVFS driver: <ERR> PdvfsOpendir: failed errno=2
Often getting around 5 posts / minute

Please let us know if you get it working.

Martin_Forster's picture

Hi,

after speaking to a duty manager i managed to get hold of a technican .
My call was stalled in America for a week. No answers, to email and voicemail.

However this technican confirmed two bugs which i experience.

GRT to Dedupe doesnt work.
Dedupe creates to may empty OST---- Medias. ( i have around 15000 of them )
a file restore from dedupe fails. When you disable the fast restore feature in the registry, it works, but it took me nearly 3 hours for 10KB file.

But a hotfix has already passed testing, and is now in the packaging phase, so stay tuned, he will hopefully arrive shortly.

Regards

maho's picture

It solves a lot of dedup issues for BE. I do not believe it is posted to Live Update yet, but you can get it from here: http://support.veritas.com/docs/348518

Regards

T35216's picture

Hi All,
I have also installed the Hotfix and no  joy, I suspect the issue is with the combination of dedupe and GRT, my GRT jobs are stalling when running to a dedupe storage folder on an ISCSI device.  Just before the job runs into trouble I note the job status is "loading media" .  The server is a dual quad core box with 8GB of Ram.  But the intensive processing going on between the spoold process is really kicking the crap out of the box.   I suspect this is a known issue and once again we have become the R&D department.
Can someone from Symantec comment here please?

maqjack's picture

Hi All,

Even i have the same issue for which i have not got any solution so far after rasing the ticket with symantec for more than 15-20 days.

Even though the server is up to date in terms of Symantec BackupExec all the three latest HF

348284
348518
348215

So far there is lot of R & D which has already done. The backup works for the firs time after a reboot of the server for Exchange and AD with GRT.

After the first backup is finshed, at the next schedule the backup fails with the following error.

An error occurred while creating or accessing the directory specified for this operation. Check to make sure that the B2D folder and/or the temporary path specified for this operation are valid.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-4611

When backup has configured with De-Duplication device why is it showing B2D Device error.

There is some issue with the PDVFS where i get lot of error in the event viewer

Source: PDVFS
Event ID 50000

I any one gets the solution kindly update

Thanks

Maqjack
 

Martin_Forster's picture

Hello Folks,

recently a update was published to liveupdate with the number 348518.
with this update and a complete remove and recreate of the dedupe store i archived a good success so far.
i have done 1 full and 2 Workset backups of my file server.
and 3 full backups of my exchange Information Store and Active Directory with GRT enabled.

I have done parrallel GRT and non GRT Backups to the dedupe store successfully.
I haven't got thousand of empty OST medias so far.
Im able to do email restores from the dedupe device.
However file restores from the dedupe device still need the Fast File Restore set to 0, and took very long to complete.
With fast file Restore 1 i got the error
An unknown error occurred on device "B2D_Dedupe:2". V-79-57344-34029 - A hardware error occurred.

Kind Regards

Martin_Forster's picture

hi sorry,

but it worked only one time.
After the 2nd Backup i got the
An error occurred in the PDVFS driver: <ERR> PdvfsOpendir: failed errno=2

error again ....

FischerRoman's picture

we have the same issues here, after applying all recent hotfixes.

also the dedup store went currupt again last friday night, support got tons of logfiles (including dedup logs) - but no reply yet.
even after some escalations to the duty manager by symantec austria sales.

i'll keep you up to date with this, when we get a solution/workaround/hotfix..

CraigV's picture

Hi,

If any of this has helped, can you close it off please?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

joup's picture

I don't think this is fixed, been struggeling with the same problems for weeks.

My server-side GRT backups fails almost everytime with different errors and usually ALOT of events like this in the event log (like 30 every minute until I reboot server)

Log Name:      Application
Source:        PDVFS
Date:          2010-06-01 09:16:57
Event ID:      50000
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      backupserver.domain.local
Description:
An error occurred in the PDVFS driver: <ERR> PdvfsOpendir: failed errno=2

Errors I get from Backup Exec 2010 when the jobs fails are usually like

"V-79-57344-33858 - A memory allocation request failed. The computer may be running low on virtual memory."

OR

"V-79-57344-4611 - An error occurred creating or accessing the directory \\.pdvfs\BACKUPSERVER\2\BEData specified for this operation. Ensure that the directory is accessible and can be written to."  

If I reboot the backup server, I can usually get one or two GTR-backups through successfully, and then the same error starts again. The only thing the lastest hotfix seems to have fixed is that there is not longer creating tons and tons of "empty media" in the deduplication volume. But the errors still exists.

Normal file backup and SQL backup works fine to the deduplication folder. It's only GRT that throws these errors (Active Directory and Exchange 2007 SP2).

Got my Backup Exec 2010 with all availble patches running on a Windows Server 2008 SP2 x64 with 8 GBs of RAM and about 2,5 TB deduplication data (ISCSI).

Gavin Tam's picture

Can someone from Symantec support reply on this??!?

We want to know when will the hot-fix for this issue will be released.

Our environment is to backup Exchange 2010, AD on Windows 2008 R2 to Dedup folder with GRT enabled. This PDVFS error will be generated in hunderd throusands times in system event logs during backup. Backup server is having 16GB memory, and dedup folder has about 2TB.

Already applied latest patches.....

CraigV's picture

I have escalated to support...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Swathi Turlapaty's picture

I've had support look into the issue who responded that it could be an Exchange / dedup issue as the backup works to B2D. Hence their suggestion is to call into support and log a case. Thanks!

Swathi Turlapaty's picture

Also, please make sure to comeback and update this thread with the Solution provided to you by Support. Thanks!

djlaube's picture

I'm joining the thread as well. I have the exact same problems as outlined above with the same symptoms, even the same error messages when running backups. I'm sitting on hold with Symantec support as we speak.

Gavin Tam's picture

Does anyone have feedback from support? Any tentative schedule for Hot fix? Any workaround or solution?

The deduplication folder cannot be used for months already....

Simon B.'s picture

same problem

PMCS GmbH & Co. KG - Consulting und Support für BE/NBU/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!

Gavin Tam's picture

Upgraded to BE2010 R2. Recreate De-duplication folder. Backup is fine for 3 days till now. Hope this help!

Ged's picture

Ugrading to BE2010 R2 hasn't worked for me, re-created dedupe folder ran a exchange 2010 GRT backup worked, then the third time failed with the usual error.
Only way I have found to ensure it works is to restart the postgres & deduplication engine services before a backup in a backup pre-command script, or a server restart, not really an ideal solution.
The only reason we got BE 2010 was for exchange 2010 and the dedupe, it would be nice if it would go for a few weeks without failing and having to go searching for fixes.
Ged

FischerRoman's picture

Hi Ged,
thanks for sharing your experience with R2!

Funny thing is, that I considered upgrading from 2010 to R2 next few weeks because of the "hopefully fixed" DeDup issues.
I think I'll wait a bit longer.....
Roman

alexff's picture

I have the same issue in this thread. 

Here's my experience with the deduplication.  After applying all the current hot fixes I deleted and re-created the deduplication folder.  This seems to have stabilized things a bit as most backups are successfully.  However, periodically I do get a job that is done, but never finishes.....just sits there and I have to restart all the services to get it cleared.

Dejan R's picture

Couple of weeks ago it stacked for hours; I’ve had to restart the services in order to cancel the job.

Yesterday the job failed with the following error on verify: V-79-57344-33991. For which I can’t find any explanation for dedupe media, only for tape.

I’ll try with R2 update, but I think that Symantec needs to take dedupe issues more seriously instead of luring us with shiny promises …
Don’t get me wrong, we are successfully using a whole bunch of other BE solutions.

timlh's picture

I'm having the same problem, every couple of weeks:  Deleting and recreating the DeDup device breathes life back into it, but only for a while

Dextertronic's picture

We have given up on Dedupe after two months of working with Symantec Support (or trying to work with Symantec Support).

This is what you can kiss goodbye if you want to run Dedupe Option:

  1. Restore a file from DFS (in less than the time it took to run the original backup)
  2. Incremental Exchange Backup
  3. Virtual Machine Backup using VSPhere API

First two are confirmed bugs according to Symantec Support.

The third no one wants to talk about.

But if you go back to Disk to Disk with no Dedupe it all works!.

This is before and after R2.

Just want my money back.

BE_ADMIN2010's picture

I cant agree more, deduplication is a NIGHTMARE. How can Symantec market software that straight up...doesnt work???

I have now reverted back to B2D for exchange as it is my only hope of GRT based backups. All this money for a juiced up version of 12.5 with broken features....

Come on Symantec!

Gavin Tam's picture

No Luck!!!

Three months has spent on troubleshooting with Symantec Support from Level1 to Dev. team. It is still no luck....

 

 

CraigV's picture

...anybody with this issue upgraded to BE 2010 R2? It is supposed to fix a lot of the issues experienced with Dedupe...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Robert Cullen's picture

I have exactly the same problem and my event viewer is stuffed with

An error occurred in the PDVFS driver: <ERR> PdvfsOpendir: failed errno=2

Robert Cullen's picture

I think I've found a solution to this issue.

It turns out that I needed to configure the BE Agent on my vSphere Centre server as a Deduplication server. The option is under Devices, right click the backup media server and select Configure Remote Agent for Deduplication.

After configuring this and restarting the services I can successfully backup. I guess only time will tell if this is the resolution to the issue but so far so good.

SOLUTION
CraigV's picture

You would simply click the MARK AS SOLUTION button...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

CraigV's picture

Was yours the fix, or did anybody point you int he right direction?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Robert Cullen's picture

Plodded through myself and stumbled across it by accident after trying a million and one things.

A dialogue popped up after I created a new job that asked if I wanted to configure the agent for DD. I said yes, not really knowing what it had done. After checking the Devices I noticed the new server listed.

It still didn't work however, until all services had been restarted.

I've just successfully backed up all my VMs including Exchange 2010 R2 and AD servers.

CraigV's picture

...congrats, then the solution is yours. I just marked it for you.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Ged's picture

Unfortunately this is not a solution if you have an Exchange 2010 DAG as you can't use client dedupe it has to be backup server based, try it and it will prompt you to change it back.

Effectively this means dedupe is still buggy and unuseable for a large propertion of Exchange users.

G

Robert Cullen's picture

Agreed. I need to hand the solution back.

There is a problem with this and the only way to ensure reliable backups is to avoid GRT. I now have an open support case which is being investigated. I'll post an update as soon as I hear anything.

gerry14081982's picture

Having the same Problem with BE2010 R2 and installed HF358289. Tried all tasks posted above without result.

Only recreating DeDup or/and restarting BE-Services seams to work for a few days but thats no solution.

JonesieC's picture

Hi All,

 

We've recently purchased a complete solution from Dell. Have had issues which have actually got worse since upgrading to BE2010 R2. We not get a stop error at least once a day with a vast number of entries in the event log as per this port: PDVFS Error 5000.

 

Anyone else got anything else to try? We've had DeDupe recreated. We have hotfixes applied (Though I would have expected R2 to have had this included!!

 

Onward we tread..............

CraigV's picture

Hi Jonesie,

 

Please open up a new forum query about this...

 

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...