Video Screencast Help

BE2010: Slow B2D performance when Vmware Granular backup is disabled

Created: 18 May 2010 | 4 comments

We are evaluating Backup Exec for Vmware image backup purposes and compared to other backup products like Veeam and VCB we notice it's considerable slower. We're placing backups on a Netgear nas device, and as explained in this doc, http://seer.entsupport.symantec.com/docs/348139.htm we have to disabled granular backups.

When we first tried backing up a vm, it went ok with acceptable speeds at 1600MB/Min., but then after doing 30Gigs of backup it failed. The problem was related to Netgear/Granular backups, so we turned off Granular backups. After doing this, the data rate dropped to apx. 600MB/Min. The backup server is a fast 2*3Ghz Enterprise class server and it is also a dedicated backup server with no other tasks. We tried the backups with both Software compression on and off, and the rate dropped to apx. 500MB/Min with it turned on. The CPUs were operating with 10-15% load with compression on.

The Netgear nas is not fragmented and contains very little data. We're connected with Gbit uplinks and the network datarate is good. Both Veeam and VCBMounter.exe backups run apx. 3 times faster than Backup Exec under the same working conditions. We're at or above ESX Enterprise 3.5U2, so Backup Exec 2010 should use the Vstorage API's implemented. Liveupdate have also updated all updates available. Symantec B2DTest tool reports the volume as fit for backups.

Soon we will upgrade to Vi4 and we also recently did upgrade to Vcenter4.

An Off-Topic problem I also noticed was that when choosing the Vcenter server under the backup selection list, all vm's do not show up. This is not good when vmotion is running.

How can we have granular backups disabled and still do backups with an acceptable data-rate ?

Do Backup Exec 2010 still have the possibility to use VCB, and can it be forcibly selected ?

Comments 4 CommentsJump to latest comment

sazz.'s picture

Make sure you have the aofo option disabled in the backup job.Also can you try the backup destination as some other B2D folder instead of NAS to find out if it is an issue with the NAS with Backup Exec.
On the vmware tabe you can disable the GRT option.
With 2010 we can't use the vcb as it uses its own apis.

Progressor's picture

Aofo ? Does a Aofo client for vmfs volumes exist ? I was unaware of that. It's not installed or configured.

I'm only using the vmware option. NBD is choosen for transport.

Tests reveal that backups to local disk is just as painfully slow as to the Netgear nas device.

Granular tab is not checked, so it's completely disabled. If I could, I would enable it to boost performance.

Also We have done the tests with Granuar disabled on 2 different installations of both backup exec and vmware ESX.. The other installation use local SAS 15K disks for storing B2D. The poor performing results are the same when granular bakups are disabled.

I believe the problem lies within granular backup being disabled, and that Symantec have a limitation or bug with resulting poor performance regarding this specific setup.

CraigV's picture

Hi progressor,

Have you looked into updating BE 2010 with the latest patches?
With vSphere 4 installed, you're able to do incremental backups of VMs, making your backups faster...doesn't solve things currently, so try updating and pushing any RAWS agents out before doing another backup.

Laters!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Progressor's picture

Yes, I did mention Liveupdate had done all updates.

We do not want any clients. All we want is image backup, run once a week. I do however see that this could be useful for others.