Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

BE2010 / VMware Agent: Backups get slower the longer a job runs

Created: 26 Feb 2010 • Updated: 05 Oct 2010 | 3 comments

Hi

I've noted this very odd behaviour of BE2010's VMware Agent. I'm backing up VMs via the 'san' mode (from our EMC SAN) to another Disk Drive and my jobs usually start off with fabulous speeds at around 3500MB/min.

However, the longer the job takes, the slower the speed gets. The speed gets "resetted" once the backup of one VM (or I believe even a Harddisk of a VM) is done. It seems like for every vmdk-file, the backup rate starts off being very fast, and then gets constantly slower until the disk is fully backed up. Also, the CPU load gets higher and higher on the BE Server the longer the backup jobs runs.

This is hardly noticable on smaller VMs (up to 100GB disks)... However, we have a file-server with a 1TB VMDK... speeds start off at 3500MB/min, and towards the end, the speed is down to 150MB/min (not on average, but the Byte Count just clocks up about 12MB every 5 seconds, so do the math), with beremote.exe using up once processor completely.

The BE-Server is a HP Proliant DL380 G4 with two Xeon 3.6GHz (Hyperthreading, but no mulicores). The target device is a regular B2D Folder (not a dedupe store).

The issue obviously has something to do with the vmware agent, as regular backups via the windows agent of the same VM start off slower, but are being backed up at a constant speed of 800MB/min.

I read in the VMware forums that this might be because VCB (which is not used by Backup Exec 2010 with vSphere and not installed, but I guess the behaviour is still the same with the VMware StorageAPI) uses a compression per default, which would explain the slower backup rates and the higher cpu load the longer the job lasts. Via VCB, it is possible to disable this compression. I could not find any option in BE2010 for this though, except of disabling the compression at the job level (which i did, but it did not change my backup speeds).

Is anyone else having this problem? Do you have a workaround or solution?

Thanks and best regards,
fiNal

Comments 3 CommentsJump to latest comment

Trevor Eyte's picture

I'm having similar issues with 2010 and VM backups.

If I run a test B2D job of two small VMDK's (8GB each), I get speeds up around 6-6.5GB/min. If I then add one more VMDK of say 20GB and put it at the top of the resource order, speed will start off great and then slowly decrease. The weird part is, if I put the small VMDK's first, the speed improves until it hits the larger VMDK, and once it hits the larger VMDK it never picks up speed again.

I'm totally stumped.

Trevor Eyte's picture

After some more research, my problem may be slightly different.

I've found that thin-provisioned disks that are only using (for example) 40-50% of the total disk capacity take longer to back up than either a thin-provisioned disk that is near capacity or a thick-provisioned disk.

As it turns out, when a thin disk is backed up, Backup Exec reports that it backed up the entire maximum capacity of the disk, whereas with a thick disk, it only backs up the space that has been used!

So a 20GB thin disk that is at 50% capacity will report as being 20GB in Backup Exec, but a thick disk with the same characterisitcs will report as 10GB in Backup Exec.

I wonder if this is a Backup Exec "feature" or a vStorage API "feature"...?

fiNal's picture

my issue was solved with a faster CPU. Since I'm running BE2010 on an Nehalem Xeon, the speed does not drop anymore.